summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-08-17 16:39:34 -0700
committerTom Rini <tom_rini@mentor.com>2010-08-17 16:42:19 -0700
commit298a48ca78b3b907fd4f6fdf71b4e8e7e7b922b1 (patch)
tree2b25c1372a5ada1bdc41a53e05cc124405e4a9ea /recipes
parentb2c2771ddc0e5ddc307999a9a63c5bade88d5956 (diff)
downloadopenembedded-298a48ca78b3b907fd4f6fdf71b4e8e7e7b922b1.tar.gz
quilt-native: Provide a new do_install based on the target one.
As seen in quilt-package.inc we need to pass 'BUILD_ROOT=${D}' to have things installed where we want. Otherwise we end up with legacy staging (and empty pstaging packages). Switch to INC_PR Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/quilt/quilt-native.inc4
-rw-r--r--recipes/quilt/quilt-native_0.48.bb2
-rw-r--r--recipes/quilt/quilt.inc1
-rw-r--r--recipes/quilt/quilt_0.48.bb2
4 files changed, 7 insertions, 2 deletions
diff --git a/recipes/quilt/quilt-native.inc b/recipes/quilt/quilt-native.inc
index 10d81835c3..1306b1f87a 100644
--- a/recipes/quilt/quilt-native.inc
+++ b/recipes/quilt/quilt-native.inc
@@ -15,6 +15,10 @@ do_configure () {
oe_runconf
}
+do_install () {
+ oe_runmake 'BUILD_ROOT=${D}' install
+}
+
do_test() {
oe_runmake check
}
diff --git a/recipes/quilt/quilt-native_0.48.bb b/recipes/quilt/quilt-native_0.48.bb
index b180e58b9b..efb37ca8a0 100644
--- a/recipes/quilt/quilt-native_0.48.bb
+++ b/recipes/quilt/quilt-native_0.48.bb
@@ -1,6 +1,6 @@
require quilt-native.inc
-PR="r4"
+PR = "${INC_PR}"
SRC_URI_append = "file://fix_new_GNU_patch_detection.patch"
diff --git a/recipes/quilt/quilt.inc b/recipes/quilt/quilt.inc
index a9ed163bf6..ac657fb433 100644
--- a/recipes/quilt/quilt.inc
+++ b/recipes/quilt/quilt.inc
@@ -2,6 +2,7 @@ DESCRIPTION = "Tool to work with series of patches."
HOMEPAGE = "http://savannah.nongnu.org/projects/quilt/"
SECTION = "devel"
LICENSE = "GPL"
+INC_PR = "r5"
SRC_URI = "http://download.savannah.gnu.org/releases/quilt/quilt-${PV}.tar.gz \
file://install.patch \
diff --git a/recipes/quilt/quilt_0.48.bb b/recipes/quilt/quilt_0.48.bb
index 0a066dfcc0..3a6fd4b1dc 100644
--- a/recipes/quilt/quilt_0.48.bb
+++ b/recipes/quilt/quilt_0.48.bb
@@ -1,6 +1,6 @@
require quilt-package.inc
-PR="r1"
+PR="${INC_PR}"
SRC_URI[md5sum] = "f77adda60039ffa753f3c584a286f12b"
SRC_URI[sha256sum] = "73fd760d3b5cbf06417576591dc37d67380d189392db9000c21b7cbebee49ffc"