summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-04-29 14:25:14 +0100
committerGraeme Gregory <dp@xora.org.uk>2009-04-29 14:32:37 +0100
commitac4a2334cf292d5a131b60002753612db5c9bda2 (patch)
tree13ac161f86bbc35358ca4686fb6d356cd5281fce /recipes
parent565e76ba4588fc2baa34862f7378f243d117ee39 (diff)
downloadopenembedded-ac4a2334cf292d5a131b60002753612db5c9bda2.tar.gz
recipes/opkg/files/configure : fix the case where this is no splash installed.
recipes/opkg/opkg*.bb : bump PR for affected recipes
Diffstat (limited to 'recipes')
-rw-r--r--recipes/opkg/files/configure10
-rw-r--r--recipes/opkg/opkg-nogpg-nocurl_svn.bb2
-rw-r--r--recipes/opkg/opkg-nogpg_svn.bb2
-rw-r--r--recipes/opkg/opkg_svn.bb2
4 files changed, 9 insertions, 7 deletions
diff --git a/recipes/opkg/files/configure b/recipes/opkg/files/configure
index 318ccb19c3..d5dd74dbf3 100644
--- a/recipes/opkg/files/configure
+++ b/recipes/opkg/files/configure
@@ -7,16 +7,18 @@ status_pulse || true
fi
# run configure in bg
-opkg-cl configure &
-PID=$!
-
-if [ -f /etc/default/splashfuncs ]; then
+if [ -f /etc/default/splashfuncs ]; then
+ opkg-cl configure &
+ PID=$!
+
# while configure still running loop
while test -d /proc/$PID; do
# tick to splash so it doesn't time out
status_tick || true
sleep 1
done
+else
+ opkg-cl configure
fi
# delete myself
diff --git a/recipes/opkg/opkg-nogpg-nocurl_svn.bb b/recipes/opkg/opkg-nogpg-nocurl_svn.bb
index 60da447696..c390174d60 100644
--- a/recipes/opkg/opkg-nogpg-nocurl_svn.bb
+++ b/recipes/opkg/opkg-nogpg-nocurl_svn.bb
@@ -11,7 +11,7 @@ SRC_URI += " \
file://opkg_wget_nogpg_03_fix_tmpdirs.patch;patch=1 \
file://opkg_wget_nogpg_04_default_tmpdir.patch;patch=1 \
"
-PR = "r6"
+PR = "r7"
SRCREV = "${SRCREV_pn-opkg}"
diff --git a/recipes/opkg/opkg-nogpg_svn.bb b/recipes/opkg/opkg-nogpg_svn.bb
index c0a4d4a6e8..b6bb4b36e0 100644
--- a/recipes/opkg/opkg-nogpg_svn.bb
+++ b/recipes/opkg/opkg-nogpg_svn.bb
@@ -3,7 +3,7 @@ require opkg_svn.bb
DEPENDS = "curl"
PROVIDES += "opkg"
-PR = "r12"
+PR = "r13"
SRCREV = "${SRCREV_pn-opkg}"
diff --git a/recipes/opkg/opkg_svn.bb b/recipes/opkg/opkg_svn.bb
index 749fa1e975..d2863774a4 100644
--- a/recipes/opkg/opkg_svn.bb
+++ b/recipes/opkg/opkg_svn.bb
@@ -1,6 +1,6 @@
require opkg.inc
-PR = "r12"
+PR = "r13"
PACKAGES =+ "libopkg-dev libopkg"