summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-03-24 13:59:27 -0700
committerKhem Raj <raj.khem@gmail.com>2009-03-24 13:59:27 -0700
commitaf33616e7ede94c06a866ef7e886e65426b088ec (patch)
treee6b6cd023eacca5a43a7691da648948544c62940 /recipes
parent25183a96de2634875d9720e70903f2fcb78199a3 (diff)
parent947264decb5dee13c580ca68d35217d6d5481db5 (diff)
downloadopenembedded-af33616e7ede94c06a866ef7e886e65426b088ec.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/dsplink/ti-dmai_svn.bb (renamed from recipes/dsplink/ti-dmai_1.20.bb)27
-rw-r--r--recipes/hostap/hostap-daemon-0.6.9/defconfig144
-rw-r--r--recipes/hostap/hostap-daemon_0.6.9.bb45
-rw-r--r--recipes/linux/linux-omap-2.6.28/beagleboard/defconfig46
-rw-r--r--recipes/linux/linux-omap_2.6.28.bb2
-rw-r--r--recipes/qmake/qmake2-native.inc15
-rw-r--r--recipes/qt4/qt-embedded_4.4.3.bb2
-rw-r--r--recipes/qt4/qt4-x11-free_4.4.3.bb2
-rw-r--r--recipes/qt4/qt_staging.inc7
9 files changed, 236 insertions, 54 deletions
diff --git a/recipes/dsplink/ti-dmai_1.20.bb b/recipes/dsplink/ti-dmai_svn.bb
index 026f5a382c..f6ff173a42 100644
--- a/recipes/dsplink/ti-dmai_1.20.bb
+++ b/recipes/dsplink/ti-dmai_svn.bb
@@ -4,22 +4,17 @@ LICENCE = "unknown"
require ti-paths.inc
-# https://www-a.ti.com/downloads/sds_support/applications_packages/dmai/dmai_1_20_00_06/dmai_setuplinux_1_20_00_06.bin
-# Install the above link and put the dmai_1_20_00_06.tar.gz file in the same directory as this recipe
-SRC_URI = "file://dmai_1_20_00_06.tar.gz \
- file://dmai-update-cpu-name.patch;patch=1 \
- file://dmai-update-fb-display.patch;patch=1 \
- file://dmai-update-v4l2-display.patch;patch=1 \
- file://dmai-do-not-panic-on-mixer-failure.patch;patch=1 \
- file://dmai-support-32bit-align.patch;patch=1 \
+SRC_URI = "svn://gforge.ti.com/svn/dmai/branches;module=BRIJESH_GIT_022309;proto=https;user=anonymous;pswd='' \
file://dmai-built-with-angstrom.patch;patch=1 \
file://loadmodules-ti-dmai-apps.sh \
file://unloadmodules-ti-dmai-apps.sh \
"
-S = "${WORKDIR}/dmai_1_20_00_06"
+SRCREV = "36"
+
+S = "${WORKDIR}/BRIJESH_GIT_022309/davinci_multimedia_application_interface/dmai"
# Yes, the xdc stuff still breaks with a '.' in PWD
-PV = "120"
+PV = "120+svnr${SRCREV}"
PR = "r15"
TARGET = "all"
@@ -31,18 +26,6 @@ export CE_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine"
export FC_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/cetools"
export CODEC_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-combos"
-do_compile_prepend_omap3evm() {
-
-#temp removal of sources that fail to build on evm3530
- if [ -e packages/ti/sdo/dmai/linux/omap3530/Resize.c ]; then
- rm packages/ti/sdo/dmai/linux/omap3530/Resize.c
- fi
-
- if [ -e packages/ti/sdo/dmai/linux/omap3530/Framecopy_accel.c ]; then
- rm packages/ti/sdo/dmai/linux/omap3530/Framecopy_accel.c
- fi
-}
-
do_compile() {
cd packages/ti/sdo/dmai
oe_runmake clean
diff --git a/recipes/hostap/hostap-daemon-0.6.9/defconfig b/recipes/hostap/hostap-daemon-0.6.9/defconfig
new file mode 100644
index 0000000000..0bf24782d1
--- /dev/null
+++ b/recipes/hostap/hostap-daemon-0.6.9/defconfig
@@ -0,0 +1,144 @@
+# Example hostapd build time configuration
+#
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+# Driver interface for Host AP driver
+CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for wired authenticator
+CONFIG_DRIVER_WIRED=y
+
+# Driver interface for madwifi driver
+#CONFIG_DRIVER_MADWIFI=y
+#CFLAGS += -I../../madwifi # change to the madwifi source directory
+
+# Driver interface for Prism54 driver
+CONFIG_DRIVER_PRISM54=y
+
+# Driver interface for drivers using the nl80211 kernel interface
+CONFIG_DRIVER_NL80211=y
+# driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
+# shipped with your distribution yet. If that is the case, you need to build
+# newer libnl version and point the hostapd build to use it.
+#LIBNL=/usr/src/libnl
+#CFLAGS += -I$(LIBNL)/include
+#LIBS += -L$(LIBNL)/lib
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+
+# Driver interface for no driver (e.g., RADIUS server only)
+#CONFIG_DRIVER_NONE=y
+
+# IEEE 802.11F/IAPP
+CONFIG_IAPP=y
+
+# WPA2/IEEE 802.11i RSN pre-authentication
+CONFIG_RSN_PREAUTH=y
+
+# PeerKey handshake for Station to Station Link (IEEE 802.11e DLS)
+CONFIG_PEERKEY=y
+
+# IEEE 802.11w (management frame protection)
+# This version is an experimental implementation based on IEEE 802.11w/D1.0
+# draft and is subject to change since the standard has not yet been finalized.
+# Driver support is also needed for IEEE 802.11w.
+#CONFIG_IEEE80211W=y
+
+# Integrated EAP server
+CONFIG_EAP=y
+
+# EAP-MD5 for the integrated EAP server
+CONFIG_EAP_MD5=y
+
+# EAP-TLS for the integrated EAP server
+CONFIG_EAP_TLS=y
+
+# EAP-MSCHAPv2 for the integrated EAP server
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-PEAP for the integrated EAP server
+CONFIG_EAP_PEAP=y
+
+# EAP-GTC for the integrated EAP server
+CONFIG_EAP_GTC=y
+
+# EAP-TTLS for the integrated EAP server
+CONFIG_EAP_TTLS=y
+
+# EAP-SIM for the integrated EAP server
+#CONFIG_EAP_SIM=y
+
+# EAP-AKA for the integrated EAP server
+#CONFIG_EAP_AKA=y
+
+# EAP-AKA' for the integrated EAP server
+# This requires CONFIG_EAP_AKA to be enabled, too.
+#CONFIG_EAP_AKA_PRIME=y
+
+# EAP-PAX for the integrated EAP server
+#CONFIG_EAP_PAX=y
+
+# EAP-PSK for the integrated EAP server (this is _not_ needed for WPA-PSK)
+#CONFIG_EAP_PSK=y
+
+# EAP-SAKE for the integrated EAP server
+#CONFIG_EAP_SAKE=y
+
+# EAP-GPSK for the integrated EAP server
+#CONFIG_EAP_GPSK=y
+# Include support for optional SHA256 cipher suite in EAP-GPSK
+#CONFIG_EAP_GPSK_SHA256=y
+
+# EAP-FAST for the integrated EAP server
+# Note: Default OpenSSL package does not include support for all the
+# functionality needed for EAP-FAST. If EAP-FAST is enabled with OpenSSL,
+# the OpenSSL library must be patched (openssl-0.9.9-session-ticket.patch)
+# to add the needed functions.
+#CONFIG_EAP_FAST=y
+
+# Wi-Fi Protected Setup (WPS)
+CONFIG_WPS=y
+# Enable UPnP support for external WPS Registrars
+#CONFIG_WPS_UPNP=y
+
+# EAP-IKEv2
+#CONFIG_EAP_IKEV2=y
+
+# Trusted Network Connect (EAP-TNC)
+#CONFIG_EAP_TNC=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# RADIUS authentication server. This provides access to the integrated EAP
+# server from external hosts using RADIUS.
+CONFIG_RADIUS_SERVER=y
+
+# Build IPv6 support for RADIUS operations
+CONFIG_IPV6=y
+
+# IEEE Std 802.11r-2008 (Fast BSS Transition)
+#CONFIG_IEEE80211R=y
+
+# Use the hostapd's IEEE 802.11 authentication (ACL), but without
+# the IEEE 802.11 Management capability (e.g., madwifi or FreeBSD/net80211)
+CONFIG_DRIVER_RADIUS_ACL=y
+
+# IEEE 802.11n (High Throughput) support
+CONFIG_IEEE80211N=y
+
+# Remove debugging code that is printing out debug messages to stdout.
+# This can be used to reduce the size of the hostapd considerably if debugging
+# code is not needed.
+#CONFIG_NO_STDOUT_DEBUG=y
diff --git a/recipes/hostap/hostap-daemon_0.6.9.bb b/recipes/hostap/hostap-daemon_0.6.9.bb
new file mode 100644
index 0000000000..0b7a1925b3
--- /dev/null
+++ b/recipes/hostap/hostap-daemon_0.6.9.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libnl openssl ${@base_contains("COMBINED_FEATURES", "pci", "madwifi-ng", "",d)}"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+#we introduce MY_ARCH to get 'armv5te' as arch instead of the misleading 'arm' on armv5te builds
+MY_ARCH := "${PACKAGE_ARCH}"
+PACKAGE_ARCH = "${@base_contains('COMBINED_FEATURES', 'pci', '${MACHINE_ARCH}', '${MY_ARCH}', d)}"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
+ file://defconfig \
+ file://init"
+
+S = "${WORKDIR}/hostapd-${PV}/hostapd"
+
+export HAS_PCI = "${@base_contains('COMBINED_FEATURES', 'pci', 1, 0,d)}"
+
+inherit update-rc.d
+INITSCRIPT_NAME=hostapd
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ if [ "x$HAS_PCI" = "x1" ] ; then
+ echo "CONFIG_DRIVER_MADWIFI=y" >> .config
+ echo "CFLAGS += -I${STAGING_INCDIR}/madwifi-ng" >> .config
+ fi
+}
+
+do_compile() {
+ make
+}
+
+do_install() {
+ install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
+ install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir}
+ install -m 0755 ${S}/hostapd ${D}${sbindir}
+ install -m 0755 ${S}/hostapd_cli ${D}${sbindir}
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
+}
+
diff --git a/recipes/linux/linux-omap-2.6.28/beagleboard/defconfig b/recipes/linux/linux-omap-2.6.28/beagleboard/defconfig
index 45958e0e07..7941542b4e 100644
--- a/recipes/linux/linux-omap-2.6.28/beagleboard/defconfig
+++ b/recipes/linux/linux-omap-2.6.28/beagleboard/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.28-omap1
-# Wed Jan 14 19:12:03 2009
+# Tue Mar 24 16:56:43 2009
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -41,7 +41,10 @@ CONFIG_SYSVIPC_SYSCTL=y
# CONFIG_POSIX_MQUEUE is not set
CONFIG_BSD_PROCESS_ACCT=y
# CONFIG_BSD_PROCESS_ACCT_V3 is not set
-# CONFIG_TASKSTATS is not set
+CONFIG_TASKSTATS=y
+CONFIG_TASK_DELAY_ACCT=y
+CONFIG_TASK_XACCT=y
+CONFIG_TASK_IO_ACCOUNTING=y
# CONFIG_AUDIT is not set
CONFIG_IKCONFIG=y
CONFIG_IKCONFIG_PROC=y
@@ -726,7 +729,9 @@ CONFIG_P54_USB=y
CONFIG_HOSTAP=y
CONFIG_HOSTAP_FIRMWARE=y
CONFIG_HOSTAP_FIRMWARE_NVRAM=y
-# CONFIG_B43 is not set
+CONFIG_B43=y
+CONFIG_B43_LEDS=y
+# CONFIG_B43_DEBUG is not set
# CONFIG_B43LEGACY is not set
CONFIG_ZD1211RW=y
# CONFIG_ZD1211RW_DEBUG is not set
@@ -743,21 +748,21 @@ CONFIG_RT2X00_LIB_LEDS=y
#
# USB Network Adapters
#
-CONFIG_USB_CATC=m
-CONFIG_USB_KAWETH=m
-CONFIG_USB_PEGASUS=m
-CONFIG_USB_RTL8150=m
+CONFIG_USB_CATC=y
+CONFIG_USB_KAWETH=y
+CONFIG_USB_PEGASUS=y
+CONFIG_USB_RTL8150=y
CONFIG_USB_USBNET=y
CONFIG_USB_NET_AX8817X=y
CONFIG_USB_NET_CDCETHER=y
-CONFIG_USB_NET_DM9601=m
-# CONFIG_USB_NET_SMSC95XX is not set
-CONFIG_USB_NET_GL620A=m
-CONFIG_USB_NET_NET1080=m
-CONFIG_USB_NET_PLUSB=m
+CONFIG_USB_NET_DM9601=y
+CONFIG_USB_NET_SMSC95XX=y
+CONFIG_USB_NET_GL620A=y
+CONFIG_USB_NET_NET1080=y
+CONFIG_USB_NET_PLUSB=y
CONFIG_USB_NET_MCS7830=m
CONFIG_USB_NET_RNDIS_HOST=y
-CONFIG_USB_NET_CDC_SUBSET=m
+CONFIG_USB_NET_CDC_SUBSET=y
CONFIG_USB_ALI_M5632=y
CONFIG_USB_AN2720=y
CONFIG_USB_BELKIN=y
@@ -832,6 +837,12 @@ CONFIG_MOUSE_PS2_TRACKPOINT=y
# CONFIG_INPUT_TABLET is not set
# CONFIG_INPUT_TOUCHSCREEN is not set
CONFIG_INPUT_MISC=y
+# CONFIG_INPUT_ATI_REMOTE is not set
+# CONFIG_INPUT_ATI_REMOTE2 is not set
+# CONFIG_INPUT_KEYSPAN_REMOTE is not set
+# CONFIG_INPUT_POWERMATE is not set
+# CONFIG_INPUT_YEALINK is not set
+# CONFIG_INPUT_CM109 is not set
CONFIG_INPUT_UINPUT=y
#
@@ -1061,7 +1072,9 @@ CONFIG_SSB_POSSIBLE=y
#
# Sonics Silicon Backplane
#
-# CONFIG_SSB is not set
+CONFIG_SSB=y
+# CONFIG_SSB_SILENT is not set
+# CONFIG_SSB_DEBUG is not set
#
# Multifunction device drivers
@@ -1664,14 +1677,13 @@ CONFIG_USB_GADGET_SELECTED=y
# CONFIG_USB_GADGET_DUMMY_HCD is not set
CONFIG_USB_GADGET_DUALSPEED=y
# CONFIG_USB_ZERO is not set
-CONFIG_USB_ETH=y
-CONFIG_USB_ETH_RNDIS=y
+# CONFIG_USB_ETH is not set
# CONFIG_USB_GADGETFS is not set
# CONFIG_USB_FILE_STORAGE is not set
# CONFIG_USB_G_SERIAL is not set
# CONFIG_USB_MIDI_GADGET is not set
# CONFIG_USB_G_PRINTER is not set
-# CONFIG_USB_CDC_COMPOSITE is not set
+CONFIG_USB_CDC_COMPOSITE=y
#
# OTG and related infrastructure
diff --git a/recipes/linux/linux-omap_2.6.28.bb b/recipes/linux/linux-omap_2.6.28.bb
index a64ff4b940..8a3d6be27e 100644
--- a/recipes/linux/linux-omap_2.6.28.bb
+++ b/recipes/linux/linux-omap_2.6.28.bb
@@ -12,7 +12,7 @@ DEFAULT_PREFERENCE_overo = "1"
SRCREV = "79d042a081d3e467c735bb0d9569ed6296f85a3c"
PV = "2.6.28"
-PR = "r15"
+PR = "r17"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;branch=omap-2.6.28;protocol=git \
file://defconfig"
diff --git a/recipes/qmake/qmake2-native.inc b/recipes/qmake/qmake2-native.inc
index 467f130f2e..f84da2ad52 100644
--- a/recipes/qmake/qmake2-native.inc
+++ b/recipes/qmake/qmake2-native.inc
@@ -3,7 +3,7 @@ PRIORITY = "optional"
HOMEPAGE = "http://www.trolltech.com"
SECTION = "devel"
LICENSE = "GPL"
-PR = "r5"
+PR = "r7"
# We call 'moc' during the build
DEPENDS = "uicmoc4-native"
@@ -17,9 +17,6 @@ SRC_URI = "ftp://ftp.trolltech.com/qt/source/${QTVER}.tar.bz2 \
file://linux-oe-qmake.conf"
S = "${WORKDIR}/${QTVER}"
-# we need the real target system here
-CROSS_SYS := "${MULTIMACH_TARGET_SYS}"
-
inherit autotools
export QTDIR = "${S}"
@@ -39,7 +36,6 @@ do_configure() {
QMAKESPEC=
PLATFORM=${HOST_OS}-oe-g++
export PLATFORM
- # yes, TARGET_SYS is correct, because this is a 'cross'-qmake-native :) :M:
export OE_QMAKE_CC="${CC}"
export OE_QMAKE_CFLAGS="${CFLAGS}"
export OE_QMAKE_CXX="${CXX}"
@@ -55,7 +51,7 @@ do_configure() {
export QMAKE_RCC="${STAGING_BINDIR_NATIVE}/rcc4"
export OE_QMAKE_QMAKE="${STAGING_BINDIR_NATIVE}/qmake"
export OE_QMAKE_RPATH="-Wl,-rpath-link,"
- echo yes | ./configure -prefix ${STAGING_DIR_TARGET}/qt4 ${EXTRA_OECONF} || die "Configuring qt failed"
+ echo yes | ./configure -prefix ${STAGING_DIR_NATIVE}/qt4 ${EXTRA_OECONF} || die "Configuring qt failed"
}
do_compile() {
@@ -65,8 +61,7 @@ do_compile() {
do_stage() {
install -d ${STAGING_BINDIR_NATIVE}
install -m 0755 bin/qmake ${STAGING_BINDIR_NATIVE}/qmake2
- install -m 0755 bin/qmake ${STAGING_BINDIR_NATIVE}/qmake-qt4
-
- install -d ${CROSS_DATADIR}/qt4
- cp -PfR mkspecs ${CROSS_DATADIR}/qt4/
+ install -m 0755 bin/qmake ${STAGING_BINDIR_NATIVE}/qmake-qt4
+ install -d ${STAGING_DATADIR_NATIVE}/qt4
+ cp -PfR mkspecs ${STAGING_DATADIR_NATIVE}/qt4/
}
diff --git a/recipes/qt4/qt-embedded_4.4.3.bb b/recipes/qt4/qt-embedded_4.4.3.bb
index 22715cc382..d0f57ca35f 100644
--- a/recipes/qt4/qt-embedded_4.4.3.bb
+++ b/recipes/qt4/qt-embedded_4.4.3.bb
@@ -1,2 +1,2 @@
require qt-embedded.inc
-PR = "r6"
+PR = "r7"
diff --git a/recipes/qt4/qt4-x11-free_4.4.3.bb b/recipes/qt4/qt4-x11-free_4.4.3.bb
index 987a489e97..d1bf335420 100644
--- a/recipes/qt4/qt4-x11-free_4.4.3.bb
+++ b/recipes/qt4/qt4-x11-free_4.4.3.bb
@@ -1,5 +1,5 @@
require qt4-x11-free.inc
-PR = "r4"
+PR = "r5"
SRC_URI += " \
file://0002-fix-resinit-declaration.patch;patch=1 \
diff --git a/recipes/qt4/qt_staging.inc b/recipes/qt4/qt_staging.inc
index 3bbcdcde22..21e1b4c31f 100644
--- a/recipes/qt4/qt_staging.inc
+++ b/recipes/qt4/qt_staging.inc
@@ -16,6 +16,7 @@ do_stage_append() {
sed -i s#"-L${S}/lib"##g libQt*.la
sed -i s#'$(OE_QMAKE_LIBS_X11)'#"${OE_QMAKE_LIBS_X11}"#g libQt*.la
+ # FIXME: is this really needed?
install -d ${STAGING_DIR_TARGET}/qt4/bin
cp ${STAGING_DIR_NATIVE}/qt4/bin/* ${STAGING_DIR_TARGET}/qt4/bin/ || true
cp ${STAGING_DIR_NATIVE}/${bindir}/{rcc*,uic*,moc*} ${STAGING_DIR_TARGET}/qt4/bin/ || true
@@ -30,9 +31,11 @@ do_stage() {
mkdir -p ${STAGE_TEMP}
oe_runmake install INSTALL_ROOT=${STAGE_TEMP}
- install -d ${STAGING_INCDIR}/
+ install -d ${STAGING_INCDIR}
install -d ${STAGING_LIBDIR}
- cp -pPRf ${STAGE_TEMP}/$includedir/* ${STAGING_INCDIR}/
+ cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/
+ install -d ${STAGING_DATADIR}/${QT_DIR_NAME}/mkspecs
+ cp -pPRf ${STAGE_TEMP}/${datadir}/${QT_DIR_NAME}/mkspecs/* ${STAGING_DATADIR}/${QT_DIR_NAME}/mkspecs/
for i in ${STAGE_TEMP}/${libdir}/*.la
do