summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-08-17 10:04:12 -0700
committerTom Rini <tom_rini@mentor.com>2010-08-17 10:04:12 -0700
commitaf89852d1cb18250b7bc01991e9c9ddeaf369110 (patch)
tree6cb5550add78bd72a31f653a94001a0f90fdfa17 /recipes
parent65cd015e629cdb14aefd0de210530aee83b9cb15 (diff)
downloadopenembedded-af89852d1cb18250b7bc01991e9c9ddeaf369110.tar.gz
lmbench: Fix 2.0.4 like Koen did for 2.5
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/lmbench/lmbench_2.0.4.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/recipes/lmbench/lmbench_2.0.4.bb b/recipes/lmbench/lmbench_2.0.4.bb
index fc6c7a13dc..50a5377428 100644
--- a/recipes/lmbench/lmbench_2.0.4.bb
+++ b/recipes/lmbench/lmbench_2.0.4.bb
@@ -2,7 +2,10 @@ SECTION = "console/utils"
DESCRIPTION = "Tools for performance analysis."
LICENSE = "GPL"
RDEPENDS_${PN} = "debianutils"
-PR = "r2"
+
+PR = "r3"
+
+inherit autotools
SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
file://debian.patch \
@@ -14,12 +17,6 @@ EXTRA_OEMAKE = '"CC=${CC}" "AR=${AR}" "CFLAGS=$CFLAGS" \
"LDFLAGS=${LDFLAGS}" "LD=${LD}" "OS=${TARGET_SYS}" \
"TARGET=${TARGET_OS}" "O=${S}/bin/${TARGET_SYS}"'
-
-inherit siteinfo
-
-# Space separated list of shell scripts with variables defined to supply test
-# results for autoconf tests we cannot run at build time.
-export CONFIG_SITE = "${@siteinfo_get_files(d)}"
python do_unpack () {
bb.build.exec_func('base_do_unpack', d)
bb.build.exec_func('byebk_do_unpack', d)
@@ -29,6 +26,10 @@ byebk_do_unpack () {
find ${S}/.. -name BitKeeper -o -name SCCS | xargs rm -rf
}
+do_configure() {
+ :
+}
+
do_compile () {
. ${CONFIG_SITE}
if [ X"$ac_cv_uint" == X"yes" ]; then