summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-04-01 18:59:48 +0200
committerJeremy Lainé <jeremy.laine@m4x.org>2009-04-01 18:59:48 +0200
commitd323bccf4de598e47ec193058f2a5a8dac9b0d31 (patch)
tree6429e929501d64f84df5c2a23b235c43878069de /recipes
parentb44ce1af2eed4793c5ddb38f1a545deb7ac9aacb (diff)
downloadopenembedded-d323bccf4de598e47ec193058f2a5a8dac9b0d31.tar.gz
hostap-daemon-0.6.9: disable madwifi-ng support
Diffstat (limited to 'recipes')
-rw-r--r--recipes/hostap/hostap-daemon_0.6.9.bb14
1 files changed, 2 insertions, 12 deletions
diff --git a/recipes/hostap/hostap-daemon_0.6.9.bb b/recipes/hostap/hostap-daemon_0.6.9.bb
index 0b7a1925b3..8e9aa5d328 100644
--- a/recipes/hostap/hostap-daemon_0.6.9.bb
+++ b/recipes/hostap/hostap-daemon_0.6.9.bb
@@ -3,32 +3,22 @@ HOMEPAGE = "http://hostap.epitest.fi"
SECTION = "kernel/userland"
PRIORITY = "optional"
LICENSE = "GPL"
-DEPENDS = "libnl openssl ${@base_contains("COMBINED_FEATURES", "pci", "madwifi-ng", "",d)}"
-PR = "r0"
+DEPENDS = "libnl openssl"
+PR = "r1"
DEFAULT_PREFERENCE = "-1"
-#we introduce MY_ARCH to get 'armv5te' as arch instead of the misleading 'arm' on armv5te builds
-MY_ARCH := "${PACKAGE_ARCH}"
-PACKAGE_ARCH = "${@base_contains('COMBINED_FEATURES', 'pci', '${MACHINE_ARCH}', '${MY_ARCH}', d)}"
-
SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
file://defconfig \
file://init"
S = "${WORKDIR}/hostapd-${PV}/hostapd"
-export HAS_PCI = "${@base_contains('COMBINED_FEATURES', 'pci', 1, 0,d)}"
-
inherit update-rc.d
INITSCRIPT_NAME=hostapd
do_configure() {
install -m 0644 ${WORKDIR}/defconfig ${S}/.config
- if [ "x$HAS_PCI" = "x1" ] ; then
- echo "CONFIG_DRIVER_MADWIFI=y" >> .config
- echo "CFLAGS += -I${STAGING_INCDIR}/madwifi-ng" >> .config
- fi
}
do_compile() {