aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-25 04:14:52 +0000
committerKhem Raj <raj.khem@gmail.com>2011-01-24 18:27:13 -0800
commit61a8d80ccdc245898e878d97439a929d758ceb5b (patch)
tree7a9639a26f00d5ec92dcae8e2bfa5d7d6c85d1eb /recipes
parent46cc091e64b1be3eab002653b426a9492730cecd (diff)
downloadopenembedded-61a8d80ccdc245898e878d97439a929d758ceb5b.tar.gz
udev: Remove duplicate udev firmware loading rule
A duplicate udev rule calling firmware.sh exists in 50-udev-default.rules and udev.rules This causes the kernel to sometimes get the wrong the firmware due to a race between the two calls. This is with udev124 from the stable2009 openembedded branch however a quick glance suggests that the same problem exists on the dev branch. 50-udev-default.rules comes from the upstream tarball udev.rules is in the openembedded recipe. This causes the infamous "Error number -110" while uploading firmware, i.e: [ 4171.357272] firmware: requesting zd1211/zd1211b_ub [ 4171.375779] firmware: requesting zd1211/zd1211b_uphr [ 4193.981056] firmware: requesting zd1211/zd1211b_ub [ 4193.986433] firmware: requesting zd1211/zd1211b_uphr [ 4195.033695] usb 8-3: USB control request for firmware upload failed. Error number -110 * Fixes Bugzilla/5334 Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/udev/udev-097/udev.rules3
-rw-r--r--recipes/udev/udev-100/udev.rules3
-rw-r--r--recipes/udev/udev-124/udev.rules3
-rw-r--r--recipes/udev/udev-141/udev.rules3
-rw-r--r--recipes/udev/udev-151/udev.rules3
-rw-r--r--recipes/udev/udev-154/udev.rules3
-rw-r--r--recipes/udev/udev-162/udev.rules3
-rw-r--r--recipes/udev/udev-165/udev.rules3
-rw-r--r--recipes/udev/udev_097.bb2
-rw-r--r--recipes/udev/udev_100.bb2
-rw-r--r--recipes/udev/udev_124.bb2
-rw-r--r--recipes/udev/udev_141.bb2
-rw-r--r--recipes/udev/udev_151.bb2
-rw-r--r--recipes/udev/udev_154.bb2
-rw-r--r--recipes/udev/udev_162.bb2
-rw-r--r--recipes/udev/udev_165.bb2
16 files changed, 8 insertions, 32 deletions
diff --git a/recipes/udev/udev-097/udev.rules b/recipes/udev/udev-097/udev.rules
index 27c4cb86ce..1fcf0cd939 100644
--- a/recipes/udev/udev-097/udev.rules
+++ b/recipes/udev/udev-097/udev.rules
@@ -94,9 +94,6 @@ KERNEL=="device-mapper", NAME="mapper/control"
KERNEL=="rfcomm[0-9]*", NAME="%k", GROUP="users", MODE="0660"
-# Firmware Helper
-ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware.sh"
-
# Samsung UARTS
KERNEL=="s3c2410_serial[0-9]", NAME="ttySAC%n"
diff --git a/recipes/udev/udev-100/udev.rules b/recipes/udev/udev-100/udev.rules
index 27c4cb86ce..1fcf0cd939 100644
--- a/recipes/udev/udev-100/udev.rules
+++ b/recipes/udev/udev-100/udev.rules
@@ -94,9 +94,6 @@ KERNEL=="device-mapper", NAME="mapper/control"
KERNEL=="rfcomm[0-9]*", NAME="%k", GROUP="users", MODE="0660"
-# Firmware Helper
-ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware.sh"
-
# Samsung UARTS
KERNEL=="s3c2410_serial[0-9]", NAME="ttySAC%n"
diff --git a/recipes/udev/udev-124/udev.rules b/recipes/udev/udev-124/udev.rules
index a19d4a0bf6..6117b94875 100644
--- a/recipes/udev/udev-124/udev.rules
+++ b/recipes/udev/udev-124/udev.rules
@@ -105,9 +105,6 @@ KERNEL=="device-mapper", NAME="mapper/control"
KERNEL=="rfcomm[0-9]*", NAME="%k", GROUP="users", MODE="0660"
-# Firmware Helper
-ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware.sh"
-
# Samsung UARTS
KERNEL=="s3c2410_serial[0-9]", NAME="ttySAC%n"
diff --git a/recipes/udev/udev-141/udev.rules b/recipes/udev/udev-141/udev.rules
index a19d4a0bf6..6117b94875 100644
--- a/recipes/udev/udev-141/udev.rules
+++ b/recipes/udev/udev-141/udev.rules
@@ -105,9 +105,6 @@ KERNEL=="device-mapper", NAME="mapper/control"
KERNEL=="rfcomm[0-9]*", NAME="%k", GROUP="users", MODE="0660"
-# Firmware Helper
-ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware.sh"
-
# Samsung UARTS
KERNEL=="s3c2410_serial[0-9]", NAME="ttySAC%n"
diff --git a/recipes/udev/udev-151/udev.rules b/recipes/udev/udev-151/udev.rules
index 60288c06ed..c20cdcc153 100644
--- a/recipes/udev/udev-151/udev.rules
+++ b/recipes/udev/udev-151/udev.rules
@@ -105,9 +105,6 @@ KERNEL=="device-mapper", NAME="mapper/control"
KERNEL=="rfcomm[0-9]*", GROUP="users", MODE="0660"
-# Firmware Helper
-ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware.sh"
-
# Samsung UARTS
KERNEL=="s3c2410_serial[0-9]", NAME="ttySAC%n"
diff --git a/recipes/udev/udev-154/udev.rules b/recipes/udev/udev-154/udev.rules
index 60288c06ed..c20cdcc153 100644
--- a/recipes/udev/udev-154/udev.rules
+++ b/recipes/udev/udev-154/udev.rules
@@ -105,9 +105,6 @@ KERNEL=="device-mapper", NAME="mapper/control"
KERNEL=="rfcomm[0-9]*", GROUP="users", MODE="0660"
-# Firmware Helper
-ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware.sh"
-
# Samsung UARTS
KERNEL=="s3c2410_serial[0-9]", NAME="ttySAC%n"
diff --git a/recipes/udev/udev-162/udev.rules b/recipes/udev/udev-162/udev.rules
index 60288c06ed..c20cdcc153 100644
--- a/recipes/udev/udev-162/udev.rules
+++ b/recipes/udev/udev-162/udev.rules
@@ -105,9 +105,6 @@ KERNEL=="device-mapper", NAME="mapper/control"
KERNEL=="rfcomm[0-9]*", GROUP="users", MODE="0660"
-# Firmware Helper
-ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware.sh"
-
# Samsung UARTS
KERNEL=="s3c2410_serial[0-9]", NAME="ttySAC%n"
diff --git a/recipes/udev/udev-165/udev.rules b/recipes/udev/udev-165/udev.rules
index 60288c06ed..c20cdcc153 100644
--- a/recipes/udev/udev-165/udev.rules
+++ b/recipes/udev/udev-165/udev.rules
@@ -105,9 +105,6 @@ KERNEL=="device-mapper", NAME="mapper/control"
KERNEL=="rfcomm[0-9]*", GROUP="users", MODE="0660"
-# Firmware Helper
-ACTION=="add", SUBSYSTEM=="firmware", RUN+="/lib/udev/firmware.sh"
-
# Samsung UARTS
KERNEL=="s3c2410_serial[0-9]", NAME="ttySAC%n"
diff --git a/recipes/udev/udev_097.bb b/recipes/udev/udev_097.bb
index 84d4b61c6a..2a20005ca8 100644
--- a/recipes/udev/udev_097.bb
+++ b/recipes/udev/udev_097.bb
@@ -10,7 +10,7 @@ needed to link programs with libvolume_id."
require udev.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
LD = "${CC}"
diff --git a/recipes/udev/udev_100.bb b/recipes/udev/udev_100.bb
index a6692cfdd5..c55a6a2b70 100644
--- a/recipes/udev/udev_100.bb
+++ b/recipes/udev/udev_100.bb
@@ -11,7 +11,7 @@ needed to link programs with libvolume_id."
require udev.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
LD = "${CC}"
diff --git a/recipes/udev/udev_124.bb b/recipes/udev/udev_124.bb
index a6c0e18dc3..1585d8cf57 100644
--- a/recipes/udev/udev_124.bb
+++ b/recipes/udev/udev_124.bb
@@ -5,7 +5,7 @@ RPROVIDES_${PN} = "hotplug"
require udev.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
LD = "${CC}"
diff --git a/recipes/udev/udev_141.bb b/recipes/udev/udev_141.bb
index 7a34adabf6..1c6a14893a 100644
--- a/recipes/udev/udev_141.bb
+++ b/recipes/udev/udev_141.bb
@@ -7,7 +7,7 @@ DEFAULT_PREFERENCE = "-1"
require udev.inc
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
SRC_URI += "file://mount.blacklist \
file://run.rules \
diff --git a/recipes/udev/udev_151.bb b/recipes/udev/udev_151.bb
index c903f0e449..32ab909a5d 100644
--- a/recipes/udev/udev_151.bb
+++ b/recipes/udev/udev_151.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
LICENSE = "GPLv2+"
-PR = "r22"
+PR = "r23"
# Untested
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/udev/udev_154.bb b/recipes/udev/udev_154.bb
index d7740a625d..4a358d3753 100644
--- a/recipes/udev/udev_154.bb
+++ b/recipes/udev/udev_154.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
LICENSE = "GPLv2+"
-PR = "r6"
+PR = "r7"
# Untested
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/udev/udev_162.bb b/recipes/udev/udev_162.bb
index dc9d3137d3..90d66ce3b2 100644
--- a/recipes/udev/udev_162.bb
+++ b/recipes/udev/udev_162.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
LICENSE = "GPLv2+"
-PR = "r8"
+PR = "r9"
# Untested
#DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/udev/udev_165.bb b/recipes/udev/udev_165.bb
index c9e5096bdf..55eccb059f 100644
--- a/recipes/udev/udev_165.bb
+++ b/recipes/udev/udev_165.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
LICENSE = "GPLv2+"
-PR = "r0"
+PR = "r1"
# Untested
DEFAULT_PREFERENCE = "-1"