aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSteffen Sledz <sledz@dresearch-fe.de>2012-09-07 16:36:54 +0200
committerSteffen Sledz <sledz@dresearch-fe.de>2012-09-07 16:36:54 +0200
commitd7139c46a628d72ac781294d154e8c12ac9c52e6 (patch)
treee14e51dd651f9cae15e993c00c7b9027a675c59e /recipes
parent3b1d1112a9a80aba8dbee8b7bd54fe83a1acc6a1 (diff)
downloadopenembedded-d7139c46a628d72ac781294d154e8c12ac9c52e6.tar.gz
llvm2.7: provide "lseek64" symbol
EE: Provide the symbol "lseek64" explicitly with <unistd.h> on Linux glibc. With libcxx, it seems <unistd.h> would not be provided. Thanks to Ryuta Suzuki. See also: <http://llvm.org/viewvc/llvm-project?view=rev&revision=137567> Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/llvm/llvm2.7/r137567-lseek64.patch23
-rw-r--r--recipes/llvm/llvm2.7_2.7.bb3
2 files changed, 25 insertions, 1 deletions
diff --git a/recipes/llvm/llvm2.7/r137567-lseek64.patch b/recipes/llvm/llvm2.7/r137567-lseek64.patch
new file mode 100644
index 0000000000..a751d0ff1e
--- /dev/null
+++ b/recipes/llvm/llvm2.7/r137567-lseek64.patch
@@ -0,0 +1,23 @@
+Upstream-Status: Accepted
+
+EE: Provide the symbol "lseek64" explicitly with <unistd.h> on Linux glibc.
+
+With libcxx, it seems <unistd.h> would not be provided. Thanks to Ryuta Suzuki.
+
+See also:
+
+ <http://llvm.org/viewvc/llvm-project?view=rev&revision=137567>
+
+Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de>
+
+diff -Nurd llvm-2.7.orig/lib/ExecutionEngine/JIT/Intercept.cpp llvm-2.7/lib/ExecutionEngine/JIT/Intercept.cpp
+--- llvm-2.7.orig/lib/ExecutionEngine/JIT/Intercept.cpp 2012-09-07 16:21:14.000000000 +0200
++++ llvm-2.7/lib/ExecutionEngine/JIT/Intercept.cpp 2012-09-07 16:22:14.000000000 +0200
+@@ -51,6 +51,7 @@
+ #if defined(HAVE_SYS_STAT_H)
+ #include <sys/stat.h>
+ #endif
++#include <unistd.h>"
+ #include <fcntl.h>
+ /* stat functions are redirecting to __xstat with a version number. On x86-64
+ * linking with libc_nonshared.a and -Wl,--export-dynamic doesn't make 'stat'
diff --git a/recipes/llvm/llvm2.7_2.7.bb b/recipes/llvm/llvm2.7_2.7.bb
index 7d56e7dd3a..758c337967 100644
--- a/recipes/llvm/llvm2.7_2.7.bb
+++ b/recipes/llvm/llvm2.7_2.7.bb
@@ -1,6 +1,6 @@
require llvm.inc
-PR = "r11"
+PR = "r12"
DEPENDS = "llvm-common llvm2.7-native"
@@ -16,6 +16,7 @@ SRC_URI += "\
file://r104653-BFC-BFI.patch \
file://rawMOVLRPC.patch \
file://include-fixes.patch \
+ file://r137567-lseek64.patch \
"
LLVM_RELEASE = "2.7"