aboutsummaryrefslogtreecommitdiffstats
path: root/scummvm
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-09 09:47:41 +0000
committerChris Larson <clarson@kergoth.com>2004-12-09 09:47:41 +0000
commit2c5b8ec6d95cf68650265941530e5ce38c8dd6d9 (patch)
treebf879bea7ef8517ba8c3d1286ef300401d3d484c /scummvm
parent101e2f1623def0a355d20aacb8bd93810703e834 (diff)
downloadopenembedded-2c5b8ec6d95cf68650265941530e5ce38c8dd6d9.tar.gz
Merge oe-devel@oe-devel.bkbits.net:openembedded
into hyperion.kergoth.com:/home/kergoth/code/openembedded 2004/12/09 03:39:39-06:00 kergoth.com!kergoth Break people's builds again.. this time moving the packages into a packages/ subdir to clean things up a bit. BKrev: 41b81f3dvlp3rU7_8MUXLcI8LDdDoA
Diffstat (limited to 'scummvm')
-rw-r--r--scummvm/scummvm-0.6.0/mouse.patch36
-rw-r--r--scummvm/scummvm-0.6.0/sword1.patch16
-rw-r--r--scummvm/scummvm-0.6.0/tremor.patch32
-rw-r--r--scummvm/scummvm-0.6.1b/mouse.patch36
-rw-r--r--scummvm/scummvm-0.6.1b/tremor.patch32
-rw-r--r--scummvm/scummvm_0.6.0.bb0
-rw-r--r--scummvm/scummvm_0.6.1b.bb0
7 files changed, 0 insertions, 152 deletions
diff --git a/scummvm/scummvm-0.6.0/mouse.patch b/scummvm/scummvm-0.6.0/mouse.patch
deleted file mode 100644
index 1697ac811d..0000000000
--- a/scummvm/scummvm-0.6.0/mouse.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- ./backends/sdl/sdl-common.cpp~mouse.patch 2004-03-05 07:23:04.000000000 +1030
-+++ ./backends/sdl/sdl-common.cpp 2004-05-16 07:53:24.000000000 +0930
-@@ -866,6 +866,9 @@
- return true;
-
- case SDL_MOUSEBUTTONDOWN:
-+#ifdef QTOPIA
-+ event->event_code = EVENT_LBUTTONDOWN;
-+#else
- if (ev.button.button == SDL_BUTTON_LEFT)
- event->event_code = EVENT_LBUTTONDOWN;
- else if (ev.button.button == SDL_BUTTON_RIGHT)
-@@ -878,18 +881,23 @@
- #endif
- else
- break;
-+#endif
-
- fillMouseEvent(*event, ev.button.x, ev.button.y);
-
- return true;
-
- case SDL_MOUSEBUTTONUP:
-+#ifdef QTOPIA
-+ event->event_code = EVENT_LBUTTONUP;
-+#else
- if (ev.button.button == SDL_BUTTON_LEFT)
- event->event_code = EVENT_LBUTTONUP;
- else if (ev.button.button == SDL_BUTTON_RIGHT)
- event->event_code = EVENT_RBUTTONUP;
- else
- break;
-+#endif
- fillMouseEvent(*event, ev.button.x, ev.button.y);
-
- return true;
diff --git a/scummvm/scummvm-0.6.0/sword1.patch b/scummvm/scummvm-0.6.0/sword1.patch
deleted file mode 100644
index 0c934ef20f..0000000000
--- a/scummvm/scummvm-0.6.0/sword1.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./sword1/sword1.cpp.old 2004-05-16 03:17:26.000000000 +0930
-+++ ./sword1/sword1.cpp 2004-05-16 03:12:42.000000000 +0930
-@@ -1061,8 +1061,11 @@
- _systemVars.runningFromCd = true;
- _systemVars.currentCD = 2;
- test.close();
-- } else
-- error("Unable to find files.\nPlease read the instructions again");
-+ } else {
-+ _systemVars.runningFromCd = false;
-+ _systemVars.playSpeech = false;
-+// error("Unable to find files.\nPlease read the instructions again");
-+ }
- }
- }
-
diff --git a/scummvm/scummvm-0.6.0/tremor.patch b/scummvm/scummvm-0.6.0/tremor.patch
deleted file mode 100644
index 3acf302ec8..0000000000
--- a/scummvm/scummvm-0.6.0/tremor.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- ./sound/vorbis.cpp.old 2004-05-16 04:23:59.000000000 +0930
-+++ ./sound/vorbis.cpp 2004-05-16 04:24:23.000000000 +0930
-@@ -29,7 +29,7 @@
- #include "sound/audiostream.h"
- #include "sound/audiocd.h"
-
--#include <vorbis/vorbisfile.h>
-+#include <tremor/ivorbisfile.h>
-
-
- AudioStream *makeVorbisStream(OggVorbis_File *file, int duration);
---- ./configure.old 2004-05-16 04:46:47.000000000 +0930
-+++ ./configure 2004-05-16 04:50:42.000000000 +0930
-@@ -560,15 +560,15 @@
- if test "$_vorbis" = auto ; then
- _vorbis=no
- cat > $TMPC << EOF
--#include <vorbis/codec.h>
-+#include <tremor/ivorbiscodec.h>
- int main(void) { vorbis_packet_blocksize(0,0); return 0; }
- EOF
- cc_check $LDFLAGS $CXXFLAGS $OGG_CFLAGS $OGG_LIBS $VORBIS_CFLAGS $VORBIS_LIBS \
-- -lvorbis -logg -lm && _vorbis=yes
-+ -lvorbisidec -logg -lm && _vorbis=yes
- fi
- if test "$_vorbis" = yes ; then
- _def_vorbis='#define USE_VORBIS'
-- LIBS="$LIBS $OGG_LIBS $VORBIS_LIBS -lvorbisfile -lvorbis -logg"
-+ LIBS="$LIBS $OGG_LIBS $VORBIS_LIBS -lvorbisidec -logg"
- INCLUDES="$INCLUDES $OGG_CFLAGS $VORBIS_CFLAGS"
- else
- _def_vorbis='#undef USE_VORBIS'
diff --git a/scummvm/scummvm-0.6.1b/mouse.patch b/scummvm/scummvm-0.6.1b/mouse.patch
deleted file mode 100644
index 1697ac811d..0000000000
--- a/scummvm/scummvm-0.6.1b/mouse.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- ./backends/sdl/sdl-common.cpp~mouse.patch 2004-03-05 07:23:04.000000000 +1030
-+++ ./backends/sdl/sdl-common.cpp 2004-05-16 07:53:24.000000000 +0930
-@@ -866,6 +866,9 @@
- return true;
-
- case SDL_MOUSEBUTTONDOWN:
-+#ifdef QTOPIA
-+ event->event_code = EVENT_LBUTTONDOWN;
-+#else
- if (ev.button.button == SDL_BUTTON_LEFT)
- event->event_code = EVENT_LBUTTONDOWN;
- else if (ev.button.button == SDL_BUTTON_RIGHT)
-@@ -878,18 +881,23 @@
- #endif
- else
- break;
-+#endif
-
- fillMouseEvent(*event, ev.button.x, ev.button.y);
-
- return true;
-
- case SDL_MOUSEBUTTONUP:
-+#ifdef QTOPIA
-+ event->event_code = EVENT_LBUTTONUP;
-+#else
- if (ev.button.button == SDL_BUTTON_LEFT)
- event->event_code = EVENT_LBUTTONUP;
- else if (ev.button.button == SDL_BUTTON_RIGHT)
- event->event_code = EVENT_RBUTTONUP;
- else
- break;
-+#endif
- fillMouseEvent(*event, ev.button.x, ev.button.y);
-
- return true;
diff --git a/scummvm/scummvm-0.6.1b/tremor.patch b/scummvm/scummvm-0.6.1b/tremor.patch
deleted file mode 100644
index 3acf302ec8..0000000000
--- a/scummvm/scummvm-0.6.1b/tremor.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- ./sound/vorbis.cpp.old 2004-05-16 04:23:59.000000000 +0930
-+++ ./sound/vorbis.cpp 2004-05-16 04:24:23.000000000 +0930
-@@ -29,7 +29,7 @@
- #include "sound/audiostream.h"
- #include "sound/audiocd.h"
-
--#include <vorbis/vorbisfile.h>
-+#include <tremor/ivorbisfile.h>
-
-
- AudioStream *makeVorbisStream(OggVorbis_File *file, int duration);
---- ./configure.old 2004-05-16 04:46:47.000000000 +0930
-+++ ./configure 2004-05-16 04:50:42.000000000 +0930
-@@ -560,15 +560,15 @@
- if test "$_vorbis" = auto ; then
- _vorbis=no
- cat > $TMPC << EOF
--#include <vorbis/codec.h>
-+#include <tremor/ivorbiscodec.h>
- int main(void) { vorbis_packet_blocksize(0,0); return 0; }
- EOF
- cc_check $LDFLAGS $CXXFLAGS $OGG_CFLAGS $OGG_LIBS $VORBIS_CFLAGS $VORBIS_LIBS \
-- -lvorbis -logg -lm && _vorbis=yes
-+ -lvorbisidec -logg -lm && _vorbis=yes
- fi
- if test "$_vorbis" = yes ; then
- _def_vorbis='#define USE_VORBIS'
-- LIBS="$LIBS $OGG_LIBS $VORBIS_LIBS -lvorbisfile -lvorbis -logg"
-+ LIBS="$LIBS $OGG_LIBS $VORBIS_LIBS -lvorbisidec -logg"
- INCLUDES="$INCLUDES $OGG_CFLAGS $VORBIS_CFLAGS"
- else
- _def_vorbis='#undef USE_VORBIS'
diff --git a/scummvm/scummvm_0.6.0.bb b/scummvm/scummvm_0.6.0.bb
deleted file mode 100644
index e69de29bb2..0000000000
--- a/scummvm/scummvm_0.6.0.bb
+++ /dev/null
diff --git a/scummvm/scummvm_0.6.1b.bb b/scummvm/scummvm_0.6.1b.bb
deleted file mode 100644
index e69de29bb2..0000000000
--- a/scummvm/scummvm_0.6.1b.bb
+++ /dev/null