aboutsummaryrefslogtreecommitdiffstats
path: root/ssmtp
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
commitf96441b9faf769c9ecdd4d338b605ea3d0cc4010 (patch)
treeedb17ec2c4ea13c5acb1c7350957a249a820e28d /ssmtp
parentb6588aa6851fb220cedc387d21c51513ef8d67f4 (diff)
downloadopenembedded-f96441b9faf769c9ecdd4d338b605ea3d0cc4010.tar.gz
Disable bk EOLN_NATIVE conversions on all files in packages FILESPATHs, to prevent it screwing up patches.
BKrev: 4190111fA4MuVozAqwE7xOSL9fr-TA
Diffstat (limited to 'ssmtp')
-rw-r--r--ssmtp/ssmtp-2.60.9/configure.patch32
-rw-r--r--ssmtp/ssmtp-2.60.9/ldflags.patch24
-rw-r--r--ssmtp/ssmtp-2.61/configure.patch32
-rw-r--r--ssmtp/ssmtp-2.61/ldflags.patch24
4 files changed, 112 insertions, 0 deletions
diff --git a/ssmtp/ssmtp-2.60.9/configure.patch b/ssmtp/ssmtp-2.60.9/configure.patch
index e69de29bb2..2feaa8a80c 100644
--- a/ssmtp/ssmtp-2.60.9/configure.patch
+++ b/ssmtp/ssmtp-2.60.9/configure.patch
@@ -0,0 +1,32 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ssmtp-2.60/./configure.in~configure
++++ ssmtp-2.60/./configure.in
+@@ -1,5 +1,6 @@
+ dnl Process this file with autoconf to produce a configure script.
+-AC_INIT(ssmtp.c)
++AC_INIT
++AC_CONFIG_SRCDIR([ssmtp.c])
+
+ dnl Checks for programs.
+ AC_PROG_INSTALL
+@@ -13,8 +14,7 @@
+
+
+ AC_CACHE_CHECK([for obsolete openlog],ssmtp_cv_obsolete_openlog,
+- [ AC_TRY_COMPILE([#include <syslog.h> ] , [ openlog("xx",1); ] ,
+- ssmtp_cv_obsolete_openlog=yes, ssmtp_cv_obsolete_openlog=no)]
++ [ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <syslog.h> ]], [[ openlog("xx",1); ]])],[ssmtp_cv_obsolete_openlog=yes],[ssmtp_cv_obsolete_openlog=no])]
+ )
+
+
+@@ -70,4 +70,5 @@
+ fi
+ enableval=""
+
+-AC_OUTPUT(Makefile)
++AC_CONFIG_FILES([Makefile])
++AC_OUTPUT
diff --git a/ssmtp/ssmtp-2.60.9/ldflags.patch b/ssmtp/ssmtp-2.60.9/ldflags.patch
index e69de29bb2..0cbda2c85d 100644
--- a/ssmtp/ssmtp-2.60.9/ldflags.patch
+++ b/ssmtp/ssmtp-2.60.9/ldflags.patch
@@ -0,0 +1,24 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ssmtp-2.60/Makefile.in~ldflags
++++ ssmtp-2.60/Makefile.in
+@@ -36,6 +36,7 @@
+
+
+ CFLAGS=-Wall @DEFS@ $(EXTRADEFS) @CFLAGS@
++LDFLAGS=@LDFLAGS@
+
+ .PHONY: all
+ all: ssmtp
+@@ -78,7 +79,7 @@
+
+ # Binaries:
+ ssmtp: $(OBJS)
+- $(CC) -o ssmtp $(OBJS) @LIBS@
++ $(CC) -o ssmtp $(OBJS) $(LDFLAGS) @LIBS@
+
+ .PHONY: clean
+ clean:
diff --git a/ssmtp/ssmtp-2.61/configure.patch b/ssmtp/ssmtp-2.61/configure.patch
index e69de29bb2..2feaa8a80c 100644
--- a/ssmtp/ssmtp-2.61/configure.patch
+++ b/ssmtp/ssmtp-2.61/configure.patch
@@ -0,0 +1,32 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ssmtp-2.60/./configure.in~configure
++++ ssmtp-2.60/./configure.in
+@@ -1,5 +1,6 @@
+ dnl Process this file with autoconf to produce a configure script.
+-AC_INIT(ssmtp.c)
++AC_INIT
++AC_CONFIG_SRCDIR([ssmtp.c])
+
+ dnl Checks for programs.
+ AC_PROG_INSTALL
+@@ -13,8 +14,7 @@
+
+
+ AC_CACHE_CHECK([for obsolete openlog],ssmtp_cv_obsolete_openlog,
+- [ AC_TRY_COMPILE([#include <syslog.h> ] , [ openlog("xx",1); ] ,
+- ssmtp_cv_obsolete_openlog=yes, ssmtp_cv_obsolete_openlog=no)]
++ [ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <syslog.h> ]], [[ openlog("xx",1); ]])],[ssmtp_cv_obsolete_openlog=yes],[ssmtp_cv_obsolete_openlog=no])]
+ )
+
+
+@@ -70,4 +70,5 @@
+ fi
+ enableval=""
+
+-AC_OUTPUT(Makefile)
++AC_CONFIG_FILES([Makefile])
++AC_OUTPUT
diff --git a/ssmtp/ssmtp-2.61/ldflags.patch b/ssmtp/ssmtp-2.61/ldflags.patch
index e69de29bb2..0cbda2c85d 100644
--- a/ssmtp/ssmtp-2.61/ldflags.patch
+++ b/ssmtp/ssmtp-2.61/ldflags.patch
@@ -0,0 +1,24 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ssmtp-2.60/Makefile.in~ldflags
++++ ssmtp-2.60/Makefile.in
+@@ -36,6 +36,7 @@
+
+
+ CFLAGS=-Wall @DEFS@ $(EXTRADEFS) @CFLAGS@
++LDFLAGS=@LDFLAGS@
+
+ .PHONY: all
+ all: ssmtp
+@@ -78,7 +79,7 @@
+
+ # Binaries:
+ ssmtp: $(OBJS)
+- $(CC) -o ssmtp $(OBJS) @LIBS@
++ $(CC) -o ssmtp $(OBJS) $(LDFLAGS) @LIBS@
+
+ .PHONY: clean
+ clean: