aboutsummaryrefslogtreecommitdiffstats
path: root/sudo
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-01-20 05:43:54 +0000
committerChris Larson <clarson@kergoth.com>2004-01-20 05:43:54 +0000
commitb8ca3ab682cf5026455f2a73d521c6c6222839aa (patch)
tree9feeba57f1228ad366c9529ce01777571929414a /sudo
parent6901fcfdbac9341642366c4cfbf580701d78a119 (diff)
downloadopenembedded-b8ca3ab682cf5026455f2a73d521c6c6222839aa.tar.gz
BUGFIX: Correct m4 quoting in sudo autoconf macros.
BKrev: 400cc01a6OOraYo4nX6KiUhbQLkQMQ
Diffstat (limited to 'sudo')
-rw-r--r--sudo/sudo-1.6.7p5/configure.patch42
-rw-r--r--sudo/sudo_1.6.7p5.oe4
2 files changed, 44 insertions, 2 deletions
diff --git a/sudo/sudo-1.6.7p5/configure.patch b/sudo/sudo-1.6.7p5/configure.patch
index e69de29bb2..b33ea48a9d 100644
--- a/sudo/sudo-1.6.7p5/configure.patch
+++ b/sudo/sudo-1.6.7p5/configure.patch
@@ -0,0 +1,42 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sudo-1.6.7p5/configure.in~configure 2003-05-06 11:22:36.000000000 -0400
++++ sudo-1.6.7p5/configure.in 2004-01-20 00:04:46.000000000 -0500
+@@ -1652,12 +1652,14 @@
+ if test -z "$BROKEN_GETCWD"; then
+ AC_REPLACE_FUNCS(getcwd)
+ fi
+-AC_CHECK_FUNCS(lockf flock, [break])
+-AC_CHECK_FUNCS(waitpid wait3, [break])
+-AC_CHECK_FUNCS(innetgr _innetgr, [AC_CHECK_FUNCS(getdomainname) [break]])
+-AC_CHECK_FUNCS(lsearch, , [AC_CHECK_LIB(compat, lsearch, AC_CHECK_HEADER(search.h, AC_DEFINE(HAVE_LSEARCH) [LIBS="${LIBS} -lcompat"], AC_LIBOBJ(lsearch), -), AC_LIBOBJ(lsearch))])
+-AC_CHECK_FUNCS(utime, [SUDO_FUNC_UTIME_POSIX], [AC_LIBOBJ(utime)])
+-SUDO_FUNC_FNMATCH(AC_DEFINE(HAVE_FNMATCH, 1, [Define if you have the `fnmatch' function.]), AC_LIBOBJ(fnmatch))
++AC_CHECK_FUNCS(lockf flock)
++AC_CHECK_FUNCS(waitpid wait3)
++AC_CHECK_FUNCS(innetgr _innetgr, [AC_CHECK_FUNCS(getdomainname)])
++
++AC_CHECK_FUNCS(lsearch, , [AC_CHECK_LIB(compat, lsearch, [AC_CHECK_HEADER(search.h, [AC_DEFINE(HAVE_LSEARCH) LIBS="$LIBS -lcompat"], [AC_LIBOBJ([lsearch])])], [AC_LIBOBJ([lsearch])])])
++
++AC_CHECK_FUNCS(utime, [SUDO_FUNC_UTIME_POSIX], [AC_LIBOBJ([utime])])
++SUDO_FUNC_FNMATCH([AC_DEFINE([HAVE_FNMATCH], [1], [Define if you have the 'fnmatch' function.])], [AC_LIBOBJ([fnmatch])])
+ SUDO_FUNC_ISBLANK
+ AC_REPLACE_FUNCS(strerror strcasecmp sigaction strlcpy strlcat)
+ AC_CHECK_FUNCS(snprintf vsnprintf asprintf vasprintf, , [NEED_SNPRINTF=1])
+--- sudo-1.6.7p5/aclocal.m4~configure 2003-03-21 13:50:38.000000000 -0500
++++ sudo-1.6.7p5/aclocal.m4 2004-01-20 00:05:05.000000000 -0500
+@@ -244,9 +244,9 @@
+ rm -f core core.* *.core])dnl
+ AC_MSG_RESULT($sudo_cv_func_fnmatch)
+ if test $sudo_cv_func_fnmatch = yes; then
+- [$1]
++ $1
+ else
+- [$2]
++ $2
+ fi
+ ])
+
diff --git a/sudo/sudo_1.6.7p5.oe b/sudo/sudo_1.6.7p5.oe
index 6d1f9cbabc..8b55323eae 100644
--- a/sudo/sudo_1.6.7p5.oe
+++ b/sudo/sudo_1.6.7p5.oe
@@ -2,8 +2,8 @@ DEPENDS = virtual/libc
RDEPENDS = libc6
SRC_URI = ftp://ftp.sudo.ws/pub/sudo/sudo-${PV}.tar.gz \
- file://${FILESDIR}/configure.patch;patch=1 \
- file://${FILESDIR}/nonrootinstall.patch;patch=1
+ file://${FILESDIR}/nonrootinstall.patch;patch=1 \
+ file://${FILESDIR}/configure.patch;patch=1
inherit autotools