aboutsummaryrefslogtreecommitdiffstats
path: root/tslib
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-01-28 02:23:51 +0000
committerChris Larson <clarson@kergoth.com>2004-01-28 02:23:51 +0000
commitb8fbcbf83af1c65cb7bb473eb629584f18b60e13 (patch)
treebdd72d70ac86e04c485180fa3bfa992cbd915cfc /tslib
parente36d26a0efeb44042e2591d672813f3ae30ffb3e (diff)
downloadopenembedded-b8fbcbf83af1c65cb7bb473eb629584f18b60e13.tar.gz
Merge openembedded@openembedded.bkbits.net:packages
into zelda.tuxnami.org:/home/kergoth/code/packages 2004/01/27 21:21:24-05:00 local!kergoth Correct macro quoting in tetex's autotools usage. 2004/01/27 21:21:06-05:00 local!kergoth tslib updates, apply patch from Andrew Zabolotny. 2004/01/27 12:17:29-05:00 local!kergoth Another build fix.. openobex-apps this time. BKrev: 40171d37lRPuEIX7Cj76CTTmNUXu2A
Diffstat (limited to 'tslib')
-rw-r--r--tslib/tslib.oe19
-rw-r--r--tslib/tslib/automake.patch97
-rw-r--r--tslib/tslib/pthres.patch0
-rw-r--r--tslib/tslib/zap.patch0
4 files changed, 110 insertions, 6 deletions
diff --git a/tslib/tslib.oe b/tslib/tslib.oe
index 6178a81779..7303fe9fea 100644
--- a/tslib/tslib.oe
+++ b/tslib/tslib.oe
@@ -3,12 +3,19 @@ PV=${DATE}
DEPENDS = virtual/libc
RDEPENDS = libc6
-SRC_URI := cvs://cvs:@pubcvs.arm.linux.org.uk/mnt/src/cvsroot;module=tslib
-SRC_URI_append = " file://${FILESDIR}/pointercal.patch;patch=1"
-SRC_URI_append = " file://${FILESDIR}/automake.patch;patch=1"
-SRC_URI_append = " file://${FILESDIR}/configure.patch;patch=1"
-#SRC_URI_append = " file://${FILESDIR}/raw.patch;patch=1"
-#SRC_URI_append = " file://${FILESDIR}/collie-module.patch;patch=1"
+SRC_URI = cvs://cvs:@pubcvs.arm.linux.org.uk/mnt/src/cvsroot;module=tslib
+SRC_URI_append=" file://${FILESDIR}/automake.patch;patch=1"
+SRC_URI_append=" file://${FILESDIR}/zap.patch;patch=1"
+SRC_URI_append=" file://${FILESDIR}/pthres.patch;patch=1"
+#SRC_URI_append=" file://${FILESDIR}/collie-module.patch;patch=1"
+#SRC_URI_append=" file://${FILESDIR}/configure.patch;patch=1"
+#SRC_URI_append=" file://${FILESDIR}/devfs.patch;patch=1"
+#SRC_URI_append=" file://${FILESDIR}/envvar_doc.patch;patch=1"
+#SRC_URI_append=" file://${FILESDIR}/event1.patch;patch=1"
+#SRC_URI_append=" file://${FILESDIR}/multievent.patch;patch=1"
+#SRC_URI_append=" file://${FILESDIR}/pointercal.patch;patch=1"
+#SRC_URI_append=" file://${FILESDIR}/raw.patch;patch=1"
+#SRC_URI_append=" file://${FILESDIR}/ts_calibrate.patch;patch=1"
S = ${WORKDIR}/${PN}
inherit autotools libtool
diff --git a/tslib/tslib/automake.patch b/tslib/tslib/automake.patch
index e69de29bb2..711536f753 100644
--- a/tslib/tslib/automake.patch
+++ b/tslib/tslib/automake.patch
@@ -0,0 +1,97 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tslib/configure.in~automake
++++ tslib/configure.in
+@@ -22,18 +22,15 @@
+ fi
+
+ AC_MSG_CHECKING(--enable-inputapi argument)
+-AC_ARG_ENABLE(inputapi, [ --enable-inputapi Enable use of the input API [default=yes]],
+- , [enable_inputapi="yes"])
++AC_ARG_ENABLE(inputapi,
++ [ --enable-inputapi Enable use of the input API [default=no]],
++ [AC_DEFINE(USE_INPUT_API,1)],
++ [enable_inputapi="no"])
+ AC_MSG_RESULT($enable_inputapi)
+-if test "$enable_inputapi" = "yes"; then
+- INPUTAPIFLAG="-DUSE_INPUT_API"
+-else
+- INPUTAPIFLAG=""
+-fi
++AH_TEMPLATE([USE_INPUT_API],
++ [Define if using the input layer.])
+
+ AC_SUBST(DEBUGFLAGS)
+-AC_SUBST(INPUTAPIFLAG)
+-
+ AC_SUBST(PLUGINS)
+
+ AM_DISABLE_STATIC
+--- tslib/./src/Makefile.am~automake
++++ tslib/./src/Makefile.am
+@@ -9,7 +9,7 @@
+ # $Id$
+ #
+
+-CFLAGS := $(CFLAGS) -DPLUGIN_DIR=\"@PLUGIN_DIR@\" -DTS_CONF=\"@TS_CONF@\" $(DEBUGFLAGS) $(INPUTAPIFLAG)
++AM_CFLAGS = -DPLUGIN_DIR=\"@PLUGIN_DIR@\" -DTS_CONF=\"@TS_CONF@\" $(DEBUGFLAGS)
+
+ noinst_HEADERS = tslib-private.h tslib-filter.h
+ include_HEADERS = tslib.h
+--- tslib/./plugins/Makefile.am~automake
++++ tslib/./plugins/Makefile.am
+@@ -9,24 +9,24 @@
+ # $Id$
+ #
+
+-CFLAGS := $(CFLAGS) $(DEBUGFLAGS) $(INPUTAPIFLAG)
+-INCLUDES = -I$(top_srcdir)/src
+-LDFLAGS := $(LDFLAGS) -rpath $(PLUGIN_DIR)
+-#LTVSN := -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
+-# -release $(LT_RELEASE)
+-LTVSN := -avoid-version
+-LIBS =
++AM_CFLAGS = $(DEBUGFLAGS)
++AM_LDFLAGS = -rpath $(PLUGIN_DIR)
++INCLUDES = -I$(top_srcdir)/src
+
+-plugindir = $(PLUGIN_DIR)
++#LTVSN = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
++# -release $(LT_RELEASE)
++LTVSN = -avoid-version
++LIBS =
++plugindir = $(PLUGIN_DIR)
+
+-EXTRA_LTLIBRARIES = variance.la dejitter.la linear.la
+-plugin_LTLIBRARIES = $(PLUGINS)
++EXTRA_LTLIBRARIES = variance.la dejitter.la linear.la
++plugin_LTLIBRARIES = $(PLUGINS)
+
+-variance_la_SOURCES = variance.c
+-variance_la_LDFLAGS = -module $(LTVSN)
++variance_la_SOURCES = variance.c
++variance_la_LDFLAGS = -module $(LTVSN)
+
+-dejitter_la_SOURCES = dejitter.c
+-dejitter_la_LDFLAGS = -module $(LTVSN)
++dejitter_la_SOURCES = dejitter.c
++dejitter_la_LDFLAGS = -module $(LTVSN)
+
+-linear_la_SOURCES = linear.c
+-linear_la_LDFLAGS = -module $(LTVSN)
++linear_la_SOURCES = linear.c
++linear_la_LDFLAGS = -module $(LTVSN)
+--- tslib/./tests/Makefile.am~automake
++++ tslib/./tests/Makefile.am
+@@ -9,7 +9,7 @@
+ # $Id$
+ #
+
+-CFLAGS := $(CFLAGS) $(DEBUGFLAGS) $(INPUTAPIFLAG)
++AM_CFLAGS = $(DEBUGFLAGS)
+ INCLUDES = -I$(top_srcdir)/src
+
+ bin_PROGRAMS = ts_test ts_calibrate ts_print ts_print_raw
diff --git a/tslib/tslib/pthres.patch b/tslib/tslib/pthres.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/tslib/tslib/pthres.patch
diff --git a/tslib/tslib/zap.patch b/tslib/tslib/zap.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/tslib/tslib/zap.patch