aboutsummaryrefslogtreecommitdiffstats
path: root/udev
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
commitf96441b9faf769c9ecdd4d338b605ea3d0cc4010 (patch)
treeedb17ec2c4ea13c5acb1c7350957a249a820e28d /udev
parentb6588aa6851fb220cedc387d21c51513ef8d67f4 (diff)
downloadopenembedded-f96441b9faf769c9ecdd4d338b605ea3d0cc4010.tar.gz
Disable bk EOLN_NATIVE conversions on all files in packages FILESPATHs, to prevent it screwing up patches.
BKrev: 4190111fA4MuVozAqwE7xOSL9fr-TA
Diffstat (limited to 'udev')
-rw-r--r--udev/udev-042/flags.patch67
-rw-r--r--udev/udev-042/noasmlinkage.patch27
-rw-r--r--udev/udev-042/tmpfs.patch16
3 files changed, 110 insertions, 0 deletions
diff --git a/udev/udev-042/flags.patch b/udev/udev-042/flags.patch
index e69de29bb2..a5a791df33 100644
--- a/udev/udev-042/flags.patch
+++ b/udev/udev-042/flags.patch
@@ -0,0 +1,67 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- udev-042/Makefile~flags
++++ udev-042/Makefile
+@@ -119,16 +119,18 @@
+ endif
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DLOG
++ override CFLAGS += -DLOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip or optimize
++override CFLAGS += -D_GNU_SOURCE
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -O1 -g -DDEBUG -D_GNU_SOURCE
++ CFLAGS += -O1 -g
++ override CFLAGS += -DDEBUG
+ LDFLAGS += -Wl,-warn-common
+ STRIPCMD = /bin/true -Since_we_are_debugging
+ else
+- CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer -D_GNU_SOURCE
++ CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer
+ LDFLAGS += -s -Wl,-warn-common
+ STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
+ endif
+@@ -150,8 +152,8 @@
+
+ CRT0 = $(KLIBC_DIR)/crt0.o
+ LIBC = $(ARCH_LIB_OBJS) $(LIB_OBJS) $(CRT0)
+- CFLAGS += $(WARNINGS) -nostdinc \
+- $(OPTFLAGS) \
++ CFLAGS += $(WARNINGS) $(OPTFLAGS)
++ override CFLAGS += -nostdinc \
+ -D__KLIBC__ -fno-builtin-printf \
+ -I$(KLIBC_FIXUPS_DIR) \
+ -include $(KLIBC_FIXUPS_DIR)/klibc_fixups.h \
+@@ -161,12 +163,13 @@
+ -I$(GCCINCDIR) \
+ -I$(LINUX_INCLUDE_DIR)
+ LIB_OBJS =
+- LDFLAGS = --static --nostdlib -nostartfiles -nodefaultlibs
++ override LDFLAGS += --static --nostdlib -nostartfiles -nodefaultlibs
+ else
+ WARNINGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
+ CRT0 =
+ LIBC =
+- CFLAGS += $(WARNINGS) -I$(GCCINCDIR)
++ CFLAGS += $(WARNINGS)
++ override CFLAGS += -I$(GCCINCDIR)
+ LIB_OBJS = -lc
+ LDFLAGS =
+ endif
+@@ -176,8 +179,8 @@
+ LIB_OBJS += -lselinux
+ endif
+
+-CFLAGS += -I$(PWD)/libsysfs/sysfs \
+- -I$(PWD)/libsysfs
++override CFLAGS += -I$(PWD)/libsysfs/sysfs \
++ -I$(PWD)/libsysfs
+
+ # config files automatically generated
+ GEN_CONFIGS = $(LOCAL_CFG_DIR)/udev.conf
diff --git a/udev/udev-042/noasmlinkage.patch b/udev/udev-042/noasmlinkage.patch
index e69de29bb2..1694d4d661 100644
--- a/udev/udev-042/noasmlinkage.patch
+++ b/udev/udev-042/noasmlinkage.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- udev-042/udev.c~noasmlinkage
++++ udev-042/udev.c
+@@ -60,7 +60,7 @@
+ }
+ #endif
+
+-static void asmlinkage sig_handler(int signum)
++static void sig_handler(int signum)
+ {
+ switch (signum) {
+ case SIGALRM:
+--- udev-042/udevd.c~noasmlinkage
++++ udev-042/udevd.c
+@@ -308,7 +308,7 @@
+ return;
+ }
+
+-static void asmlinkage sig_handler(int signum)
++static void sig_handler(int signum)
+ {
+ int rc;
+
diff --git a/udev/udev-042/tmpfs.patch b/udev/udev-042/tmpfs.patch
index e69de29bb2..9d0d8b4515 100644
--- a/udev/udev-042/tmpfs.patch
+++ b/udev/udev-042/tmpfs.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- udev-031/extras/start_udev~tmpfs 2004-09-10 17:10:03.000000000 -0400
++++ udev-031/extras/start_udev 2004-09-11 15:18:15.560789160 -0400
+@@ -85,7 +85,7 @@
+ fi
+
+ echo "mounting... ramfs at $udev_root"
+-mount -n -t ramfs none $udev_root
++mount -n -t ramfs none $udev_root || mount -n -t tmpfs none $udev_root
+
+ # propogate /udev from /sys
+ echo "Creating initial udev device nodes:"