aboutsummaryrefslogtreecommitdiffstats
path: root/usermanual/usermanual.xml
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-05-13 20:54:26 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-13 20:54:26 +0000
commit10b785cbae1b84736810777e0783a62dd0d9f7f5 (patch)
tree3d5fb750acf74eafb3e86a6ded376b53e27a4989 /usermanual/usermanual.xml
parent0eba4c8c52c5044f040b31cc60ba94bf15fed0b9 (diff)
downloadopenembedded-10b785cbae1b84736810777e0783a62dd0d9f7f5.tar.gz
usermanual:
use BitBake not bitbake, Bitbake, BitNake, Nakebake... use <application> and <command> whatever they result in
Diffstat (limited to 'usermanual/usermanual.xml')
-rw-r--r--usermanual/usermanual.xml24
1 files changed, 12 insertions, 12 deletions
diff --git a/usermanual/usermanual.xml b/usermanual/usermanual.xml
index 34417379dc..24676eb0c6 100644
--- a/usermanual/usermanual.xml
+++ b/usermanual/usermanual.xml
@@ -30,8 +30,8 @@
<title>Introduction</title>
<section>
<title>Overview</title>
- <para><ulink url="http://www.openembedded.org">OpenEmbedded</ulink> is a set of metadata used to crosscompile, package and install software packages. OpenEmbedded is being used to build and maintain a number of embedded Linux distributions, including OpenZaurus, Familiar and SlugOS.</para>
- <para>The primary usecase of OpenEmbedded are:
+ <para><ulink url="http://www.openembedded.org"><application>OpenEmbedded</application></ulink> is a set of metadata used to crosscompile, package and install software packages. <application>OpenEmbedded</application> is being used to build and maintain a number of embedded Linux distributions, including OpenZaurus, Familiar and SlugOS.</para>
+ <para>The primary usecase of <application>OpenEmbedded</application> are:
<itemizedlist>
<listitem><para>Handle crosscompilation.</para></listitem>
<listitem><para>Handle interpackage dependencies</para></listitem>
@@ -41,7 +41,7 @@
<listitem><para>Writing of metadata must be easy and reusable</para></listitem>
</itemizedlist>
</para>
- <para>Together with <ulink url="http://bitbake.berlios.de/manual">BitBake</ulink>, OpenEmbedded satisfies all these and many more. Flexibility and power have always been the priorities.</para>
+ <para>Together with <ulink url="http://bitbake.berlios.de/manual"><application>BitBake</application></ulink>, OpenEmbedded satisfies all these and many more. Flexibility and power have always been the priorities.</para>
</section>
@@ -52,7 +52,7 @@ At this time the project had pushed <emphasis>buildroot</emphasis> to its limits
<emphasis>ipk</emphasis> packages, feeds and images and had support for more than one machine. But it was impossible
to use different patches, files for different architectures, machines or distributions. To overcome this shortcoming
OpenEmbedded was created.</para>
- <para>After a few months other projects started using OpenEmbedded and contributing back. On 7 December 2004 Chris Larson split the project into two parts: Bitbake, a generic task executor and OpenEmbedded, the metadata for bitbake.</para>
+ <para>After a few months other projects started using OpenEmbedded and contributing back. On 7 December 2004 Chris Larson split the project into two parts: BitBake, a generic task executor and OpenEmbedded, the metadata for BitBake.</para>
</section>
</chapter>
@@ -61,23 +61,23 @@ OpenEmbedded was created.</para>
<title>Metadata</title>
<section>
<title>File Layout</title>
- <para>OpenEmbedded has three directories holding BitBake metadata <emphasis>conf</emphasis>,
+ <para>OpenEmbedded has three directories holding <application>BitBake</application> metadata <emphasis>conf</emphasis>,
<emphasis>classes</emphasis> and <emphasis>packaes</emphasis>. FIXME</para>
</section>
<section>
<title>Syntax</title>
<para>OpenEmbedded has files ending with <emphasis>.conf</emphasis>, <emphasis>.inc</emphasis>,
<emphasis>.bb</emphasis> and<emphasis>.bbclass</emphasis>. The syntax and semantic of these files are best
-described in the <ulink url="http://bitbake.berlios.de/manual">BitBake manual</ulink>. </para>
+described in the <ulink url="http://bitbake.berlios.de/manual"><application>BitBake</application> manual</ulink>. </para>
</section>
<section>
<title>Classes</title>
- <para>OpenEmbedded provides special BitBake classes to ease compiling, packaging and other things. FIXME.</para>
+ <para>OpenEmbedded provides special <application>BitBake</application> classes to ease compiling, packaging and other things. FIXME.</para>
</section>
<section>
<title>Writing Meta Data (Adding packages)</title>
<para>
-This page will guide you trough the effort of writing a .bb file or <emphasis>recipe</emphasis> in bitbake speak.
+This page will guide you trough the effort of writing a .bb file or <emphasis>recipe</emphasis> in BitBake speak.
Let's start with the easy stuff, like the package description, license, etc:
@@ -111,7 +111,7 @@ SRC_URI = "http://www.host.com/foo/files/${P}.tar.bz2;md5sum=yoursum"
</screen>
-This will tell the fetcher to where to download the sources from and it will check the integrity using md5sum if you provided the appropriate <emphasis>yoursum</emphasis>. You can make one by doing <screen>md5sum foo-3.2.2.tar.gz</screen> and replacing <emphasis>yoursum</emphasis> with the md5sum on your screen. A typical md5sum will look like this: <screen>a6434b0fc8a54c3dec3d6875bf3be8db </screen>Notice the <emphasis>${P}</emphasis> variable, that one holds the package name, <emphasis>${PN}</emphasis> in bitbake speak and the package version, <emphasis>${PV}</emphasis> in bitbake speak. It's a short way of writing <emphasis>${PN}-${PV}</emphasis>. Using this notation means you can copy the recipe when a new version is released without having to alter the contents. You do need to check if everything is still correct, because new versions mean new bugs.
+This will tell the fetcher to where to download the sources from and it will check the integrity using md5sum if you provided the appropriate <emphasis>yoursum</emphasis>. You can make one by doing <screen>md5sum foo-3.2.2.tar.gz</screen> and replacing <emphasis>yoursum</emphasis> with the md5sum on your screen. A typical md5sum will look like this: <screen>a6434b0fc8a54c3dec3d6875bf3be8db </screen>Notice the <emphasis>${P}</emphasis> variable, that one holds the package name, <emphasis>${PN}</emphasis> in BitBake speak and the package version, <emphasis>${PV}</emphasis> in BitBake speak. It's a short way of writing <emphasis>${PN}-${PV}</emphasis>. Using this notation means you can copy the recipe when a new version is released without having to alter the contents. You do need to check if everything is still correct, because new versions mean new bugs.
Before we can move to the actual building we need to find out which build system the package is using. If we're lucky, we see a <emphasis>configure</emphasis> file in the build tree this is an indicator that we can <emphasis>inherit autotools</emphasis> if we see a <emphasis>.pro</emphasis> file, it might be qmake, which needs <emphasis>inherit qmake</emphasis>. Virtually all gtk apps use autotools:
@@ -127,7 +127,7 @@ Lets start the build:
<screen>
-bitbake foo
+<command>bitbake</command> foo
</screen>
@@ -175,7 +175,7 @@ It's important to use <emphasis>+=</emphasis> so it will get appended to the sta
<chapter>
<title>Getting OpenEmbedded</title>
<section>
- <title>Getting BitBake</title>
+ <title>Getting <application>BitBake</application></title>
<para></para>
</section>
@@ -283,7 +283,7 @@ arm-linux-objdump
the buildsystem they use to build their software. This will lead to a variety of issues you can run into. This can be failing
tests on configuration because of executing cross compiled binaries or crashes at runtime due wrong sizes of basic types.
When utilizing OpenEmbedded you avoid searching for patches at many different places and will be able to get things done more quickly.
-OpenEmbedded allows you to chooose from a pool of ready to use software packages, allow creation of images and many more.</para>
+<application>OpenEmbedded</application> allows you to chooose from a pool of ready to use software packages, allow creation of images and many more.</para>
</section>
</chapter>
</book>