aboutsummaryrefslogtreecommitdiffstats
path: root/usermanual
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-05-04 06:19:30 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-05-04 06:19:30 +0000
commit6c78836b83609a6be795c52d07c44ea27a54f6b7 (patch)
tree675fc6d4c3d6e1094aea5d2d23b720c83dc1fcc6 /usermanual
parente1cc792c540fe305f094a79ff633fe63110d7d4a (diff)
downloadopenembedded-6c78836b83609a6be795c52d07c44ea27a54f6b7.tar.gz
usermanual: Modify the Makefile so that "make <type>" works for the
following types: dvi, pdf, ps, rtf, tex, texi and txt. This is in addition to html and xhtml were already working. Update the readme to give a guide as to what packages you need on the host for these to work.
Diffstat (limited to 'usermanual')
-rw-r--r--usermanual/Makefile8
-rw-r--r--usermanual/README19
2 files changed, 24 insertions, 3 deletions
diff --git a/usermanual/Makefile b/usermanual/Makefile
index 1562893228..5649442ed5 100644
--- a/usermanual/Makefile
+++ b/usermanual/Makefile
@@ -2,8 +2,9 @@ topdir = .
manual = $(topdir)/usermanual.xml
# types = pdf txt rtf ps xhtml html man tex texi dvi
# types = pdf txt
-types = $(xmltotypes) $(htmltypes)
-xmltotypes = pdf txt
+types = $(xmltotypes) $(htmltypes) $(docbooktotypes)
+xmltotypes =
+docbooktotypes = dvi pdf ps rtf tex texi txt
htmltypes = html xhtml
htmlxsl = $(if $(filter $@,$(foreach type,$(htmltypes),$(type)-nochunks)),docbook-utf8.xsl,http://docbook.sourceforge.net/release/xsl/current/$@/chunk.xsl)
htmlcssfile = docbook.css
@@ -47,6 +48,9 @@ endif
$(xmltotypes): $(manual)
$(call command,xmlto --extensions -o $(topdir)/$@ $@ $(manual),XMLTO $@ $(manual))
+$(docbooktotypes): $(manual)
+ $(call command,docbook2$@ $(manual),DOCBOOK2 $@ $(manual))
+
clean:
rm -rf $(cleanfiles)
diff --git a/usermanual/README b/usermanual/README
index 9f1f399a4c..f2aecf8a6e 100644
--- a/usermanual/README
+++ b/usermanual/README
@@ -1 +1,18 @@
-use 'docbook2pdf usermanual.xml' to generate a pdf version, because doing it via the Makefile doesn't work
+To generate the user-manual, run:
+
+ make <type>
+
+in this directory, where type is one of:
+
+ xhtml
+ html
+ dvi
+ pdf
+ ps
+ rtf
+ tex
+ texi
+ txt
+
+For html and xhtml you need xsltproc installed.
+For the other you need docbook-utils installed.