aboutsummaryrefslogtreecommitdiffstats
path: root/zcip
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-09 09:47:41 +0000
committerChris Larson <clarson@kergoth.com>2004-12-09 09:47:41 +0000
commit2c5b8ec6d95cf68650265941530e5ce38c8dd6d9 (patch)
treebf879bea7ef8517ba8c3d1286ef300401d3d484c /zcip
parent101e2f1623def0a355d20aacb8bd93810703e834 (diff)
downloadopenembedded-2c5b8ec6d95cf68650265941530e5ce38c8dd6d9.tar.gz
Merge oe-devel@oe-devel.bkbits.net:openembedded
into hyperion.kergoth.com:/home/kergoth/code/openembedded 2004/12/09 03:39:39-06:00 kergoth.com!kergoth Break people's builds again.. this time moving the packages into a packages/ subdir to clean things up a bit. BKrev: 41b81f3dvlp3rU7_8MUXLcI8LDdDoA
Diffstat (limited to 'zcip')
-rw-r--r--zcip/zcip-4/char-signed-idiocy.patch16
-rw-r--r--zcip/zcip-4/compile.patch125
-rw-r--r--zcip/zcip-4/linux-types.patch15
-rw-r--r--zcip/zcip_4.bb0
4 files changed, 0 insertions, 156 deletions
diff --git a/zcip/zcip-4/char-signed-idiocy.patch b/zcip/zcip-4/char-signed-idiocy.patch
deleted file mode 100644
index 109efc2349..0000000000
--- a/zcip/zcip-4/char-signed-idiocy.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- zcip-4/zcip.c~char-signed-idiocy
-+++ zcip-4/zcip.c
-@@ -1243,7 +1243,7 @@
-
- int main(int argc, char *argv[]) {
- int r, rand_seed = 0;
-- char c;
-+ int c;
- char ebuf[LIBNET_ERRBUF_SIZE];
-
- struct option longopts[] = {
diff --git a/zcip/zcip-4/compile.patch b/zcip/zcip-4/compile.patch
deleted file mode 100644
index a8cfa32cd8..0000000000
--- a/zcip/zcip-4/compile.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- zcip-4/Makefile~compile
-+++ zcip-4/Makefile
-@@ -5,21 +5,17 @@
- CPPFLAGS=`libnet-config --cflags` `libnet-config --defines`
- CFLAGS=-O2 -Wall -W -I/usr/local/contrib/include -I/usr/local/include/pcap
- LDFLAGS=-L/usr/local/contrib/lib -L/usr/local/lib -static
--
--
-+LIBS=-lpcap `libnet-config --libs`
- OBJS=zcip.o
-
--
--
--
- all: zcip make-arp
-
-
- make-arp: make-arp.o
-- $(CC) make-arp.o $(LDFLAGS) -o make-arp -lpcap `libnet-config --libs`
-+ $(CC) make-arp.o $(LDFLAGS) -o make-arp $(LIBS)
-
- zcip: $(OBJS)
-- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o zcip -lpcap `libnet-config --libs`
-+ $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o zcip $(LIBS)
-
-
- clean:
---- zcip-4/zcip.c~compile
-+++ zcip-4/zcip.c
-@@ -1204,14 +1204,14 @@
- }
-
- void version(void) {
-- printf("zcip release " RELEASE "
--Copyright (C) 2001-2002 Various authors
--zcip comes with NO WARRANTY,
--to the extent permitted by law.
--You may redistribute copies of zcip
--under the terms of the 3-clause BSD license.
--For more information about these matters,
--see the file named Copyright.
-+ printf("zcip release " RELEASE "\n\
-+Copyright (C) 2001-2002 Various authors\n\
-+zcip comes with NO WARRANTY,\n\
-+to the extent permitted by law.\n\
-+You may redistribute copies of zcip\n\
-+under the terms of the 3-clause BSD license.\n\
-+For more information about these matters,\n\
-+see the file named Copyright.\n\
- ");
-
- exit (0);
-@@ -1219,19 +1219,19 @@
-
-
- void usage(int exit_code) {
-- printf("usage: zcip [OPTIONS]
--Zeroconf IPv4 Link-Local Address Configuration
--OPTIONS:
-- -h, --help Print this help, and exit.
-- -i, --interface IFNAME Use interface IFNAME.
-- If not provided it uses 'eth0'.
-- -r, --randseed Seeds RNG with random # rather than MAC address.
-- -s, --syslog Output to syslog instead of stdout.
-- -v, --version Print the version information, and exit.
--
--This program does the ad-hoc link-local IPv4 auto-configuration trick, as
--described in the IETF Internet Draft 'Dynamic Configuration of IPv4
--Link-Local Addresses'.
-+ printf("usage: zcip [OPTIONS]\n\
-+Zeroconf IPv4 Link-Local Address Configuration\n\
-+OPTIONS:\n\
-+ -h, --help Print this help, and exit.\n\
-+ -i, --interface IFNAME Use interface IFNAME.\n\
-+ If not provided it uses 'eth0'.\n\
-+ -r, --randseed Seeds RNG with random # rather than MAC address.\n\
-+ -s, --syslog Output to syslog instead of stdout.\n\
-+ -v, --version Print the version information, and exit.\n\
-+\n\
-+This program does the ad-hoc link-local IPv4 auto-configuration trick, as\n\
-+described in the IETF Internet Draft 'Dynamic Configuration of IPv4\n\
-+Link-Local Addresses'.\n\
- ");
-
- exit (exit_code);
---- zcip-4/make-arp.c~compile
-+++ zcip-4/make-arp.c
-@@ -106,19 +106,19 @@
-
-
- void usage(int exit_code) {
-- printf("
--make-arp -- sends arbitrary ARP Requests
--
--usage: make-arp [OPTIONS] [sea=SOURCE-EA] [sip=SOURCE-IP] tea=TARGET-EA tip=TARGET-IP
--
--OPTIONS:
--
-- -h Print this help.
--
--
--Only ARP Requests for now. In the Ethernet header, the source EA is
--mine and the target EA is the broadcast address FF:FF:FF:FF:FF:FF.
--
-+ printf("\n\
-+make-arp -- sends arbitrary ARP Requests\n\
-+\n\
-+usage: make-arp [OPTIONS] [sea=SOURCE-EA] [sip=SOURCE-IP] tea=TARGET-EA tip=TARGET-IP\n\
-+\n\
-+OPTIONS:\n\
-+\n\
-+ -h Print this help.\n\
-+\n\
-+\n\
-+Only ARP Requests for now. In the Ethernet header, the source EA is\n\
-+mine and the target EA is the broadcast address FF:FF:FF:FF:FF:FF.\n\
-+\n\
- ");
-
- exit (exit_code);
diff --git a/zcip/zcip-4/linux-types.patch b/zcip/zcip-4/linux-types.patch
deleted file mode 100644
index 5ca388cafc..0000000000
--- a/zcip/zcip-4/linux-types.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- zcip-4/zcip.c~linux-types
-+++ zcip-4/zcip.c
-@@ -163,6 +163,7 @@
- #endif
-
- #ifdef CHECK_KERNEL_SOCKETFILTERS
-+#include <linux/types.h>
- #include <linux/filter.h>
-
- //
diff --git a/zcip/zcip_4.bb b/zcip/zcip_4.bb
deleted file mode 100644
index e69de29bb2..0000000000
--- a/zcip/zcip_4.bb
+++ /dev/null