aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/vnc/files/x11vnc-0.9.8-xshm-header-fix.patch15
-rw-r--r--recipes/vnc/x11vnc_0.9.8.bb4
2 files changed, 18 insertions, 1 deletions
diff --git a/recipes/vnc/files/x11vnc-0.9.8-xshm-header-fix.patch b/recipes/vnc/files/x11vnc-0.9.8-xshm-header-fix.patch
new file mode 100644
index 0000000000..3383f63365
--- /dev/null
+++ b/recipes/vnc/files/x11vnc-0.9.8-xshm-header-fix.patch
@@ -0,0 +1,15 @@
+Looks like X_ShmAttach is considered private to the library and has been removed from its headers.
+Just hardcode the value, it's only usd to print some help in case of an shm attach error.
+--- x11vnc-0.9.8/x11vnc/cleanup.c
++++ x11vnc-0.9.8/x11vnc/cleanup.c
+@@ -276,6 +276,10 @@
+ return 0;
+ }
+
++#ifndef X_ShmAttach
++#define X_ShmAttach 1
++#endif
++
+ static int Xerror(Display *d, XErrorEvent *error) {
+ X_UNLOCK;
+
diff --git a/recipes/vnc/x11vnc_0.9.8.bb b/recipes/vnc/x11vnc_0.9.8.bb
index f3d706be5b..fd29d278e0 100644
--- a/recipes/vnc/x11vnc_0.9.8.bb
+++ b/recipes/vnc/x11vnc_0.9.8.bb
@@ -5,6 +5,8 @@ SECTION = "x11/utils"
LICENSE = "GPL"
DEPENDS = "openssl virtual/libx11 libxtst libxext avahi jpeg zlib"
-SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/x11vnc-${PV}.tar.gz"
+PR = "r1"
+SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/x11vnc-${PV}.tar.gz \
+ file://x11vnc-0.9.8-xshm-header-fix.patch;patch=1"
inherit autotools