aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini8
-rw-r--r--recipes/gstreamer/gst-ffmpeg_0.10.7.bb2
-rw-r--r--recipes/gstreamer/gst-ffmpeg_0.10.8.bb26
3 files changed, 35 insertions, 1 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 3eb9f6fd2e..1377816bcc 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -10030,6 +10030,10 @@ sha256=c9a5f4c9b1eddd7cb042d83390072f832f19f3712d023e4d6568391e5eb4878a
md5=6be89b26592f36ef631b22a68b8e06c4
sha256=94bd5110a03837145afe5c81760f22bd7bef9ef455f4417340eeeb2b12e54fb0
+[http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-0.10.8.tar.bz2]
+md5=a7177f85c87d404a3c0d511b835129d1
+sha256=d9e056793d05bf0b6f4989b27d3107c2f223a14205ee54be403bbe52945c8853
+
[http://core.fluendo.com/gstreamer/src/gst-fluendo-mp3/gst-fluendo-mp3-0.10.2.tar.bz2]
md5=f3c32e0bc3ec1be461ce43e407a6a67f
sha256=cba1eac94de8de8c181c6c60dfc59f8069d388761aba71bcd8c48b8ba9b2edf5
@@ -11490,6 +11494,10 @@ sha256=84a111a6a979152cd25b60825b4945da4b167f19fb9ec115f9c59b4b49927547
md5=a593b2eabde56f122e2bb3d2d45f7ca7
sha256=90f69ae24cc21fa6d33dc406077f16c06113b3000f7d267e7056e52f50d0abc0
+[http://heanet.dl.sourceforge.net/inotify-tools/inotify-tools-3.12.tar.gz]
+md5=a593b2eabde56f122e2bb3d2d45f7ca7
+sha256=90f69ae24cc21fa6d33dc406077f16c06113b3000f7d267e7056e52f50d0abc0
+
[http://downloads.sourceforge.net/inotify-tools/inotify-tools-3.13.tar.gz]
md5=35d7178297390f18bae451e083362acf
sha256=464146acec2c118be63a6c2a090d9252fbe9689c093db85b695d0502fa229445
diff --git a/recipes/gstreamer/gst-ffmpeg_0.10.7.bb b/recipes/gstreamer/gst-ffmpeg_0.10.7.bb
index 20cea128dd..32b59f61ca 100644
--- a/recipes/gstreamer/gst-ffmpeg_0.10.7.bb
+++ b/recipes/gstreamer/gst-ffmpeg_0.10.7.bb
@@ -4,7 +4,7 @@ PRIORITY = "optional"
LICENSE = "LGPL"
HOMEPAGE = "http://www.gstreamer.net/"
DEPENDS = "ffmpeg gstreamer gst-plugins-base zlib"
-PR = "r1"
+PR = "r2"
inherit autotools pkgconfig
diff --git a/recipes/gstreamer/gst-ffmpeg_0.10.8.bb b/recipes/gstreamer/gst-ffmpeg_0.10.8.bb
new file mode 100644
index 0000000000..70d8556334
--- /dev/null
+++ b/recipes/gstreamer/gst-ffmpeg_0.10.8.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "FFmpeg-based GStreamer plug-in"
+SECTION = "multimedia"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+HOMEPAGE = "http://www.gstreamer.net/"
+DEPENDS = "ffmpeg gstreamer gst-plugins-base zlib"
+
+inherit autotools pkgconfig
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2 \
+ file://lower-rank.diff;patch=1 \
+"
+
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
+
+EXTRA_OECONF = " --with-system-ffmpeg "
+
+# We do this because the install program is called with -s which causes it to
+# call "strip" and it then mangles cross compiled stuff..
+PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
+
+# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
+CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
+