aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/base.bbclass6
-rw-r--r--classes/bootimg.bbclass8
-rw-r--r--classes/image.bbclass8
-rw-r--r--classes/insane.bbclass2
-rw-r--r--classes/kernel.bbclass2
-rw-r--r--classes/mono.bbclass2
-rw-r--r--classes/package.bbclass2
-rw-r--r--classes/package_deb.bbclass4
-rw-r--r--classes/package_ipk.bbclass6
-rw-r--r--classes/package_rpm.bbclass4
-rw-r--r--classes/package_tar.bbclass4
-rw-r--r--classes/packaged-staging.bbclass26
-rw-r--r--classes/patch.bbclass2
-rw-r--r--classes/rootfs_deb.bbclass2
-rw-r--r--classes/rootfs_ipk.bbclass2
-rw-r--r--classes/rootfs_rpm.bbclass4
-rw-r--r--classes/sanity.bbclass7
-rw-r--r--classes/sip.bbclass2
-rw-r--r--classes/sip3.bbclass2
-rw-r--r--classes/srctree.bbclass12
-rw-r--r--classes/staging.bbclass21
-rw-r--r--conf/abi_version.conf2
-rw-r--r--conf/bitbake.conf2
-rw-r--r--contrib/qa/bugzilla.py2
-rw-r--r--recipes/apex/apex-nslu2-16mb_1.5.14.bb2
-rw-r--r--recipes/apex/apex-nslu2_1.5.14.bb2
-rw-r--r--recipes/faad2/faad2_2.0.bb2
-rw-r--r--recipes/freedoom/freedoom_0.3.bb2
-rw-r--r--recipes/freedoom/freedoom_0.6.2.bb2
-rw-r--r--recipes/gnuradio/gnuradio-libusb-compat.inc2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe-native_2.1.bb2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe-native_2.4.bb2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe_2.1.bb2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe_2.3.2.bb2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe_2.4.bb2
-rw-r--r--recipes/jpeg/jasper_1.900.1.bb2
-rw-r--r--recipes/juce/juce_1.29.bb2
-rw-r--r--recipes/klimt/klimt_0.6.1.bb2
-rw-r--r--recipes/librcf/librcf_0.4.bb2
-rw-r--r--recipes/linux/compulab-pxa270_2.6.16.bb2
-rw-r--r--recipes/miglayout/miglayout_3.0.3.bb2
-rw-r--r--recipes/misc-binary-only/tda1004x-firmware.bb2
-rw-r--r--recipes/ogre/freeimage_3.11.0.bb2
-rw-r--r--recipes/zaurus-utils/zaurus-updater.bb5
45 files changed, 94 insertions, 85 deletions
diff --git a/classes/base.bbclass b/classes/base.bbclass
index 31b551a9a2..3c854c6e7b 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -325,7 +325,7 @@ python base_eventhandler() {
addtask configure after do_unpack do_patch
do_configure[dirs] = "${S} ${B}"
-do_configure[deptask] = "do_populate_staging"
+do_configure[deptask] = "do_populate_sysroot"
base_do_configure() {
:
}
@@ -393,7 +393,7 @@ python () {
srcuri = bb.data.getVar('SRC_URI', d, 1)
if "git://" in srcuri:
depends = bb.data.getVarFlag('do_fetch', 'depends', d) or ""
- depends = depends + " git-native:do_populate_staging"
+ depends = depends + " git-native:do_populate_sysroot"
bb.data.setVarFlag('do_fetch', 'depends', depends, d)
# unzip-native should already be staged before unpacking ZIP recipes
@@ -402,7 +402,7 @@ python () {
if ".zip" in src_uri or need_unzip == "1":
depends = bb.data.getVarFlag('do_unpack', 'depends', d) or ""
- depends = depends + " unzip-native:do_populate_staging"
+ depends = depends + " unzip-native:do_populate_sysroot"
bb.data.setVarFlag('do_unpack', 'depends', depends, d)
# 'multimachine' handling
diff --git a/classes/bootimg.bbclass b/classes/bootimg.bbclass
index d58cf1f424..35b0d76b4e 100644
--- a/classes/bootimg.bbclass
+++ b/classes/bootimg.bbclass
@@ -12,10 +12,10 @@
# ${APPEND} - an override list of append strings for each label
# ${SYSLINUX_OPTS} - additional options to add to the syslinux file ';' delimited
-do_bootimg[depends] += "dosfstools-native:do_populate_staging \
- syslinux-native:do_populate_staging \
- mtools-native:do_populate_staging \
- cdrtools-native:do_populate_staging"
+do_bootimg[depends] += "dosfstools-native:do_populate_sysroot \
+ syslinux-native:do_populate_sysroot \
+ mtools-native:do_populate_sysroot \
+ cdrtools-native:do_populate_sysroot"
PACKAGES = " "
diff --git a/classes/image.bbclass b/classes/image.bbclass
index 614d368c9b..f695d3c4df 100644
--- a/classes/image.bbclass
+++ b/classes/image.bbclass
@@ -36,7 +36,7 @@ IMAGE_BASENAME[export] = "1"
export PACKAGE_INSTALL ?= "${IMAGE_INSTALL} ${IMAGE_BOOT}"
# We need to recursively follow RDEPENDS and RRECOMMENDS for images
-do_rootfs[recrdeptask] += "do_deploy do_populate_staging"
+do_rootfs[recrdeptask] += "do_deploy do_populate_sysroot"
# Images are generally built explicitly, do not need to be part of world.
EXCLUDE_FROM_WORLD = "1"
@@ -47,7 +47,7 @@ PID = "${@os.getpid()}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-do_rootfs[depends] += "makedevs-native:do_populate_staging fakeroot-native:do_populate_staging"
+do_rootfs[depends] += "makedevs-native:do_populate_sysroot fakeroot-native:do_populate_sysroot"
python () {
import bb
@@ -55,9 +55,9 @@ python () {
deps = bb.data.getVarFlag('do_rootfs', 'depends', d) or ""
for type in (bb.data.getVar('IMAGE_FSTYPES', d, True) or "").split():
for dep in ((bb.data.getVar('IMAGE_DEPENDS_%s' % type, d) or "").split() or []):
- deps += " %s:do_populate_staging" % dep
+ deps += " %s:do_populate_sysroot" % dep
for dep in (bb.data.getVar('EXTRA_IMAGEDEPENDS', d, True) or "").split():
- deps += " %s:do_populate_staging" % dep
+ deps += " %s:do_populate_sysroot" % dep
bb.data.setVarFlag('do_rootfs', 'depends', deps, d)
runtime_mapping_rename("PACKAGE_INSTALL", d)
diff --git a/classes/insane.bbclass b/classes/insane.bbclass
index 923751d029..af6cec3a96 100644
--- a/classes/insane.bbclass
+++ b/classes/insane.bbclass
@@ -445,7 +445,7 @@ python do_package_qa () {
# The Staging Func, to check all staging
-addtask qa_staging after do_populate_staging before do_build
+addtask qa_staging after do_populate_sysroot before do_build
python do_qa_staging() {
bb.debug(2, "QA checking staging")
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index f27b24ebcc..989d3e3a21 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -549,6 +549,6 @@ do_deploy() {
}
do_deploy[dirs] = "${S}"
-do_deploy[depends] += "fakeroot-native:do_populate_staging"
+do_deploy[depends] += "fakeroot-native:do_populate_sysroot"
addtask deploy before do_build after do_package
diff --git a/classes/mono.bbclass b/classes/mono.bbclass
index cf8dd15bdf..c3dc87c905 100644
--- a/classes/mono.bbclass
+++ b/classes/mono.bbclass
@@ -152,7 +152,7 @@ do_mono_stage() {
fi
done
}
-addtask mono_stage after do_package before do_populate_staging
+addtask mono_stage after do_package before do_populate_sysroot
def mono_after_parse(d):
import bb
diff --git a/classes/package.bbclass b/classes/package.bbclass
index 910d282a01..77a20bf9c5 100644
--- a/classes/package.bbclass
+++ b/classes/package.bbclass
@@ -138,7 +138,7 @@ python () {
if bb.data.getVar('PACKAGES', d, True) != '':
deps = bb.data.getVarFlag('do_package', 'depends', d) or ""
for dep in (bb.data.getVar('PACKAGE_DEPENDS', d, True) or "").split():
- deps += " %s:do_populate_staging" % dep
+ deps += " %s:do_populate_sysroot" % dep
bb.data.setVarFlag('do_package', 'depends', deps, d)
deps = (bb.data.getVarFlag('do_package', 'deptask', d) or "").split()
diff --git a/classes/package_deb.bbclass b/classes/package_deb.bbclass
index 9fb16740d8..837efd8438 100644
--- a/classes/package_deb.bbclass
+++ b/classes/package_deb.bbclass
@@ -254,8 +254,8 @@ python do_package_deb () {
python () {
if bb.data.getVar('PACKAGES', d, True) != '':
deps = (bb.data.getVarFlag('do_package_write_deb', 'depends', d) or "").split()
- deps.append('dpkg-native:do_populate_staging')
- deps.append('fakeroot-native:do_populate_staging')
+ deps.append('dpkg-native:do_populate_sysroot')
+ deps.append('fakeroot-native:do_populate_sysroot')
bb.data.setVarFlag('do_package_write_deb', 'depends', " ".join(deps), d)
}
diff --git a/classes/package_ipk.bbclass b/classes/package_ipk.bbclass
index 031c658762..435d59fb06 100644
--- a/classes/package_ipk.bbclass
+++ b/classes/package_ipk.bbclass
@@ -71,7 +71,7 @@ do_package_update_index_ipk[lockfiles] = "${DEPLOY_DIR_IPK}.lock"
do_package_update_index_ipk[nostamp] = "1"
do_package_update_index_ipk[recrdeptask] += "do_package_write_ipk"
do_package_update_index_ipk[recrdeptask] += "do_package_write_ipk"
-do_package_update_index_ipk[depends] += "ipkg-utils-native:do_populate_staging"
+do_package_update_index_ipk[depends] += "ipkg-utils-native:do_populate_sysroot"
#
# Update the Packages index files in ${DEPLOY_DIR_IPK}
@@ -312,8 +312,8 @@ python do_package_ipk () {
python () {
if bb.data.getVar('PACKAGES', d, True) != '':
deps = (bb.data.getVarFlag('do_package_write_ipk', 'depends', d) or "").split()
- deps.append('ipkg-utils-native:do_populate_staging')
- deps.append('fakeroot-native:do_populate_staging')
+ deps.append('ipkg-utils-native:do_populate_sysroot')
+ deps.append('fakeroot-native:do_populate_sysroot')
bb.data.setVarFlag('do_package_write_ipk', 'depends', " ".join(deps), d)
}
diff --git a/classes/package_rpm.bbclass b/classes/package_rpm.bbclass
index ab09bb24d3..56fa006bb9 100644
--- a/classes/package_rpm.bbclass
+++ b/classes/package_rpm.bbclass
@@ -209,8 +209,8 @@ python () {
not bb.data.inherits_class('native', d) and \
not bb.data.inherits_class('cross', d):
deps = (bb.data.getVarFlag('do_package_write_rpm', 'depends', d) or "").split()
- deps.append('rpm-native:do_populate_staging')
- deps.append('fakeroot-native:do_populate_staging')
+ deps.append('rpm-native:do_populate_sysroot')
+ deps.append('fakeroot-native:do_populate_sysroot')
bb.data.setVarFlag('do_package_write_rpm', 'depends', " ".join(deps), d)
}
diff --git a/classes/package_tar.bbclass b/classes/package_tar.bbclass
index b905e170f4..4ba69c77d4 100644
--- a/classes/package_tar.bbclass
+++ b/classes/package_tar.bbclass
@@ -91,8 +91,8 @@ python do_package_tar () {
python () {
if bb.data.getVar('PACKAGES', d, True) != '':
deps = (bb.data.getVarFlag('do_package_write_tar', 'depends', d) or "").split()
- deps.append('tar-native:do_populate_staging')
- deps.append('fakeroot-native:do_populate_staging')
+ deps.append('tar-native:do_populate_sysroot')
+ deps.append('fakeroot-native:do_populate_sysroot')
bb.data.setVarFlag('do_package_write_tar', 'depends', " ".join(deps), d)
}
diff --git a/classes/packaged-staging.bbclass b/classes/packaged-staging.bbclass
index 98623a0fc2..bcc4ff4f52 100644
--- a/classes/packaged-staging.bbclass
+++ b/classes/packaged-staging.bbclass
@@ -65,7 +65,7 @@ python () {
# as inactive.
if pstage_allowed:
deps = bb.data.getVarFlag('do_setscene', 'depends', d) or ""
- deps += " stagemanager-native:do_populate_staging"
+ deps += " stagemanager-native:do_populate_sysroot"
bb.data.setVarFlag('do_setscene', 'depends', deps, d)
policy = bb.data.getVar("BB_STAMP_POLICY", d, True)
@@ -127,7 +127,7 @@ def pstage_cleanpackage(pkgname, d):
bb.note("Failure removing staging package")
else:
bb.debug(1, "Manually removing any installed files from staging...")
- pstage_manualclean("staging", "STAGING_DIR", d)
+ pstage_manualclean("sysroots", "STAGING_DIR", d)
pstage_manualclean("cross", "CROSS_DIR", d)
pstage_manualclean("deploy", "DEPLOY_DIR", d)
@@ -277,14 +277,14 @@ python packagedstage_stampfixing_eventhandler() {
_package_unlink(stamp)
}
-populate_staging_preamble () {
+populate_sysroot_preamble () {
if [ "$PSTAGING_ACTIVE" = "1" ]; then
stage-manager -p ${STAGING_DIR} -c ${DEPLOY_DIR_PSTAGE}/stamp-cache-staging -u || true
stage-manager -p ${CROSS_DIR} -c ${DEPLOY_DIR_PSTAGE}/stamp-cache-cross -u || true
fi
}
-populate_staging_postamble () {
+populate_sysroot_postamble () {
if [ "$PSTAGING_ACTIVE" = "1" ]; then
# list the packages currently installed in staging
# ${PSTAGE_LIST_CMD} | awk '{print $1}' > ${DEPLOY_DIR_PSTAGE}/installed-list
@@ -306,20 +306,20 @@ populate_staging_postamble () {
packagedstaging_fastpath () {
if [ "$PSTAGING_ACTIVE" = "1" ]; then
- mkdir -p ${PSTAGE_TMPDIR_STAGE}/staging/
+ mkdir -p ${PSTAGE_TMPDIR_STAGE}/sysroots/
mkdir -p ${PSTAGE_TMPDIR_STAGE}/cross/${BASE_PACKAGE_ARCH}/
- cp -fpPR ${SYSROOT_DESTDIR}${STAGING_DIR}/* ${PSTAGE_TMPDIR_STAGE}/staging/ || /bin/true
- cp -fpPR ${SYSROOT_DESTDIR}${CROSS_DIR}/* ${PSTAGE_TMPDIR_STAGE}/cross/${BASE_PACKAGE_ARCH}/ || /bin/true
+ cp -fpPR ${SYSROOT_DESTDIR}/${STAGING_DIR}/* ${PSTAGE_TMPDIR_STAGE}/sysroots/ || /bin/true
+ cp -fpPR ${SYSROOT_DESTDIR}/${CROSS_DIR}/* ${PSTAGE_TMPDIR_STAGE}/cross/${BASE_PACKAGE_ARCH}/ || /bin/true
fi
}
-do_populate_staging[dirs] =+ "${DEPLOY_DIR_PSTAGE}"
+ bb.build.exec_func("populate_sysroot_preamble", d)
+do_populate_sysroot[dirs] =+ "${DEPLOY_DIR_PSTAGE}"
python populate_staging_prehook() {
- bb.build.exec_func("populate_staging_preamble", d)
}
-python populate_staging_posthook() {
- bb.build.exec_func("populate_staging_postamble", d)
+python populate_sysroot_posthook() {
+ bb.build.exec_func("populate_sysroot_postamble", d)
}
@@ -447,9 +447,9 @@ python do_package_stage () {
}
#
-# Note an assumption here is that do_deploy runs before do_package_write/do_populate_staging
+# Note an assumption here is that do_deploy runs before do_package_write/do_populate_sysroot
#
-addtask package_stage after do_package_write do_populate_staging before do_build
+addtask package_stage after do_package_write do_populate_sysroot before do_build
do_package_stage_all () {
:
diff --git a/classes/patch.bbclass b/classes/patch.bbclass
index cc3d8dd5da..1af374b39b 100644
--- a/classes/patch.bbclass
+++ b/classes/patch.bbclass
@@ -3,7 +3,7 @@
# Point to an empty file so any user's custom settings don't break things
QUILTRCFILE ?= "${STAGING_BINDIR_NATIVE}/quiltrc"
-PATCHDEPENDENCY = "${PATCHTOOL}-native:do_populate_staging"
+PATCHDEPENDENCY = "${PATCHTOOL}-native:do_populate_sysroot"
python patch_do_patch() {
import oe.patch
diff --git a/classes/rootfs_deb.bbclass b/classes/rootfs_deb.bbclass
index dc2b2cb02c..e077127144 100644
--- a/classes/rootfs_deb.bbclass
+++ b/classes/rootfs_deb.bbclass
@@ -4,7 +4,7 @@
ROOTFS_PKGMANAGE = "run-postinsts dpkg"
ROOTFS_PKGMANAGE_BOOTSTRAP = "run-postinsts"
-do_rootfs[depends] += "dpkg-native:do_populate_staging apt-native:do_populate_staging"
+do_rootfs[depends] += "dpkg-native:do_populate_sysroot apt-native:do_populate_sysroot"
do_rootfs[recrdeptask] += "do_package_write_deb"
fakeroot rootfs_deb_do_rootfs () {
diff --git a/classes/rootfs_ipk.bbclass b/classes/rootfs_ipk.bbclass
index 5483c7e077..9fa1d5ec6c 100644
--- a/classes/rootfs_ipk.bbclass
+++ b/classes/rootfs_ipk.bbclass
@@ -5,7 +5,7 @@
# See image.bbclass for a usage of this.
#
-do_rootfs[depends] += "opkg-native:do_populate_staging"
+do_rootfs[depends] += "opkg-native:do_populate_sysroot"
IPKG_TMP_DIR = "${IMAGE_ROOTFS}-tmp"
IPKG_ARGS = "-f ${IPKGCONF_TARGET} -o ${IMAGE_ROOTFS} -t ${IPKG_TMP_DIR} ${@base_conditional("PACKAGE_INSTALL_NO_DEPS", "1", "-nodeps", "", d)}"
diff --git a/classes/rootfs_rpm.bbclass b/classes/rootfs_rpm.bbclass
index e3e306450e..c018a03e2f 100644
--- a/classes/rootfs_rpm.bbclass
+++ b/classes/rootfs_rpm.bbclass
@@ -6,7 +6,7 @@ ROOTFS_PKGMANAGE = "rpm yum"
ROOTFS_PKGMANAGE_BOOTSTRAP = "run-postinsts"
-do_rootfs[depends] += "rpm-native:do_populate_staging yum-native:do_populate_staging createrepo-native:do_populate_staging fakechroot-native:do_populate_staging"
+do_rootfs[depends] += "rpm-native:do_populate_sysroot yum-native:do_populate_sysroot createrepo-native:do_populate_sysroot fakechroot-native:do_populate_sysroot"
do_rootfs[recrdeptask] += "do_package_write_rpm"
YUMCONF = "${IMAGE_ROOTFS}/etc/yum.conf"
@@ -203,7 +203,7 @@ python () {
flags = bb.data.getVarFlag('do_rootfs', 'recrdeptask', d)
flags = flags.replace("do_package_write_rpm", "")
flags = flags.replace("do_deploy", "")
- flags = flags.replace("do_populate_staging", "")
+ flags = flags.replace("do_populate_sysroot", "")
bb.data.setVarFlag('do_rootfs', 'recrdeptask', flags, d)
bb.data.setVar('RPM_PREPROCESS_COMMANDS', "rpm_insert_feed_uris", d)
bb.data.setVar('RPM_POSTPROCESS_COMMANDS', '', d)
diff --git a/classes/sanity.bbclass b/classes/sanity.bbclass
index 4051d49557..2e9151f540 100644
--- a/classes/sanity.bbclass
+++ b/classes/sanity.bbclass
@@ -141,6 +141,13 @@ def check_sanity(e):
if not abi.isdigit():
f = file(abifile, "w")
f.write(current_abi)
+ elif abi == "3" and current_abi == "4":
+ bb.note("Converting staging from layout version 2 to layout version 3")
+ os.system(bb.data.expand("mv ${TMPDIR}/staging ${TMPDIR}/sysroots", e.data))
+ os.system(bb.data.expand("ln -s sysroots ${TMPDIR}/staging", e.data))
+ os.system(bb.data.expand("cd ${TMPDIR}/stamps; for i in */*do_populate_staging; do new=`echo $i | sed -e 's/do_populate_staging/do_populate_sysroot/'`; mv $i $new; done", e.data))
+ f = file(abifile, "w")
+ f.write(current_abi)
elif (abi != current_abi):
# Code to convert from one ABI to another could go here if possible.
messages = messages + "Error, TMPDIR has changed ABI (%s to %s) and you need to either rebuild, revert or adjust it at your own risk.\n" % (abi, current_abi)
diff --git a/classes/sip.bbclass b/classes/sip.bbclass
index 30c08b1ed9..6bc248aeb3 100644
--- a/classes/sip.bbclass
+++ b/classes/sip.bbclass
@@ -55,7 +55,7 @@ sip_do_generate() {
done
}
-do_generate[deptask] = "do_populate_staging"
+do_generate[deptask] = "do_populate_sysroot"
EXPORT_FUNCTIONS do_generate
diff --git a/classes/sip3.bbclass b/classes/sip3.bbclass
index 7ecc63bf02..c2c4725377 100644
--- a/classes/sip3.bbclass
+++ b/classes/sip3.bbclass
@@ -53,7 +53,7 @@ sip3_do_generate() {
done
}
-do_generate[deptask] = "do_populate_staging"
+do_generate[deptask] = "do_populate_sysroot"
EXPORT_FUNCTIONS do_generate
diff --git a/classes/srctree.bbclass b/classes/srctree.bbclass
index dbf8ad2c3f..7232c26b12 100644
--- a/classes/srctree.bbclass
+++ b/classes/srctree.bbclass
@@ -26,8 +26,8 @@ def merge_tasks(d):
"""
merge_tasks performs two operations:
1) removes do_patch and its deps from the build entirely.
- 2) merges all of the operations that occur prior to do_populate_staging
- into do_populate_staging.
+ 2) merges all of the operations that occur prior to do_populate_sysroot
+ into do_populate_sysroot.
This is necessary, because of recipe variants (normal, native, cross,
sdk). If a bitbake run happens to want to build more than one of
@@ -50,7 +50,7 @@ def merge_tasks(d):
__gather_taskdeps(task, items)
return items
- newtask = "do_populate_staging"
+ newtask = "do_populate_sysroot"
mergedtasks = gather_taskdeps(newtask)
mergedtasks.pop()
deltasks = gather_taskdeps("do_patch")
@@ -86,14 +86,14 @@ def merge_tasks(d):
depends = (d.getVarFlag(task, "depends") or ""
for task in mergedtasks[:-1]
if not task in deltasks)
- d.setVarFlag("do_populate_staging", "depends", " ".join(depends))
+ d.setVarFlag("do_populate_sysroot", "depends", " ".join(depends))
python () {
merge_tasks(d)
}
# Manually run do_install & all of its deps, then do_stage
-python do_populate_staging () {
+python do_populate_sysroot () {
from os.path import exists
from bb.build import exec_task, exec_func
from bb import note
@@ -112,4 +112,4 @@ python do_populate_staging () {
rec_exec_task("do_install", set())
exec_func("do_stage", d)
}
-do_populate_staging[lockfiles] += "${S}/.lock"
+do_populate_sysroot[lockfiles] += "${S}/.lock"
diff --git a/classes/staging.bbclass b/classes/staging.bbclass
index 263ac915f2..a81ea865ea 100644
--- a/classes/staging.bbclass
+++ b/classes/staging.bbclass
@@ -1,9 +1,9 @@
-python populate_staging_prehook () {
- return
+python populate_sysroot_prehook () {
+ return
}
-python populate_staging_posthook () {
- return
+python populate_sysroot_posthook () {
+ return
}
packagedstaging_fastpath () {
@@ -109,21 +109,22 @@ def is_legacy_staging(d):
legacy = True
return legacy
-do_populate_staging[dirs] = "${STAGING_DIR_TARGET}/${bindir} ${STAGING_DIR_TARGET}/${libdir} \
+do_populate_sysroot[dirs] = "${STAGING_DIR_TARGET}/${bindir} ${STAGING_DIR_TARGET}/${libdir} \
${STAGING_DIR_TARGET}/${includedir} \
${STAGING_BINDIR_NATIVE} ${STAGING_LIBDIR_NATIVE} \
${STAGING_INCDIR_NATIVE} \
${STAGING_DATADIR} \
${S} ${B}"
-# Could be compile but populate_staging and do_install shouldn't run at the same time
-addtask populate_staging after do_install before do_build
+# Could be compile but populate_sysroot and do_install shouldn't run at the same time
+addtask populate_sysroot after do_install
SYSROOT_PREPROCESS_FUNCS ?= ""
SYSROOT_DESTDIR = "${WORKDIR}/sysroot-destdir/"
SYSROOT_LOCK = "${STAGING_DIR}/staging.lock"
-python do_populate_staging () {
+
+python do_populate_sysroot () {
#
# if do_stage exists, we're legacy. In that case run the do_stage,
# modify the SYSROOT_DESTDIR variable and then run the staging preprocess
@@ -150,11 +151,11 @@ python do_populate_staging () {
if bb.data.getVarFlags('do_stage', d) is None:
bb.fatal("This recipe (%s) has a do_stage_prepend or do_stage_append and do_stage now doesn't exist. Please rename this to do_stage()" % bb.data.getVar("FILE", d, True))
lock = bb.utils.lockfile(lockfile)
- bb.build.exec_func('populate_staging_prehook', d)
+ bb.build.exec_func('populate_sysroot_prehook', d)
bb.build.exec_func('do_stage', d)
for f in (bb.data.getVar('SYSROOT_PREPROCESS_FUNCS', d, True) or '').split():
bb.build.exec_func(f, d)
- bb.build.exec_func('populate_staging_posthook', d)
+ bb.build.exec_func('populate_sysroot_posthook', d)
bb.utils.unlockfile(lock)
else:
dest = bb.data.getVar('D', d, True)
diff --git a/conf/abi_version.conf b/conf/abi_version.conf
index 7f190c38c1..92b6b5868a 100644
--- a/conf/abi_version.conf
+++ b/conf/abi_version.conf
@@ -4,7 +4,7 @@
# that breaks the format and have been previously discussed on the mailing list
# with general agreement from the core team.
#
-OELAYOUT_ABI = "3"
+OELAYOUT_ABI = "4"
#
# DISTRO_PR allows us to regenerate all packages when a fundamental change is
diff --git a/conf/bitbake.conf b/conf/bitbake.conf
index 74d4da238e..5a5eefad94 100644
--- a/conf/bitbake.conf
+++ b/conf/bitbake.conf
@@ -295,7 +295,7 @@ D = "${WORKDIR}/image"
S = "${WORKDIR}/${BP}"
B = "${S}"
-STAGING_DIR = "${TMPDIR}/staging"
+STAGING_DIR = "${TMPDIR}/sysroots"
STAGING_DIR_JAVA = "${STAGING_DIR}/java"
STAGING_DIR_NATIVE = "${STAGING_DIR}/${BUILD_SYS}"
diff --git a/contrib/qa/bugzilla.py b/contrib/qa/bugzilla.py
index d1fd0d84c0..569f140d78 100644
--- a/contrib/qa/bugzilla.py
+++ b/contrib/qa/bugzilla.py
@@ -7682,7 +7682,7 @@ bugs_openmoko = """<!-- 1.0@bugzilla.org -->
</td>
<td><nobr></nobr>
</td>
- <td>package libelf-0.8.6-r0: task do_populate_staging: failed
+ <td>package libelf-0.8.6-r0: task do_populate_sysroot: failed
</td>
</tr>
diff --git a/recipes/apex/apex-nslu2-16mb_1.5.14.bb b/recipes/apex/apex-nslu2-16mb_1.5.14.bb
index f71eaa5d4b..8e764dd28f 100644
--- a/recipes/apex/apex-nslu2-16mb_1.5.14.bb
+++ b/recipes/apex/apex-nslu2-16mb_1.5.14.bb
@@ -58,7 +58,7 @@ do_stage() {
elif [ "x${SITEINFO_ENDIANESS}" = "xle" ]; then
devio '<<'src/arch-arm/rom/apex.bin >${STAGING_LOADER_DIR}/apex-nslu2-16mb.bin 'xp $,4'
else
- oefatal do_populate_staging cannot determine endianess
+ oefatal do_populate_sysroot cannot determine endianess
fi
}
diff --git a/recipes/apex/apex-nslu2_1.5.14.bb b/recipes/apex/apex-nslu2_1.5.14.bb
index db78872251..a1d91b7e67 100644
--- a/recipes/apex/apex-nslu2_1.5.14.bb
+++ b/recipes/apex/apex-nslu2_1.5.14.bb
@@ -58,7 +58,7 @@ do_stage() {
elif [ "x${SITEINFO_ENDIANESS}" = "xle" ]; then
devio '<<'src/arch-arm/rom/apex.bin >${STAGING_LOADER_DIR}/apex-nslu2.bin 'xp $,4'
else
- oefatal do_populate_staging cannot determine endianess
+ oefatal do_populate_sysroot cannot determine endianess
fi
}
diff --git a/recipes/faad2/faad2_2.0.bb b/recipes/faad2/faad2_2.0.bb
index ebb59feb01..3f15c026e9 100644
--- a/recipes/faad2/faad2_2.0.bb
+++ b/recipes/faad2/faad2_2.0.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "LGPL"
PRIORITY = "optional"
DEPENDS = ""
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
PR ="r2"
inherit autotools
diff --git a/recipes/freedoom/freedoom_0.3.bb b/recipes/freedoom/freedoom_0.3.bb
index 6cd002cd55..002f54441d 100644
--- a/recipes/freedoom/freedoom_0.3.bb
+++ b/recipes/freedoom/freedoom_0.3.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "The Freedoom project aims at collaboratively creating a Free IWAD
HOMEPAGE = "http://freedoom.sourceforge.net/"
PRIORITY = "optional"
LICENSE = "GPL"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
SRC_URI = "http://ovh.dl.sourceforge.net/sourceforge/freedoom/freedoom-iwad-0.3.zip"
diff --git a/recipes/freedoom/freedoom_0.6.2.bb b/recipes/freedoom/freedoom_0.6.2.bb
index 06cccc671a..655441c2c7 100644
--- a/recipes/freedoom/freedoom_0.6.2.bb
+++ b/recipes/freedoom/freedoom_0.6.2.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "The Freedoom project aims at collaboratively creating a Free IWAD
HOMEPAGE = "http://freedoom.sourceforge.net/"
PRIORITY = "optional"
LICENSE = "GPL"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
SRC_URI = "${SOURCEFORGE_MIRROR}/freedoom/freedoom-iwad-${PV}.zip"
diff --git a/recipes/gnuradio/gnuradio-libusb-compat.inc b/recipes/gnuradio/gnuradio-libusb-compat.inc
index 516775bec3..efe2b88b4f 100644
--- a/recipes/gnuradio/gnuradio-libusb-compat.inc
+++ b/recipes/gnuradio/gnuradio-libusb-compat.inc
@@ -47,7 +47,7 @@ do_buildlibusb() {
addtask buildlibusb before do_configure after do_unpack
-do_buildlibusb[deptask] = "do_populate_staging"
+do_buildlibusb[deptask] = "do_populate_sysroot"
do_configure_prepend() {
if [ -e ${WORKDIR}/acinclude.m4 ] ; then
diff --git a/recipes/ixp4xx/ixp4xx-npe-native_2.1.bb b/recipes/ixp4xx/ixp4xx-npe-native_2.1.bb
index 1510a750a9..f7ff764765 100644
--- a/recipes/ixp4xx/ixp4xx-npe-native_2.1.bb
+++ b/recipes/ixp4xx/ixp4xx-npe-native_2.1.bb
@@ -4,7 +4,7 @@ PR = "r3"
SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_1.zip"
SRC_URI += "file://IxNpeMicrocode.h"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
inherit native
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
diff --git a/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb b/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb
index 926fa98dcc..aabc043c6c 100644
--- a/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb
+++ b/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb
@@ -4,7 +4,7 @@ PR = "r1"
SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.3.2.bb-For-Instructions/IPL_ixp400NpeLibrary-2_3_2.zip"
SRC_URI += "file://IxNpeMicrocode.h"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
inherit native
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
diff --git a/recipes/ixp4xx/ixp4xx-npe-native_2.4.bb b/recipes/ixp4xx/ixp4xx-npe-native_2.4.bb
index 7bc28e6181..1ac22b2cdb 100644
--- a/recipes/ixp4xx/ixp4xx-npe-native_2.4.bb
+++ b/recipes/ixp4xx/ixp4xx-npe-native_2.4.bb
@@ -4,7 +4,7 @@ PR = "r0"
SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.4.bb-For-Instructions/IPL_ixp400NpeLibrary-2_4.zip"
SRC_URI += "file://IxNpeMicrocode.h"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
inherit native
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
diff --git a/recipes/ixp4xx/ixp4xx-npe_2.1.bb b/recipes/ixp4xx/ixp4xx-npe_2.1.bb
index 7eb3a3dbe0..ff10ff040c 100644
--- a/recipes/ixp4xx/ixp4xx-npe_2.1.bb
+++ b/recipes/ixp4xx/ixp4xx-npe_2.1.bb
@@ -4,7 +4,7 @@ PR = "r6"
DEPENDS = "ixp4xx-npe-native"
SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_1.zip"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
COMPATIBLE_MACHINE = "(nslu2|ixp4xx)"
diff --git a/recipes/ixp4xx/ixp4xx-npe_2.3.2.bb b/recipes/ixp4xx/ixp4xx-npe_2.3.2.bb
index 40ef4e653f..540528b2a6 100644
--- a/recipes/ixp4xx/ixp4xx-npe_2.3.2.bb
+++ b/recipes/ixp4xx/ixp4xx-npe_2.3.2.bb
@@ -9,7 +9,7 @@ DEPENDS = "ixp4xx-npe-native"
# Make sure you *read* and accept the license - it is not a standard one.
SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.3.2.bb-For-Instructions/IPL_ixp400NpeLibrary-2_3_2.zip"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
COMPATIBLE_MACHINE = "(nslu2|ixp4xx)"
diff --git a/recipes/ixp4xx/ixp4xx-npe_2.4.bb b/recipes/ixp4xx/ixp4xx-npe_2.4.bb
index 900ef8928a..bae416d121 100644
--- a/recipes/ixp4xx/ixp4xx-npe_2.4.bb
+++ b/recipes/ixp4xx/ixp4xx-npe_2.4.bb
@@ -11,7 +11,7 @@ DEPENDS = "ixp4xx-npe-native"
SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.4.bb-For-Instructions/IPL_ixp400NpeLibrary-2_4.zip \
file://Intel"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
COMPATIBLE_MACHINE = "(nslu2|ixp4xx|kixrp435)"
diff --git a/recipes/jpeg/jasper_1.900.1.bb b/recipes/jpeg/jasper_1.900.1.bb
index 2598088ecd..94b83b953b 100644
--- a/recipes/jpeg/jasper_1.900.1.bb
+++ b/recipes/jpeg/jasper_1.900.1.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Jpeg 2000 implementation"
LICENSE = "MIT"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
SRC_URI = "http://www.ece.uvic.ca/~mdadams/jasper/software/jasper-${PV}.zip"
diff --git a/recipes/juce/juce_1.29.bb b/recipes/juce/juce_1.29.bb
index a007313005..14906a9cb5 100644
--- a/recipes/juce/juce_1.29.bb
+++ b/recipes/juce/juce_1.29.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.rawmaterialsoftware.com/juce"
AUTHOR = "Julian Stoerer"
LICENSE = "GPL"
DEPENDS = "alsa-lib freetype virtual/libx11"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
PR = "r0"
#FIXME the patches are a) HACKS and b) something's wrong with lineend conversion
diff --git a/recipes/klimt/klimt_0.6.1.bb b/recipes/klimt/klimt_0.6.1.bb
index 2ad9628dca..d6bd55cda8 100644
--- a/recipes/klimt/klimt_0.6.1.bb
+++ b/recipes/klimt/klimt_0.6.1.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL"
PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/klimt/klimt-src-${PV}.zip"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
S = "${WORKDIR}/klimt/build/LinuxQTE"
EXTRA_QMAKEVARS_POST += " QMAKE_CXXFLAGS+=-fpermissive"
diff --git a/recipes/librcf/librcf_0.4.bb b/recipes/librcf/librcf_0.4.bb
index 2bb6c1e1a9..0559698457 100644
--- a/recipes/librcf/librcf_0.4.bb
+++ b/recipes/librcf/librcf_0.4.bb
@@ -3,7 +3,7 @@ SECTION = "base"
PRIORITY = "optional"
LICENSE = "unknown"
DEPENDS="zlib openssl boost-asio"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
# the SOURCE_URI requires authentication via web browser and cookie (gasp)
# all we can do right now is download the file and save it under sources/
diff --git a/recipes/linux/compulab-pxa270_2.6.16.bb b/recipes/linux/compulab-pxa270_2.6.16.bb
index 6917ec92b7..edaecb3a94 100644
--- a/recipes/linux/compulab-pxa270_2.6.16.bb
+++ b/recipes/linux/compulab-pxa270_2.6.16.bb
@@ -2,7 +2,7 @@ SECTION = "kernel"
DESCRIPTION = "Linux kernel for the Compulab PXA270 system"
LICENSE = "GPLv2"
PR = "r6"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
# Note, the compulab package contains a binary NAND driver that is not
# EABI compatible
diff --git a/recipes/miglayout/miglayout_3.0.3.bb b/recipes/miglayout/miglayout_3.0.3.bb
index a362e16452..7013914d88 100644
--- a/recipes/miglayout/miglayout_3.0.3.bb
+++ b/recipes/miglayout/miglayout_3.0.3.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}"
inherit java-library
DEPENDS = "fastjar-native classpath swt3.4-gtk"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
do_unpackpost() {
find -name "*.jar" -exec rm {} \;
diff --git a/recipes/misc-binary-only/tda1004x-firmware.bb b/recipes/misc-binary-only/tda1004x-firmware.bb
index 56fa8ee6c2..d862e9eafb 100644
--- a/recipes/misc-binary-only/tda1004x-firmware.bb
+++ b/recipes/misc-binary-only/tda1004x-firmware.bb
@@ -1,5 +1,5 @@
SECTION = "base"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
SRC_URI = "http://hauppauge.lightpath.net/de/nova-pci218c.exe"
FILES_${PN} = '*'
diff --git a/recipes/ogre/freeimage_3.11.0.bb b/recipes/ogre/freeimage_3.11.0.bb
index fd238f275a..d38882f124 100644
--- a/recipes/ogre/freeimage_3.11.0.bb
+++ b/recipes/ogre/freeimage_3.11.0.bb
@@ -1,5 +1,5 @@
LICENSE = "MIT"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
PR = "r1"
diff --git a/recipes/zaurus-utils/zaurus-updater.bb b/recipes/zaurus-utils/zaurus-updater.bb
index 7c72921e75..1d9441b5d1 100644
--- a/recipes/zaurus-utils/zaurus-updater.bb
+++ b/recipes/zaurus-utils/zaurus-updater.bb
@@ -24,5 +24,6 @@ do_deploy() {
package_stagefile_shell ${DEPLOY_DIR_IMAGE}/updater.sh
}
-# package_stagefile_shell needs to run before populate_staging for packaged-staging
-addtask deploy before do_populate_staging after do_compile
+# package_stagefile_shell need to run before populate_sysroot for packaged-staging
+addtask deploy before do_populate_sysroot after do_compile
+