aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/flickcurl/flickcurl_1.9.bb22
2 files changed, 26 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 504d1d173f..8e833562ab 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -6050,6 +6050,10 @@ sha256=701353279a17655d78e3b3678ad78d0375f5bf45877ad8b3507d589c42427f26
md5=e7737236f1eccadd4cf8cfcc0c82e005
sha256=ca7653a03f562057098c9fb956de34021a14017c2a44eedd3ab0963dc877e7e5
+[http://download.dajobe.org/flickcurl/flickcurl-1.9.tar.gz]
+md5=d701fcc8d764e634ee979f18ff9db322
+sha256=573ae52509289ed366a161facf390aa6ce530da143c760ca546868c8b0a0d034
+
[http://www.speech.cs.cmu.edu/flite/packed/flite-1.2/flite-1.2-release.tar.bz2]
md5=24c1576f5b3eb23ecedf4bebde96710f
sha256=10ff42ce08a628c7fd84d26b5228d549e9eecb1eb03cb158e87d8be66bc58ae2
diff --git a/recipes/flickcurl/flickcurl_1.9.bb b/recipes/flickcurl/flickcurl_1.9.bb
new file mode 100644
index 0000000000..ea1cdb1974
--- /dev/null
+++ b/recipes/flickcurl/flickcurl_1.9.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "flickcurl is a C libarry for the Flick API"
+SECTION = "libs"
+HOMEPAGE = "http://librdf.org/flickcurl/"
+LICENSE = "LGPL 2.1/GPL 2/Apache 2.0"
+PR = "r0"
+SRC_URI = "http://download.dajobe.org/${PN}/${PN}-${PV}.tar.gz"
+
+DEPENDS = "curl libxml2"
+
+EXTRA_OECONF = "ac_cv_func_vsnprintf=no"
+
+inherit autotools
+
+do_stage() {
+ install -d ${STAGING_INCDIR}
+ install -m 0644 ${D}/usr/include/*.h ${STAGING_INCDIR}
+ oe_libinstall -so libflickcurl ${STAGING_LIBDIR}
+}
+
+LEAD_SONAME = "libflickcurl.so.1"
+
+FILES_${PN} += "${libdir}/libflickcurl.so.*"