aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/sane-srcrevs.inc1
-rw-r--r--recipes/connman/connman-gnome_git.bb7
-rw-r--r--recipes/connman/connman.inc3
-rw-r--r--recipes/connman/connman_git.bb30
4 files changed, 36 insertions, 5 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index 3c9a287acc..deb4be7535 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -30,7 +30,6 @@ SRCREV_pn-clutter-gtk-0.8 ?= "7d3c3230376e731c06c21afa9d8c1d44dbea27cd"
SRCREV_pn-clutter-gtk ?= "70f4b0cbd568dfa265484a03be3bd08ad15ed12e"
SRCREV_pn-clutter ?= "3240"
SRCREV_pn-comic-reader ?= "54"
-SRCREV_pn-connman ?= "103706c4f4da0c89f8b6f33cccdc3149f4ecc09a"
SRCREV_pn-contact ?= "1410"
SRCREV_pn-dasher-gpe ?= "1251"
SRCREV_pn-dbus-c++-native ?= "13131"
diff --git a/recipes/connman/connman-gnome_git.bb b/recipes/connman/connman-gnome_git.bb
index cd244b84ca..34175b71d9 100644
--- a/recipes/connman/connman-gnome_git.bb
+++ b/recipes/connman/connman-gnome_git.bb
@@ -4,14 +4,17 @@ SECTION = "libs/network"
LICENSE = "GPL"
DEPENDS = "gtk+ dbus"
-RRECOMMENDS_${PN} = "connman connman-plugin-ethernet connman-plugin-loopback connman-plugin-udhcp connman-plugin-wifi"
+RRECOMMENDS_${PN} = "connman connman-plugin-ethernet connman-plugin-loopback connman-plugin-udhcp connman-plugin-wifi connman-plugin-bluetooth"
PV = "0.5+git"
+PR = "r3"
PR_append = ".gitr${SRCREV}"
DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "1"
+
+SRCREV = "bdc9164b405d18cfc5dbde2a33f070341d5ad673"
-SRCREV = "0059a16915d65880e3f9892a8f0a25f65968260e"
SRC_URI = "\
git://git.kernel.org/pub/scm/network/connman/connman-gnome.git;protocol=git \
file://connman-applet.desktop"
diff --git a/recipes/connman/connman.inc b/recipes/connman/connman.inc
index 516684daa3..eb7aa1ab52 100644
--- a/recipes/connman/connman.inc
+++ b/recipes/connman/connman.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
SECTION = "libs/network"
LICENSE = "GPL"
# we need to define the depends here, the dynamic stuff is too late
-DEPENDS = "wpa-supplicant dbus glib-2.0 ppp busybox dhclient resolvconf bluez4"
+DEPENDS = "libnl wpa-supplicant dbus glib-2.0 ppp busybox dhclient resolvconf bluez4"
EXTRA_OECONF += "\
ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \
@@ -29,6 +29,7 @@ do_compile_append() {
}
do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
}
diff --git a/recipes/connman/connman_git.bb b/recipes/connman/connman_git.bb
index 3a04f5f541..523d39ba2f 100644
--- a/recipes/connman/connman_git.bb
+++ b/recipes/connman/connman_git.bb
@@ -1,11 +1,39 @@
+EXTRA_OECONF = " \
+ --enable-threads \
+ --enable-ethernet \
+ --enable-wifi \
+ --enable-bluetooth \
+ --enable-modemmgr \
+ --enable-udhcp \
+ --enable-dhclient \
+ --enable-resolvconf \
+ --enable-loopback \
+ --enable-dnsproxy \
+ --enable-novatel \
+ --enable-huawei \
+ --enable-hso \
+ --enable-mbm \
+ --enable-ppp \
+ --disable-polkit \
+ --enable-client \
+ --enable-tools \
+ --enable-fake \
+"
+
require connman.inc
-PV = "0.12+gitr${SRCREV}"
+
+SRCREV = "1a94db417ecaba20a609ff4b4431a3f67c5dcbc6"
+
+PV = "0.42+git"
PR = "r0"
+PR_append = ".gitr${SRCREV}"
DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "1"
SRC_URI = "\
git://git.kernel.org/pub/scm/network/connman/connman.git;protocol=git \
file://connman \
"
+
S = "${WORKDIR}/git"