aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/kexecboot/kexecboot-0.4/kexecboot-tosa.patch15
-rw-r--r--packages/kexecboot/kexecboot_0.4.bb3
2 files changed, 17 insertions, 1 deletions
diff --git a/packages/kexecboot/kexecboot-0.4/kexecboot-tosa.patch b/packages/kexecboot/kexecboot-0.4/kexecboot-tosa.patch
new file mode 100644
index 0000000000..e10d1d70b3
--- /dev/null
+++ b/packages/kexecboot/kexecboot-0.4/kexecboot-tosa.patch
@@ -0,0 +1,15 @@
+Index: kexecboot-0.4/kexecboot.c
+===================================================================
+--- kexecboot-0.4.orig/kexecboot.c 2009-01-29 00:38:21.000000000 +0000
++++ kexecboot-0.4/kexecboot.c 2009-01-29 00:39:05.000000000 +0000
+@@ -566,7 +566,9 @@
+ break;
+ }
+
+- }while(evt.code != 87 && evt.code != 63);
++ }while(evt.code != 87 && evt.code != 63 &&
++ evt.code != KEY_SPACE && evt.code != KEY_ENTER &&
++ evt.code != KEY_HIRAGANA && evt.code != KEY_HENKAN);
+ fclose(f);
+ // reset terminal
+ tcsetattr(fileno(stdin), TCSANOW, &old);
diff --git a/packages/kexecboot/kexecboot_0.4.bb b/packages/kexecboot/kexecboot_0.4.bb
index 557c5be4b3..c370b227c2 100644
--- a/packages/kexecboot/kexecboot_0.4.bb
+++ b/packages/kexecboot/kexecboot_0.4.bb
@@ -1,5 +1,5 @@
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
DEPENDS = "klibc"
RDEPENDS = "kexec-static"
@@ -15,6 +15,7 @@ SRC_URI = "http://projects.linuxtogo.org/~jay7/kexecboot-${PV}.tar.gz \
file://switch-cursor-off.patch;patch=1 \
file://add-sleep.patch;patch=1 \
file://silent-output-hack.patch;patch=1 \
+ file://kexecboot-tosa.patch;patch=1 \
"
S = "${WORKDIR}/kexecboot-${PV}"