aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch12
-rw-r--r--recipes/gsoap/gsoap-native_2.7.13.bb12
-rw-r--r--recipes/gsoap/gsoap_2.7.13.bb15
-rw-r--r--recipes/gsoap/gsoap_2.7.13.inc15
5 files changed, 58 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index d08d7bc303..6c94287f4e 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -9278,6 +9278,10 @@ sha256=5149991a219e8f2059350ed9d52bb110c0695da6eb9fe256e9e213e69f83929f
md5=5bfa5605d9565ff01138d7a574cc2614
sha256=fc029984019736eab2b0f10ce28d48ff88f8ceed7a1739cb4b71b851c4b89b91
+[http://downloads.sourceforge.net/gsoap2/gsoap_2.7.13.tar.gz]
+md5=fffb49eb1db7ff03643a4313115dc3b1
+sha256=3d40a528b8f3309f392945dca2ecaee5a698f4ee00a6036907a57c4f25a6a479
+
[http://downloads.sourceforge.net/gsoap2/gsoap_2.7.7.tar.gz]
md5=a0bbbfdc135034cd778537f979121df7
sha256=7b531f1b6481fbe1a21620a86649f42cb2de9cf086e7bdde46335137d3ca11dc
diff --git a/recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch b/recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch
new file mode 100644
index 0000000000..25a8ef0db1
--- /dev/null
+++ b/recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch
@@ -0,0 +1,12 @@
+diff -urN gsoap-2.7.orig/gsoap/wsdl/Makefile.am gsoap-2.7.orig/gsoap/wsdl/Makefile.am
+--- gsoap-2.7.orig/gsoap/wsdl/Makefile.am 2009-03-21 22:24:42.000000000 +0100
++++ gsoap-2.7.orig/gsoap/wsdl/Makefile.am 2009-04-07 11:30:50.000000000 +0200
+@@ -17,7 +17,7 @@ BUILT_SOURCES=$(SOAP_CPP_SRC)
+ # WSDL2H_EXTRA_LIBS=-lssl -lcrypto -lz # defined in configure.in
+
+ $(SOAP_CPP_SRC) : $(SOAPHEADER)
+- $(SOAP) $(SOAP_FLAGS) $(SOAPHEADER)
++ ../src/soapcpp2 $(SOAP_FLAGS) $(SOAPHEADER)
+
+ #LIBS=
+
diff --git a/recipes/gsoap/gsoap-native_2.7.13.bb b/recipes/gsoap/gsoap-native_2.7.13.bb
new file mode 100644
index 0000000000..3ed78d0227
--- /dev/null
+++ b/recipes/gsoap/gsoap-native_2.7.13.bb
@@ -0,0 +1,12 @@
+require gsoap_${PV}.inc
+
+DEPENDS = ""
+
+SRC_URI += "file://use-just-built-binary-2.7.13.patch;patch=1"
+
+inherit native
+
+do_install() {
+ :
+}
+
diff --git a/recipes/gsoap/gsoap_2.7.13.bb b/recipes/gsoap/gsoap_2.7.13.bb
new file mode 100644
index 0000000000..54f89c68fc
--- /dev/null
+++ b/recipes/gsoap/gsoap_2.7.13.bb
@@ -0,0 +1,15 @@
+require gsoap_${PV}.inc
+
+DEPENDS = "gsoap-native"
+
+do_install_append() {
+ install -d ${D}${libdir}
+ for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
+ do
+ oe_libinstall -C gsoap $lib ${D}${libdir}
+ done
+}
+
+
+FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
+FILES_${PN} += "${datadir}"
diff --git a/recipes/gsoap/gsoap_2.7.13.inc b/recipes/gsoap/gsoap_2.7.13.inc
new file mode 100644
index 0000000000..a6fbbb59e2
--- /dev/null
+++ b/recipes/gsoap/gsoap_2.7.13.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
+for the development of SOAP Web Services and clients."
+SECTION = "devel"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gsoap2/gsoap_${PV}.tar.gz"
+
+inherit autotools_stage
+
+S = "${WORKDIR}/gsoap-2.7"
+
+PARALLEL_MAKE = ""
+
+EXTRA_OEMAKE = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
+