aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/gcc/gcc-4.0.0.inc8
-rw-r--r--recipes/gcc/gcc-4.0.0/ldflags.patch22
-rw-r--r--recipes/gcc/gcc-cross-initial_4.0.0.bb6
-rw-r--r--recipes/gcc/gcc-cross-intermediate_4.0.0.bb4
-rw-r--r--recipes/gcc/gcc-cross_4.0.0.bb2
-rw-r--r--recipes/gcc/gcc_4.0.0.bb2
6 files changed, 17 insertions, 27 deletions
diff --git a/recipes/gcc/gcc-4.0.0.inc b/recipes/gcc/gcc-4.0.0.inc
index 5745ba050d..fe56c3443b 100644
--- a/recipes/gcc/gcc-4.0.0.inc
+++ b/recipes/gcc/gcc-4.0.0.inc
@@ -1,11 +1,13 @@
require gcc-common.inc
+DEPENDS = "mpfr gmp"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
- file://zecke-xgcc-cpp.patch;patch=1 \
- file://ldflags.patch;patch=1"
+ file://gcc-posix-open-fix.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1"
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
# Language Overrides
FORTRAN = ",f95"
-EXTRA_OECONF_BASE = "--disable-libssp"
+EXTRA_OECONF_BASE = "--disable-libssp --disable-libmudflap"
diff --git a/recipes/gcc/gcc-4.0.0/ldflags.patch b/recipes/gcc/gcc-4.0.0/ldflags.patch
deleted file mode 100644
index 1196bf0c8e..0000000000
--- a/recipes/gcc/gcc-4.0.0/ldflags.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- gcc-4.0.0/Makefile.tpl.old 2005-06-10 13:05:09.000000000 +0100
-+++ gcc-4.0.0/Makefile.tpl 2005-06-10 13:05:10.000000000 +0100
-@@ -339,7 +339,7 @@
- NM = @NM@
-
- LD = @LD@
--LDFLAGS =
-+LDFLAGS = @LDFLAGS@
-
- RANLIB = @RANLIB@
-
---- gcc-4.0.0/Makefile.in.old 2005-06-10 17:13:12.000000000 +0100
-+++ gcc-4.0.0/Makefile.in 2005-06-10 17:13:22.000000000 +0100
-@@ -336,7 +336,7 @@
- NM = @NM@
-
- LD = @LD@
--LDFLAGS =
-+LDFLAGS = @LDFLAGS@
-
- RANLIB = @RANLIB@
-
diff --git a/recipes/gcc/gcc-cross-initial_4.0.0.bb b/recipes/gcc/gcc-cross-initial_4.0.0.bb
new file mode 100644
index 0000000000..976cd96b00
--- /dev/null
+++ b/recipes/gcc/gcc-cross-initial_4.0.0.bb
@@ -0,0 +1,6 @@
+require gcc-cross_${PV}.bb
+require gcc-cross-initial.inc
+
+DEPENDS += "gmp-native mpfr-native"
+
+EXTRA_OECONF += "--disable-multilib --disable-libssp --disable-libmudflap"
diff --git a/recipes/gcc/gcc-cross-intermediate_4.0.0.bb b/recipes/gcc/gcc-cross-intermediate_4.0.0.bb
new file mode 100644
index 0000000000..1feb434a21
--- /dev/null
+++ b/recipes/gcc/gcc-cross-intermediate_4.0.0.bb
@@ -0,0 +1,4 @@
+require gcc-cross_${PV}.bb
+require gcc-cross-intermediate.inc
+
+EXTRA_OECONF += "--disable-multilib --disable-libssp --disable-libmudflap"
diff --git a/recipes/gcc/gcc-cross_4.0.0.bb b/recipes/gcc/gcc-cross_4.0.0.bb
index e192d82adc..e9e2e7bae8 100644
--- a/recipes/gcc/gcc-cross_4.0.0.bb
+++ b/recipes/gcc/gcc-cross_4.0.0.bb
@@ -1,4 +1,4 @@
-PR = "r8"
+PR = "r9"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/recipes/gcc/gcc_4.0.0.bb b/recipes/gcc/gcc_4.0.0.bb
index 1bbab50930..5e2598079b 100644
--- a/recipes/gcc/gcc_4.0.0.bb
+++ b/recipes/gcc/gcc_4.0.0.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
require gcc-${PV}.inc
require gcc-configure-target.inc