aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini6
-rw-r--r--recipes/batmand/batmand-0.3.2/makefile-fix.patch13
-rw-r--r--recipes/batmand/batmand.inc28
-rw-r--r--recipes/batmand/batmand_0.3.2.bb3
-rw-r--r--recipes/batmand/batmand_0.3.bb30
5 files changed, 51 insertions, 29 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 087dee9bf9..ed3f12e0e7 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -2530,10 +2530,14 @@ sha256=0e3649531c3a5675743980ecf5ff5fcbca2801afe4dca7fb4b250aae7ac3b782
md5=e240c34f979b64bcb83c5f6567110bb1
sha256=46d427fd5b1509ec7dd980c07efd88634fde61cf07ab221dcbde9e1021bd2817
-[http://downloads.open-mesh.net/batman/stable/sources/batman-0.3.tar.gz]
+[http://downloads.open-mesh.net/batman/stable/sources/batman/batman-0.3.tar.gz]
md5=54812e81f70a4155edcce88f0c7aeb02
sha256=846f34019c6f30bbb88790088a0e205c7a4e7ee0ab656a5ea3b4b624a0a028cb
+[http://downloads.open-mesh.net/batman/stable/sources/batman/batman-0.3.2.tar.gz]
+md5=3f2f6b408828d34c5c2f1445e744e6ac
+sha256=2b0f22efc1bda016649db8d6e1214e381d034befa9c9835c3a6a75d5f95cf931
+
[http://bazaar.canonical.com/releases/src/bazaar_1.2.tar.gz]
md5=1fdb0aa41d7db06bf3429118d0136c8a
sha256=d1b657f52dea785ce1b1a8b5acfdee4492c5d779422f9b58e145162e2d33c241
diff --git a/recipes/batmand/batmand-0.3.2/makefile-fix.patch b/recipes/batmand/batmand-0.3.2/makefile-fix.patch
new file mode 100644
index 0000000000..9e74a91471
--- /dev/null
+++ b/recipes/batmand/batmand-0.3.2/makefile-fix.patch
@@ -0,0 +1,13 @@
+Index: batman-0.3.2/Makefile
+===================================================================
+--- batman-0.3.2.orig/Makefile 2009-05-15 21:41:16.000000000 +0200
++++ batman-0.3.2/Makefile 2009-09-22 16:20:05.937937168 +0200
+@@ -28,8 +28,6 @@
+ # activate this variable to deactivate policy routing for backward compatibility
+ #NO_POLICY_ROUTING = -DNO_POLICY_ROUTING
+
+-CC = gcc
+-CFLAGS += -pedantic -Wall -W -O1 -g3 -std=gnu99
+ EXTRA_CFLAGS = -DDEBUG_MALLOC -DMEMORY_USAGE -DPROFILE_DATA $(NO_POLICY_ROUTING) -DREVISION_VERSION=$(REVISION_VERSION)
+ LDFLAGS += -lpthread
+
diff --git a/recipes/batmand/batmand.inc b/recipes/batmand/batmand.inc
new file mode 100644
index 0000000000..cb99cf0d74
--- /dev/null
+++ b/recipes/batmand/batmand.inc
@@ -0,0 +1,28 @@
+DESCRIPTION = "Routing protocol daemon for multi-hop ad-hoc mesh networks."
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.open-mesh.net/"
+
+INC_PR = "r1"
+
+RDEPENDS = "kernel-module-tun"
+
+SRC_URI = "http://downloads.open-mesh.net/batman/stable/sources/batman/batman-${PV}.tar.gz \
+ file://makefile-fix.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/batman-${PV}"
+
+do_compile() {
+ oe_runmake
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 batmand ${D}${bindir}
+}
diff --git a/recipes/batmand/batmand_0.3.2.bb b/recipes/batmand/batmand_0.3.2.bb
new file mode 100644
index 0000000000..f359f5e7ca
--- /dev/null
+++ b/recipes/batmand/batmand_0.3.2.bb
@@ -0,0 +1,3 @@
+require batmand.inc
+PR = "${INC_PR}.1"
+
diff --git a/recipes/batmand/batmand_0.3.bb b/recipes/batmand/batmand_0.3.bb
index c78f94d5e3..f359f5e7ca 100644
--- a/recipes/batmand/batmand_0.3.bb
+++ b/recipes/batmand/batmand_0.3.bb
@@ -1,29 +1,3 @@
-DESCRIPTION = "Routing protocol daemon for multi-hop ad-hoc mesh networks."
-SECTION = "console/network"
-PRIORITY = "optional"
-LICENSE = "GPL"
-HOMEPAGE = "https://www.open-mesh.net/batman"
+require batmand.inc
+PR = "${INC_PR}.1"
-PR = "r0"
-
-RDEPENDS = "kernel-module-tun"
-
-SRC_URI = "\
- http://downloads.open-mesh.net/batman/stable/sources/batman-0.3.tar.gz \
- file://makefile-fix.patch;patch=1 \
- "
-
-S = "${WORKDIR}/batman-${PV}"
-
-do_compile() {
- oe_runmake
-}
-
-do_stage() {
- :
-}
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 batmand ${D}${bindir}
-}