aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/hal/hal_0.5.12.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes/hal/hal_0.5.12.bb b/recipes/hal/hal_0.5.12.bb
index b6531e8235..3edb33275b 100644
--- a/recipes/hal/hal_0.5.12.bb
+++ b/recipes/hal/hal_0.5.12.bb
@@ -2,9 +2,12 @@ require hal.inc
DEFAULT_PREFERENCE = "-1"
+PR = "r1"
+
# The following code finds the right linux/input.h,
# which also works with external-toolchain/SDK
do_configure() {
+ sed -i -e s:1.43:1.41:g ${S}/configure.in
linux_input_h=`echo "#include <linux/input.h>" | ${CPP} - | \
grep "linux\/input.h" | head -n 1 | awk -F '"' '{print $2}'`
autotools_do_configure --with-linux-input-header=${linux_input_h}