aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/bluez/bluez4_4.39.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/bluez/bluez4_4.39.bb b/recipes/bluez/bluez4_4.39.bb
index c28f260761..531eedf6da 100644
--- a/recipes/bluez/bluez4_4.39.bb
+++ b/recipes/bluez/bluez4_4.39.bb
@@ -5,6 +5,8 @@ DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
HOMEPAGE = "http://www.bluez.org"
LICENSE = "GPL"
+PR = "r1"
+
# For angstrom we want this to replace at least bluez-libs
PROVIDES_append_angstrom = " bluez-utils bluez-libs"
@@ -16,7 +18,7 @@ SRC_URI = "\
"
S = "${WORKDIR}/bluez-${PV}"
-inherit autotools_stage
+inherit autotools_stage update-rc.d
AUTOTOOLS_STAGE_PKGCONFIG = "1"
EXTRA_OECONF = "\
@@ -47,6 +49,9 @@ do_install_append() {
install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
}
+INITSCRIPT_NAME = "bluetooth"
+INITSCRIPT_PARAMS = "defaults 23 19"
+
PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"