aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/ralink/files/config.patch20
-rw-r--r--recipes/ralink/files/makefile.patch11
-rw-r--r--recipes/ralink/rt3070_2.1.1.0.bb18
4 files changed, 53 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 9364c2cc77..9b76d1df66 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -58,6 +58,10 @@ sha256=7a960180e7873b1bdb522e76b0423b5c2c1b8efe1d30d7ca80c41eb97d822b2d
md5=f13ab353b11329ce3d605b6f40e77fa6
sha256=41991e8aa2e5fe8e5dfd47b1e5c446fa03c3ee96a5eae54fd6ec15d1d9afef30
+[http://www.ralinktech.com.tw/data/drivers/2009_0525_RT3070_Linux_STA_v2.1.1.0.tar.bz2]
+md5=705c5f8ba0f8a378218fef74859335f5
+sha256=b2a24265bb29f4d429ec42fefbfc545b898c8c046c01c577ca08d9cc65c860d7
+
[http://hg.openjdk.java.net/hsx/hsx14/master/archive/25a020f13592.tar.gz]
md5=dbd7aca5544d1aeebf0eadd45d29d08e
sha256=02f10b35508cb11908bb908156daad1ea5e653840440d62482231efeb4cbe178
diff --git a/recipes/ralink/files/config.patch b/recipes/ralink/files/config.patch
new file mode 100644
index 0000000000..89a26caea0
--- /dev/null
+++ b/recipes/ralink/files/config.patch
@@ -0,0 +1,20 @@
+--- 2009_0525_RT3070_Linux_STA_v2.1.1.0/os/linux/config.mk 2009-05-20 20:33:56.000000000 -0700
++++ 2009_0525_RT3070_Linux_STA_v2.1.1.0/os/linux/config.mk 2009-08-22 19:42:55.000000000 -0700
+@@ -4,15 +4,11 @@
+ # Support 28xx QA ATE function
+ HAS_28xx_QA=n
+
+-#ifdef WPA_SUPPLICANT_SUPPORT
+ # Support Wpa_Supplicant
+-HAS_WPA_SUPPLICANT=n
+-#endif // WPA_SUPPLICANT_SUPPORT //
++HAS_WPA_SUPPLICANT=y
+
+-#ifdef NATIVE_WPA_SUPPLICANT_SUPPORT
+ # Support Native WpaSupplicant for Network Maganger
+-HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n
+-#endif // NATIVE_WPA_SUPPLICANT_SUPPORT //
++HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
+
+ #Support Net interface block while Tx-Sw queue full
+ HAS_BLOCK_NET_IF=n
diff --git a/recipes/ralink/files/makefile.patch b/recipes/ralink/files/makefile.patch
new file mode 100644
index 0000000000..ca949023cf
--- /dev/null
+++ b/recipes/ralink/files/makefile.patch
@@ -0,0 +1,11 @@
+--- 2009_0525_RT3070_Linux_STA_v2.1.1.0/Makefile 2009-05-20 20:33:56.000000000 -0700
++++ 2009_0525_RT3070_Linux_STA_v2.1.1.0/Makefile 2009-06-23 19:57:21.000000000 -0700
+@@ -153,7 +153,7 @@
+ else
+ cp -f os/linux/Makefile.6 $(RT28xx_DIR)/os/linux/Makefile
+ make -C $(LINUX_SRC) SUBDIRS=$(RT28xx_DIR)/os/linux modules
+- cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.ko /tftpboot
++# cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.ko /tftpboot
+ endif
+
+ clean:
diff --git a/recipes/ralink/rt3070_2.1.1.0.bb b/recipes/ralink/rt3070_2.1.1.0.bb
new file mode 100644
index 0000000000..d7709fa91d
--- /dev/null
+++ b/recipes/ralink/rt3070_2.1.1.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Ralink 3070"
+LICENSE = "GPLv2"
+
+inherit module
+
+SRC_URI = "http://www.ralinktech.com.tw/data/drivers/2009_0525_RT3070_Linux_STA_v${PV}.tar.bz2 \
+ file://makefile.patch;patch=1 \
+ file://config.patch;patch=1 \
+"
+
+EXTRA_OEMAKE = "LINUX_SRC=${STAGING_KERNEL_DIR}"
+
+S = "${WORKDIR}/2009_0525_RT3070_Linux_STA_v${PV}"
+
+do_install() {
+ mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ cp ${S}/os/linux/rt3070sta.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+}