aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/igep0020.conf2
-rw-r--r--recipes/x-load/x-load-git/igep0020/remove-final-ldflags.patch11
-rw-r--r--recipes/x-load/x-load_git.bb7
3 files changed, 19 insertions, 1 deletions
diff --git a/conf/machine/igep0020.conf b/conf/machine/igep0020.conf
index 55c18507c3..6295010954 100644
--- a/conf/machine/igep0020.conf
+++ b/conf/machine/igep0020.conf
@@ -21,6 +21,8 @@ KERNEL_IMAGETYPE = "uImage"
UBOOT_MACHINE = "omap3_igep0020b_config"
+XLOAD_MACHINE = "igep0020-flash_config"
+
IMAGE_FSTYPES += "tar.bz2 ubi"
# Guesswork
diff --git a/recipes/x-load/x-load-git/igep0020/remove-final-ldflags.patch b/recipes/x-load/x-load-git/igep0020/remove-final-ldflags.patch
new file mode 100644
index 0000000000..c5ac09b8e7
--- /dev/null
+++ b/recipes/x-load/x-load-git/igep0020/remove-final-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/Makefile 2010-09-03 09:59:12.000000000 +0200
++++ b/Makefile 2010-09-03 10:43:46.650000018 +0200
+@@ -90,7 +90,7 @@
+
+ x-load: $(OBJS) $(LIBS) $(LDSCRIPT)
+ UNDEF_SYM=`$(OBJDUMP) -x $(LIBS) |sed -n -e 's/.*\(__u_boot_cmd_.*\)/-u\1/p'|sort|uniq`;\
+- $(LD) $(LDFLAGS) $$UNDEF_SYM $(OBJS) \
++ $(LD) $$UNDEF_SYM $(OBJS) \
+ --start-group $(LIBS) --end-group $(PLATFORM_LIBS) \
+ -Map x-load.map -o x-load
+
diff --git a/recipes/x-load/x-load_git.bb b/recipes/x-load/x-load_git.bb
index cbcbf17d61..eb4a2deeba 100644
--- a/recipes/x-load/x-load_git.bb
+++ b/recipes/x-load/x-load_git.bb
@@ -9,7 +9,7 @@ SRCREV_beagleboard = "1c9276af4d6a5b7014a7630a1abeddf3b3177563"
PV = "1.42+${PR}+gitr${SRCREV}"
PV_beagleboard = "1.44+${PR}+gitr${SRCREV}"
-PR ="r15"
+PR ="r16"
PE = "1"
SRC_URI = "git://gitorious.org/x-load-omap3/mainline.git;branch=master;protocol=git"
@@ -56,6 +56,11 @@ SRCREV_omapzoom36x = "251d92815500143aefdbe3b3558a0ce6daeaebdc"
SRC_URI[uboot.md5sum] = "e68b30714d22ce2f926d2dd19f94a2be"
SRC_URI[uboot.sha256sum] = "e7e5c87d939cc4c1f14d17ea0814b0bed97021c7afca3ef9053c896c2b5bdd6f"
+SRC_URI_igep0020 = "git://git.igep.es/pub/scm/x-loader.git;protocol=git \
+ file://remove-final-ldflags.patch"
+SRCREV_igep0020 = "213d95fcadc54424c796259928d7c15c5a2945a0"
+PV_igep0020 = "1.43+${PR}+gitr${SRCREV}"
+
S = "${WORKDIR}/git"
PACKAGE_ARCH = "${MACHINE_ARCH}"