aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/rt2x00/rt3572-2.4.0.1/config.patch15
-rw-r--r--recipes/rt2x00/rt3572-2.4.0.1/makefile.patch11
-rw-r--r--recipes/rt2x00/rt3572_2.4.0.1.bb32
3 files changed, 58 insertions, 0 deletions
diff --git a/recipes/rt2x00/rt3572-2.4.0.1/config.patch b/recipes/rt2x00/rt3572-2.4.0.1/config.patch
new file mode 100644
index 0000000000..2128e74143
--- /dev/null
+++ b/recipes/rt2x00/rt3572-2.4.0.1/config.patch
@@ -0,0 +1,15 @@
+--- 2010_0709_RT3572_Linux_STA_v2.4.0.1/os/linux/config.mk 2010-07-09 02:09:41.000000000 +0000
++++ 2010_0709_RT3572_Linux_STA_v2.4.0.1.patched/os/linux/config.mk 2010-09-02 13:49:57.000000000 +0000
+@@ -8,10 +8,10 @@
+ HAS_XLINK=n
+
+ # Support Wpa_Supplicant
+-HAS_WPA_SUPPLICANT=n
++HAS_WPA_SUPPLICANT=y
+
+ # Support Native WpaSupplicant for Network Maganger
+-HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n
++HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
+
+ #Support Net interface block while Tx-Sw queue full
+ HAS_BLOCK_NET_IF=n
diff --git a/recipes/rt2x00/rt3572-2.4.0.1/makefile.patch b/recipes/rt2x00/rt3572-2.4.0.1/makefile.patch
new file mode 100644
index 0000000000..5886ab50ab
--- /dev/null
+++ b/recipes/rt2x00/rt3572-2.4.0.1/makefile.patch
@@ -0,0 +1,11 @@
+--- 2010_0709_RT3572_Linux_STA_v2.4.0.1/Makefile 2010-07-09 02:09:41.000000000 +0000
++++ 2010_0709_RT3572_Linux_STA_v2.4.0.1.patched/Makefile 2010-09-02 13:34:02.000000000 +0000
+@@ -238,7 +238,7 @@
+ cp -f os/linux/Makefile.4 $(RT28xx_DIR)/os/linux/Makefile
+ $(MAKE) -C $(RT28xx_DIR)/os/linux/
+
+- cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.o /tftpboot
++# cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.o /tftpboot
+ else
+ cp -f os/linux/Makefile.6 $(RT28xx_DIR)/os/linux/Makefile
+ ifeq ($(PLATFORM),DM6446)
diff --git a/recipes/rt2x00/rt3572_2.4.0.1.bb b/recipes/rt2x00/rt3572_2.4.0.1.bb
new file mode 100644
index 0000000000..b62ce98ab3
--- /dev/null
+++ b/recipes/rt2x00/rt3572_2.4.0.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Ralink 3572"
+SECTION = "kernel/modules"
+LICENSE = "GPLv2"
+PR = "r0"
+
+inherit module
+
+SRC_URI = "http://sources.openembedded.org/2010_0709_RT3572_Linux_STA_v${PV}.tar.bz2 \
+ file://makefile.patch \
+ file://config.patch \
+ "
+
+EXTRA_OEMAKE = "LINUX_SRC=${STAGING_KERNEL_DIR}"
+
+S = "${WORKDIR}/2010_0709_RT3572_Linux_STA_v${PV}"
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ install -m 0644 ${S}/os/linux/rt3572sta.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ install -d ${D}/etc/Wireless/RT2870STA
+ install -m 0644 ${S}/RT2870STA.dat ${D}/etc/Wireless/RT2870STA
+ install -d ${D}/lib/firmware
+ install -m 0644 ${S}/common/*.bin ${D}/lib/firmware/
+}
+
+PACKAGES =+ "${PN}-firmware"
+FILES_${PN}-firmware = "/etc /lib/firmware"
+
+RDEPENDS_${PN} = "${PN}-firmware"
+
+SRC_URI[md5sum] = "ae16d9a445591bbea5a234bdfc64a826"
+SRC_URI[sha256sum] = "870acc786d0c756b3d5854dd21dd1a7b03256edba1b6c343d0ffd73bc63274ce"