aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/sane-srcrevs.inc2
-rw-r--r--recipes/gabriel/gabriel-native_svn.bb13
-rw-r--r--recipes/gabriel/gabriel_svn.bb14
3 files changed, 29 insertions, 0 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index 88b3487451..eb42b334ed 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -64,6 +64,8 @@ SRCREV_pn-fso-gsm0710muxd ?= "abcbcd7cc532a8834906de3fc24c8f8fe7643cd4"
SRCREV_pn-fso-monitord ?= "0f64979a11d6263c7b7ed0e945a0889744f295f1"
SRCREV_pn-fso-sounds ?= "3d2cf5231cb0e81770a246530574142bd2b8bbff"
SRCREV_pn-fstests ?= "204"
+SRCREV_pn-gabriel ?= "38"
+SRCREV_pn-gabriel-native ?= "38"
GCCREV ?= "145550"
SRCREV_pn-gcc ?= ${GCCREV}
SRCREV_pn-gcc-cross ?= ${GCCREV}
diff --git a/recipes/gabriel/gabriel-native_svn.bb b/recipes/gabriel/gabriel-native_svn.bb
new file mode 100644
index 0000000000..a98abb028e
--- /dev/null
+++ b/recipes/gabriel/gabriel-native_svn.bb
@@ -0,0 +1,13 @@
+require gabriel_svn.bb
+inherit native
+DEPENDS = "libssh-native glib-2.0-native dbus-native dbus-glib-native"
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 src/gabriel ${DEPLOY_DIR_TOOLS}/gabriel-${PV}
+ rm -f ${DEPLOY_DIR_TOOLS}/gabriel
+ ln -sf ./gabriel-${PV} ${DEPLOY_DIR_TOOLS}/gabriel
+}
+
+
+addtask deploy before do_package after do_install
diff --git a/recipes/gabriel/gabriel_svn.bb b/recipes/gabriel/gabriel_svn.bb
new file mode 100644
index 0000000000..1449311f90
--- /dev/null
+++ b/recipes/gabriel/gabriel_svn.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Gabriel is a small utility to enable D-Bus clients to connect to a D-Bus \
+daemon running on a remote machine, through SSH. In simple words, gabriel is a proxy for \
+a dbus daemon running on a remote machine."
+LICENSE = "GPL"
+DEPENDS = "libssh glib-2.0 dbus glib-dbus"
+SECTION = "console/network"
+PV = "0.0.0+svnr${SRCREV}"
+
+SRC_URI = "svn://gabriel.svn.sourceforge.net/svnroot/gabriel;module=gabriel;proto=https"
+S = "${WORKDIR}/gabriel"
+
+inherit autotools_stage
+
+RDEPENDS = "socat"