aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/iw/iw/kill-git-version-check.patch26
-rw-r--r--recipes/iw/iw_0.9.20.bb7
2 files changed, 31 insertions, 2 deletions
diff --git a/recipes/iw/iw/kill-git-version-check.patch b/recipes/iw/iw/kill-git-version-check.patch
new file mode 100644
index 0000000000..93aad026e2
--- /dev/null
+++ b/recipes/iw/iw/kill-git-version-check.patch
@@ -0,0 +1,26 @@
+Index: iw-0.9.18/version.sh
+===================================================================
+--- iw-0.9.18.orig/version.sh 2010-09-14 13:50:27.000000000 +0400
++++ iw-0.9.18/version.sh 2010-09-14 13:50:40.000000000 +0400
+@@ -5,20 +5,6 @@
+
+ echo '#include "iw.h"' > "$OUT"
+
+-if head=`git rev-parse --verify HEAD 2>/dev/null`; then
+- git update-index --refresh --unmerged > /dev/null
+- descr=$(git describe)
+-
+- # on git builds check that the version number above
+- # is correct...
+- [ "${descr%%-*}" = "v$VERSION" ] || exit 2
+-
+- v="${descr#v}"
+- if git diff-index --name-only HEAD | read dummy ; then
+- v="$v"-dirty
+- fi
+-else
+- v="$VERSION"
+-fi
++v="$VERSION"
+
+ echo "const char iw_version[] = \"$v\";" >> "$OUT"
diff --git a/recipes/iw/iw_0.9.20.bb b/recipes/iw/iw_0.9.20.bb
index 4319d6797a..6645e2ef48 100644
--- a/recipes/iw/iw_0.9.20.bb
+++ b/recipes/iw/iw_0.9.20.bb
@@ -3,11 +3,14 @@ HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/iw"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "BSD"
-PR = "r0"
+PR = "r1"
DEPENDS = "libnl pkgconfig"
-SRC_URI = "http://wireless.kernel.org/download/iw/${P}.tar.bz2"
+SRC_URI = " \
+ http://wireless.kernel.org/download/iw/${P}.tar.bz2 \
+ file://kill-git-version-check.patch \
+ "
do_compile() {
oe_runmake