aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/ecj/ecj-initial.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes/ecj/ecj-initial.bb b/recipes/ecj/ecj-initial.bb
index 6695fbd2b2..8ddbc7ccf6 100644
--- a/recipes/ecj/ecj-initial.bb
+++ b/recipes/ecj/ecj-initial.bb
@@ -13,6 +13,8 @@ PR = "r1"
SRC_URI = "file://ecj.in"
+NATIVE_INSTALL_WORKS = "1"
+
S = "${WORKDIR}"
inherit native
@@ -27,7 +29,7 @@ do_compile() {
cat ecj.in >> ecj-initial
}
-do_stage() {
- install -d ${STAGING_BINDIR}
- install -m 755 ${S}/ecj-initial ${STAGING_BINDIR}
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 ${S}/ecj-initial ${D}${bindir}
}