aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/sane-srcrevs.inc1
-rw-r--r--recipes/libsynthesis/libsynthesis_git.bb18
2 files changed, 19 insertions, 0 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index eaa988bfbe..8757a208a5 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -111,6 +111,7 @@ SRCREV_pn-libmokopanelui2 ?= "4568"
SRCREV_pn-libmokoui2 ?= "4342"
SRCREV_pn-libowl ?= "277"
SRCREV_pn-librfid ?= "2094"
+SRCREV_pn-libsynthesis ?= "70f0065aa3b085bdf059830f95e5b5766eecb0bb"
SRCREV_pn-libw100 ?= "47"
SRCREV_pn-libxcalibrate ?= "209d83af61ed38a002c8096377deac292b3e396c"
SRCREV_pn-libxosd ?= "627"
diff --git a/recipes/libsynthesis/libsynthesis_git.bb b/recipes/libsynthesis/libsynthesis_git.bb
new file mode 100644
index 0000000000..3571a75a9f
--- /dev/null
+++ b/recipes/libsynthesis/libsynthesis_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Synthesis SyncML Engine"
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
+LICENSE = "LGPLv2.1"
+PV = "0.0+git${SRCREV}"
+PR = "r1"
+
+DEPENDS = "libpcre"
+
+S = "${WORKDIR}/git"
+
+inherit autotools_stage
+
+do_configure_prepend () {
+ cd ${S}/src
+ ${S}/src/gen-makefile-am.sh
+ cd ${S}
+}
+