aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/ttf-fonts/ttf-arphic-uming_20080216.bb15
-rw-r--r--packages/ttf-fonts/ttf.inc7
2 files changed, 21 insertions, 1 deletions
diff --git a/packages/ttf-fonts/ttf-arphic-uming_20080216.bb b/packages/ttf-fonts/ttf-arphic-uming_20080216.bb
new file mode 100644
index 0000000000..6c2da7b669
--- /dev/null
+++ b/packages/ttf-fonts/ttf-arphic-uming_20080216.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Unicode Mingti (printed) TrueType Font"
+HOMEPAGE = "http://www.freedesktop.org/wiki/Software/CJKUnifonts"
+LICENSE = "${PN}"
+SRC_DISTRIBUTE_LICENSES += "${PN}"
+RPROVIDES = "virtual/chinese-font"
+PR = "r0"
+
+SRC_URI = \
+"http://archive.ubuntu.com/ubuntu/pool/main/t/ttf-arphic-uming/ttf-arphic-uming_0.2.${PV}.1.orig.tar.gz"
+S = "${WORKDIR}"
+
+require ttf.inc
+
+FILES_${PN} = "${datadir}"
+
diff --git a/packages/ttf-fonts/ttf.inc b/packages/ttf-fonts/ttf.inc
index 00363c565f..98bd5b820d 100644
--- a/packages/ttf-fonts/ttf.inc
+++ b/packages/ttf-fonts/ttf.inc
@@ -4,7 +4,12 @@ RRECOMMENDS += "font-update-common"
do_install() {
install -d ${D}${datadir}/fonts/truetype/
- install -m 0644 ${S}/*.ttf ${D}${datadir}/fonts/truetype/
+ if [ -e *.ttf ]; then
+ install -m 0644 *.ttf ${D}${datadir}/fonts/truetype/
+ fi
+ if [ -e *.ttc ]; then
+ install -m 0644 *.ttc ${D}${datadir}/fonts/truetype/
+ fi
}
pkg_postinst_append() {