aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/gdb/gdb-cross_6.1.bb33
-rw-r--r--packages/gdb/gdb-cross_6.2.bb33
-rw-r--r--packages/gdb/gdb-cross_6.6.bb (renamed from packages/gdb/gdb-cross_6.2.1.bb)7
-rw-r--r--packages/gdb/gdb_6.1.bb51
-rw-r--r--packages/gdb/gdb_6.2.bb46
-rw-r--r--packages/gdb/gdb_6.6.bb (renamed from packages/gdb/gdb_6.2.1.bb)13
6 files changed, 14 insertions, 169 deletions
diff --git a/packages/gdb/gdb-cross_6.1.bb b/packages/gdb/gdb-cross_6.1.bb
deleted file mode 100644
index b90e8b7bd1..0000000000
--- a/packages/gdb/gdb-cross_6.1.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-require gdb.inc
-
-DEPENDS = "ncurses-native"
-
-inherit autotools sdk
-
-S = "${WORKDIR}/gdb-${PV}"
-SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
- file://sim-install.patch;patch=1"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
-
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CXX_FOR_BUILD = "${BUILD_CXX}"
-export CPP_FOR_BUILD = "${BUILD_CPP}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
-export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
-
-EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
-
-EXTRA_OECONF = "--with-curses --with-readline"
-
-do_configure () {
-# override this function to avoid the autoconf/automake/aclocal/autoheader
-# calls for now
- gnu-configize
- oe_runconf
-}
-
-do_stage() {
- :
-}
diff --git a/packages/gdb/gdb-cross_6.2.bb b/packages/gdb/gdb-cross_6.2.bb
deleted file mode 100644
index b90e8b7bd1..0000000000
--- a/packages/gdb/gdb-cross_6.2.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-require gdb.inc
-
-DEPENDS = "ncurses-native"
-
-inherit autotools sdk
-
-S = "${WORKDIR}/gdb-${PV}"
-SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
- file://sim-install.patch;patch=1"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
-
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CXX_FOR_BUILD = "${BUILD_CXX}"
-export CPP_FOR_BUILD = "${BUILD_CPP}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
-export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
-
-EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
-
-EXTRA_OECONF = "--with-curses --with-readline"
-
-do_configure () {
-# override this function to avoid the autoconf/automake/aclocal/autoheader
-# calls for now
- gnu-configize
- oe_runconf
-}
-
-do_stage() {
- :
-}
diff --git a/packages/gdb/gdb-cross_6.2.1.bb b/packages/gdb/gdb-cross_6.6.bb
index 894b5b22e7..32076b529e 100644
--- a/packages/gdb/gdb-cross_6.2.1.bb
+++ b/packages/gdb/gdb-cross_6.6.bb
@@ -1,6 +1,7 @@
-require gdb.inc
-
+LICENSE = "GPL"
+DESCRIPTION = "gdb - GNU debugger"
SECTION = "base"
+PRIORITY = "optional"
DEPENDS = "ncurses-native"
inherit autotools sdk
@@ -30,5 +31,5 @@ do_configure () {
}
do_stage() {
- :
+ :
}
diff --git a/packages/gdb/gdb_6.1.bb b/packages/gdb/gdb_6.1.bb
deleted file mode 100644
index 6191061d16..0000000000
--- a/packages/gdb/gdb_6.1.bb
+++ /dev/null
@@ -1,51 +0,0 @@
-require gdb.inc
-
-DEPENDS = "ncurses readline"
-
-PACKAGES =+ 'gdbserver '
-FILES_gdbserver = '${bindir}/gdbserver'
-
-inherit autotools gettext
-
-SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
- file://uclibc.patch;patch=1"
-
-LDFLAGS_append = " -s"
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CXX_FOR_BUILD = "${BUILD_CXX}"
-export CPP_FOR_BUILD = "${BUILD_CPP}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
-export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
-export CFLAGS_append=" -L${STAGING_LIBDIR}"
-EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils'"
-
-EXTRA_OECONF = "--disable-gdbtk --disable-tui --disable-x \
- --with-curses --with-readline --disable-sim \
- --program-prefix=''"
-
-do_configure () {
-# override this function to avoid the autoconf/automake/aclocal/autoheader
-# calls for now
- gnu-configize
- oe_runconf
-}
-
-do_install () {
- make -C bfd/doc chew LDFLAGS= CFLAGS=-O2
- oe_runmake install \
- 'prefix=${D}${prefix}' 'exec_prefix=${D}${prefix}' 'bindir=${D}${bindir}' \
- 'sbindir=${D}${sbindir}' 'infodir=${D}${infodir}' 'libdir=${D}${libdir}' \
- 'mandir=${D}${mandir}' 'includedir=${D}${includedir}'
- install -d ${D}${bindir}
- install -m 0755 gdb/gdbserver/gdbserver ${D}${bindir}
-}
-
-#
-# patch description
-#
-# readline.patch:
-# gdb 5.3 provides its own readline source which tends to conflict with
-# readline package. we override readline included from gdb source
-# with packaged readline and fix up extern tilde_expand in gdb/defs.h
-#
diff --git a/packages/gdb/gdb_6.2.bb b/packages/gdb/gdb_6.2.bb
deleted file mode 100644
index 75a08972a5..0000000000
--- a/packages/gdb/gdb_6.2.bb
+++ /dev/null
@@ -1,46 +0,0 @@
-require gdb.inc
-
-PR = "r1"
-DEPENDS = "ncurses readline"
-
-PACKAGES =+ 'gdbserver '
-FILES_gdbserver = '${bindir}/gdbserver'
-
-inherit autotools gettext
-
-SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
- file://uclibc.patch;patch=1"
-
-LDFLAGS_append = " -s"
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CXX_FOR_BUILD = "${BUILD_CXX}"
-export CPP_FOR_BUILD = "${BUILD_CPP}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
-export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
-export CFLAGS_append=" -L${STAGING_LIBDIR}"
-EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils'"
-
-EXTRA_OECONF = "--disable-gdbtk --disable-tui --disable-x \
- --with-curses --disable-multilib --with-readline --disable-sim \
- --program-prefix=''"
-
-S = "${WORKDIR}/gdb-${PV}"
-B = "${WORKDIR}/build-${TARGET_SYS}"
-
-do_configure () {
-# override this function to avoid the autoconf/automake/aclocal/autoheader
-# calls for now
- (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
- CPPFLAGS="" oe_runconf
-}
-
-do_install () {
- make -C bfd/doc chew LDFLAGS= CFLAGS=-O2
- oe_runmake install \
- 'prefix=${D}' 'exec_prefix=${D}' 'bindir=${D}${base_bindir}' \
- 'sbindir=${D}${base_sbindir}' 'infodir=${D}/share/info' 'libdir=${D}${base_libdir}' \
- 'mandir=${D}/share/man' 'includedir=${D}/include'
- install -d ${D}${bindir}
- install -m 0755 gdb/gdbserver/gdbserver ${D}${bindir}
-}
diff --git a/packages/gdb/gdb_6.2.1.bb b/packages/gdb/gdb_6.6.bb
index 641cd927b1..1bfe3dfecf 100644
--- a/packages/gdb/gdb_6.2.1.bb
+++ b/packages/gdb/gdb_6.6.bb
@@ -1,14 +1,21 @@
-require gdb.inc
-
+DESCRIPTION = "gdb - GNU debugger"
+HOMEPAGE = "http://www.gnu.org/software/gdb/"
+LICENSE="GPL"
+SECTION = "devel"
+PRIORITY = "optional"
DEPENDS = "ncurses readline"
+PR = "r0"
PACKAGES =+ 'gdbserver '
FILES_gdbserver = '${bindir}/gdbserver'
+RRECOMMENDS_gdb = "glibc-thread-db"
+
inherit autotools gettext
SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
- file://uclibc.patch;patch=1 \
+#FIXME file://uclibc.patch;patch=1 \
+ file://kill_arm_map_symbols.patch;patch=1 \
file://gdbserver-cflags-last.diff;patch=1;pnum=0"
LDFLAGS_append = " -s"