aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MAINTAINERS6
-rw-r--r--packages/gnuplot/files/gnuplot.desktop6
-rw-r--r--packages/gnuplot/gnuplot-4.2.0/term.patch20
-rw-r--r--packages/gnuplot/gnuplot.inc37
-rw-r--r--packages/gnuplot/gnuplot_4.0.0.bb36
-rw-r--r--packages/gnuplot/gnuplot_4.2.0.bb40
6 files changed, 74 insertions, 71 deletions
diff --git a/MAINTAINERS b/MAINTAINERS
index 1e6b9821b9..0b039beeea 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -90,6 +90,12 @@ Person: Joaquim Duran
Mail: joaquinduran@adtelecom.es
Recipes: gtk+, gtkmm
+Person: Junqian Gordon Xu 'xjqian'
+Mail: xjqian@gmail.com
+Machines: tosa, borzoi, nokia770
+Distros: Ångström
+Recipes: gnuplot
+
Person: Justin Patrin
Mail: papercrane@reversefold.com
Website: http://www.reversefold.com
diff --git a/packages/gnuplot/files/gnuplot.desktop b/packages/gnuplot/files/gnuplot.desktop
index f108e3f46f..f67df9e193 100644
--- a/packages/gnuplot/files/gnuplot.desktop
+++ b/packages/gnuplot/files/gnuplot.desktop
@@ -2,7 +2,7 @@
Name=Gnuplot
Comment=Plot data and function graphs
Exec=x-terminal-emulator -e gnuplot
-Terminal=0
+Terminal=false
Type=Application
-Icon=gnuplot.png
-Categories=Scientific
+Icon=gnuplot
+Categories=Science;
diff --git a/packages/gnuplot/gnuplot-4.2.0/term.patch b/packages/gnuplot/gnuplot-4.2.0/term.patch
new file mode 100644
index 0000000000..41aa8e7a97
--- /dev/null
+++ b/packages/gnuplot/gnuplot-4.2.0/term.patch
@@ -0,0 +1,20 @@
+--- gnuplot-4.2.0/src/term.h.old 2007-11-16 01:21:09.000000000 -0600
++++ gnuplot-4.2.0/src/term.h 2007-11-16 01:22:45.000000000 -0600
+@@ -70,6 +70,7 @@
+ */
+ #ifdef SHORT_TERMLIST
+ # include "dumb.trm" /* dumb terminal */
++# include "qtopia.trm" /* QTopia terminal */
+
+ # ifdef GP_ENH_EST
+ # include "estimate.trm" /* used for enhanced text processing */
+@@ -436,6 +437,9 @@
+ /* TeXDraw drawing package for LaTeX */
+ #include "texdraw.trm"
+
++/* Qtopia */
++#include "qtopia.trm"
++
+ /* METAFONT */
+ #include "metafont.trm"
+
diff --git a/packages/gnuplot/gnuplot.inc b/packages/gnuplot/gnuplot.inc
new file mode 100644
index 0000000000..9f1eebf003
--- /dev/null
+++ b/packages/gnuplot/gnuplot.inc
@@ -0,0 +1,37 @@
+DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
+(text or binary) and function plotting utility."
+HOMEPAGE = "http://www.gnuplot.info/"
+SECTION = "console/scientific"
+LICENSE = "BSD-4"
+PRIORITY = "optional"
+DEPENDS = "pango cairo virtual/libx11 libpng gd readline"
+
+inherit autotools
+
+acpaths = ""
+
+EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
+ --without-plot \
+ --with-png=${STAGING_LIBDIR}/.. \
+ --with-gd=${STAGING_LIBDIR}/.. \
+ --without-lisp-files \
+ --without-tutorial"
+
+do_compile_prepend() {
+ install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/
+}
+
+do_install_append() {
+ install -d ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
+}
+
+PACKAGES =+ "${PN}-x11-dbg ${PN}-x11"
+DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
+SECTION_${PN}-x11 = "x11/scientific"
+FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 "
+
+FILES_${PN} += "${datadir}/texmf"
+FILES_${PN}-x11-dbg += "${libexecdir}/gnuplot/*/.debug"
diff --git a/packages/gnuplot/gnuplot_4.0.0.bb b/packages/gnuplot/gnuplot_4.0.0.bb
index 150fc8d6e5..6e1be52173 100644
--- a/packages/gnuplot/gnuplot_4.0.0.bb
+++ b/packages/gnuplot/gnuplot_4.0.0.bb
@@ -1,10 +1,6 @@
-DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
-(text or binary) and function plotting utility."
-SECTION = "console/scientific"
-LICENSE = "BSD-4"
-PRIORITY = "optional"
-DEPENDS = "virtual/libx11 libpng gd readline"
-PR = "r3"
+require gnuplot.inc
+
+PR = "r4"
SRC_URI = "ftp://ftp.gnuplot.info/pub/gnuplot/gnuplot-${PV}.tar.gz \
file://subdirs.patch;patch=1 \
@@ -14,29 +10,3 @@ SRC_URI = "ftp://ftp.gnuplot.info/pub/gnuplot/gnuplot-${PV}.tar.gz \
file://term.patch;patch=1 \
file://gnuplot.desktop \
file://gnuplot.png"
-
-inherit autotools
-
-PACKAGES =+ "${PN}-x11"
-DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
-SECTION_${PN}-x11 = "x11/scientific"
-FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps"
-
-acpaths = ""
-EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
- --without-plot \
- --with-png=${STAGING_LIBDIR}/.. \
- --with-gd=${STAGING_LIBDIR}/.. \
- --without-lisp-files \
- --without-tutorial"
-
-do_compile_prepend() {
- install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/
-}
-
-do_install_append() {
- install -d ${D}${datadir}/applications/
- install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
- install -d ${D}${datadir}/pixmaps/
- install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
-}
diff --git a/packages/gnuplot/gnuplot_4.2.0.bb b/packages/gnuplot/gnuplot_4.2.0.bb
index d750aac66a..1df0c9fa21 100644
--- a/packages/gnuplot/gnuplot_4.2.0.bb
+++ b/packages/gnuplot/gnuplot_4.2.0.bb
@@ -1,40 +1,10 @@
-DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
-(text or binary) and function plotting utility."
-SECTION = "console/scientific"
-LICENSE = "BSD-4"
-PRIORITY = "optional"
-DEPENDS = "pango cairo virtual/libx11 libpng gd readline"
-PR = "r0"
+require gnuplot.inc
+
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/gnuplot/${PN}-${PV}.tar.gz \
+ http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz \
file://subdirs.patch;patch=1 \
+ file://term.patch;patch=1 \
file://gnuplot.desktop \
file://gnuplot.png"
-
-inherit autotools
-
-acpaths = ""
-EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
- --without-plot \
- --with-png=${STAGING_LIBDIR}/.. \
- --with-gd=${STAGING_LIBDIR}/.. \
- --without-lisp-files \
- --without-tutorial"
-
-do_install_append() {
- install -d ${D}${datadir}/applications/
- install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
- install -d ${D}${datadir}/pixmaps/
- install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
-}
-
-
-PACKAGES =+ "${PN}-x11-dbg ${PN}-x11"
-DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
-SECTION_${PN}-x11 = "x11/scientific"
-FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 "
-
-FILES_${PN} += "${datadir}/texmf"
-FILES_${PN}-x11-dbg += "${libexecdir}/gnuplot/*/.debug"
-
-