aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/nodejs/nodejs_0.2.1.bb23
1 files changed, 14 insertions, 9 deletions
diff --git a/recipes/nodejs/nodejs_0.2.1.bb b/recipes/nodejs/nodejs_0.2.1.bb
index 5479118f8c..b2bbcc308b 100644
--- a/recipes/nodejs/nodejs_0.2.1.bb
+++ b/recipes/nodejs/nodejs_0.2.1.bb
@@ -1,7 +1,11 @@
DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
HOMEPAGE = "http://nodejs.org"
LICENSE = "MIT"
+
+PR = "r1"
+
DEPENDS = "openssl"
+
SRC_URI = " \
http://nodejs.org/dist/node-v${PV}.tar.gz \
file://libev-cross-cc.patch \
@@ -9,20 +13,21 @@ SRC_URI = " \
"
SRC_URI[md5sum] = "c6051dd216817bf0f95bea80c42cf262"
SRC_URI[sha256sum] = "5bb7d084b2138ce43fcb34739ed894379c450a1dd569a1c710405bc39d2861c2"
+
S = "${WORKDIR}/node-v${PV}"
+
+# v8 errors out if you have set CCACHE
+CCACHE = ""
+
do_configure () {
- ./configure --without-snapshot
+ ./configure --prefix=${prefix} --without-snapshot
}
+
do_compile () {
make
}
-do_install () {
- #oe_runmake install # doesn't install to correct location
- # This works
- install -d ${D}${bindir}/
- install -m 0755 ${S}/build/default/node ${D}${bindir}/
- install -m 0755 ${S}/bin/node-waf ${D}${bindir}/
- install -m 0755 ${S}/bin/node-repl ${D}${bindir}/
+do_install () {
+ DESTDIR=${D} oe_runmake install
}
-FILES_${PN} = "${bindir}/node ${bindir}/node-repl ${bindir}/node-waf"
+