aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/wpa-supplicant/wpa-gui_0.4.8.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/wpa-supplicant/wpa-gui_0.4.8.bb b/packages/wpa-supplicant/wpa-gui_0.4.8.bb
new file mode 100644
index 0000000000..0908a5c995
--- /dev/null
+++ b/packages/wpa-supplicant/wpa-gui_0.4.8.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Qt interface for choosing which configured network to connect \
+to. It also provides a method for browsing 802.11 SSID scan results, an event \
+history log of messages generated by wpa_supplicant, and a method to add or \
+edit wpa_supplicant networks."
+SECTION = "network"
+LICENSE = "GPL BSD"
+HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/"
+
+SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz "
+
+S = "${WORKDIR}/wpa_supplicant-${PV}/wpa_gui/"
+
+inherit qmake qt3x11
+
+EXTRA_QMAKEVARS_POST += "CONFIG+=thread"
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 755 wpa_gui ${D}${sbindir}
+}