aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/ghi270.conf46
-rw-r--r--packages/base-files/base-files/ghi270/.mtn2git_empty0
-rw-r--r--packages/bluez/bluez-utils.inc12
-rw-r--r--packages/bluez/files/ghi270/.mtn2git_empty0
-rw-r--r--packages/bluez/files/r1000/.mtn2git_empty0
-rw-r--r--packages/linux/linux-handhelds-2.6.inc2
-rw-r--r--packages/linux/linux-handhelds-2.6/ghi270/.mtn2git_empty0
-rw-r--r--packages/linux/linux-handhelds-2.6_2.6.21-hh11.bb13
-rw-r--r--packages/netbase/netbase/ghi270/.mtn2git_empty0
-rw-r--r--packages/xserver-common/files/ghi270/.mtn2git_empty0
10 files changed, 72 insertions, 1 deletions
diff --git a/conf/machine/ghi270.conf b/conf/machine/ghi270.conf
new file mode 100644
index 0000000000..3536485cab
--- /dev/null
+++ b/conf/machine/ghi270.conf
@@ -0,0 +1,46 @@
+#@TYPE: Machine
+#@NAME: GHI270 / DuraMax H / DuraMaxHG
+#@DESCRIPTION: Machine configuration for the GHI270 platform with a pxa27x CPU
+
+#
+# Hardware-based properties
+#
+TARGET_ARCH = "arm"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt "
+
+# Use tune-xscale per default. Machine independent feeds should be built with tune-strongarm.
+require conf/machine/include/tune-xscale.inc
+
+# Uncomment this to use iwmmxt optimizations. Remove the above xscale stuff first
+#require conf/machine/include/tune-iwmmxt.inc
+
+EXTRA_IMAGECMD_jffs2_ghi270 = "-p -n -e 16KiB"
+
+ROOT_FLASH_SIZE = "64"
+VOLATILE_STORAGE_SIZE = "64"
+MACHINE_GUI_CLASS = "smallscreen"
+MACHINE_DISPLAY_WIDTH_PIXELS = "240"
+MACHINE_DISPLAY_HEIGHT_PIXELS = "320"
+MACHINE_FEATURES = "kernel26 touchscreen apm alsa pcmcia bluetooth irda wifi usbgadget screen"
+
+#
+# Software/packages selection
+#
+PREFERRED_PROVIDER_virtual/kernel = "linux-handhelds-2.6"
+PREFERRED_VERSION_linux-handhelds-2.6 = "2.6.21-hh11"
+
+PCMCIA_MANAGER = "pcmciautils"
+MODUTILS = "26"
+
+#PREFERRED_VERSION_xserver-kdrive = "1.3.0.0"
+
+#PREFERRED_VERSION_orinoco-modules = "0.15rc1"
+
+#
+# Modules autoload and other boot properties
+#
+
+#FIXME: this should be controlled by a userspace utility later.
+module_autoload_g_ether = "g_ether"
+
+SERIAL_CONSOLE = "115200 ttySA0"
diff --git a/packages/base-files/base-files/ghi270/.mtn2git_empty b/packages/base-files/base-files/ghi270/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/base-files/base-files/ghi270/.mtn2git_empty
diff --git a/packages/bluez/bluez-utils.inc b/packages/bluez/bluez-utils.inc
index 8a8766cbf8..4d2ce6505e 100644
--- a/packages/bluez/bluez-utils.inc
+++ b/packages/bluez/bluez-utils.inc
@@ -12,6 +12,8 @@ SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
file://hciattach-ti-bts.patch;patch=1 \
file://handle-eintr.patch;patch=1;status=applied"
+SRC_URI_append_r1000 = " file://hciattach.sh"
+SRC_URI_append_ghi270 = " file://hciattach.sh"
# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
# Let's default to that instead of 'any' until further notice...
@@ -43,6 +45,16 @@ do_install_append() {
install -m 0755 ${S}/daemon/.libs/passkey-agent ${D}${base_bindir}/
}
+do_install_append_r1000() {
+ install -d ${D}${sysconfdir} ${D}${sysconfdir}/bluetooth
+ install -m 0755 ${WORKDIR}/hciattach.sh ${D}${sysconfdir}/bluetooth/hciattach
+}
+
+do_install_append_ghi270() {
+ install -d ${D}${sysconfdir} ${D}${sysconfdir}/bluetooth
+ install -m 0755 ${WORKDIR}/hciattach.sh ${D}${sysconfdir}/bluetooth/hciattach
+}
+
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
${sysconfdir}/default/bluetooth"
diff --git a/packages/bluez/files/ghi270/.mtn2git_empty b/packages/bluez/files/ghi270/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bluez/files/ghi270/.mtn2git_empty
diff --git a/packages/bluez/files/r1000/.mtn2git_empty b/packages/bluez/files/r1000/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bluez/files/r1000/.mtn2git_empty
diff --git a/packages/linux/linux-handhelds-2.6.inc b/packages/linux/linux-handhelds-2.6.inc
index e1c8fbf189..d2256b5f27 100644
--- a/packages/linux/linux-handhelds-2.6.inc
+++ b/packages/linux/linux-handhelds-2.6.inc
@@ -3,7 +3,7 @@ DESCRIPTION = "handhelds.org Linux kernel 2.6 for PocketPCs and other consumer h
LICENSE = "GPL"
COMPATIBLE_HOST = "arm.*-linux"
-COMPATIBLE_MACHINE ?= '(asus620|asus730|aximx50|aximx50v|h1910|h2200|h3600|h3800|h3900|h4000|h5000|htcalpine|htcapache|htcblueangel|htchermes|htchimalaya|htcsable|htcuniversal|htcwallaby|hx4700|looxc550|jornada56x|magician|rx1950|rx3000)'
+COMPATIBLE_MACHINE ?= '(asus620|asus730|aximx50|aximx50v|h1910|h2200|h3600|h3800|h3900|h4000|h5000|htcalpine|htcapache|htcblueangel|htchermes|htchimalaya|htcsable|htcuniversal|htcwallaby|hx4700|ghi270|looxc550|jornada56x|magician|rx1950|rx3000)'
# SRC_URI *must* be overriden in includer, but this is a good reference
SRC_URI ?= "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
diff --git a/packages/linux/linux-handhelds-2.6/ghi270/.mtn2git_empty b/packages/linux/linux-handhelds-2.6/ghi270/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/linux/linux-handhelds-2.6/ghi270/.mtn2git_empty
diff --git a/packages/linux/linux-handhelds-2.6_2.6.21-hh11.bb b/packages/linux/linux-handhelds-2.6_2.6.21-hh11.bb
new file mode 100644
index 0000000000..7e3f93c92e
--- /dev/null
+++ b/packages/linux/linux-handhelds-2.6_2.6.21-hh11.bb
@@ -0,0 +1,13 @@
+SECTION = "kernel"
+DESCRIPTION = "handhelds.org Linux kernel 2.6 for PocketPCs and other consumer handheld devices."
+LICENSE = "GPL"
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
+ file://defconfig"
+
+SRC_URI_append_ghi270 = " file://ghi270-hh11.patch;patch=1"
+
+require linux-handhelds-2.6.inc
diff --git a/packages/netbase/netbase/ghi270/.mtn2git_empty b/packages/netbase/netbase/ghi270/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/netbase/netbase/ghi270/.mtn2git_empty
diff --git a/packages/xserver-common/files/ghi270/.mtn2git_empty b/packages/xserver-common/files/ghi270/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xserver-common/files/ghi270/.mtn2git_empty