aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xcontrib/python/generate-manifest.py20
-rw-r--r--packages/python/python-2.4.4-manifest.inc (renamed from packages/python/python-2.4.3-manifest.inc)16
-rw-r--r--packages/python/python-2.4.4/.mtn2git_empty (renamed from packages/python/python-2.4.3/.mtn2git_empty)0
-rw-r--r--packages/python/python-2.4.4/autohell.patch (renamed from packages/python/python-2.4.3/autohell.patch)0
-rw-r--r--packages/python/python-2.4.4/bindir-libdir.patch (renamed from packages/python/python-2.4.3/bindir-libdir.patch)0
-rw-r--r--packages/python/python-2.4.4/crosscompile.patch (renamed from packages/python/python-2.4.3/crosscompile.patch)0
-rw-r--r--packages/python/python-2.4.4/fix-tkinter-detection.patch (renamed from packages/python/python-2.4.3/fix-tkinter-detection.patch)0
-rw-r--r--packages/python/python-2.4.4/sitebranding.patch (renamed from packages/python/python-2.4.3/sitebranding.patch)0
-rw-r--r--packages/python/python_2.4.4.bb (renamed from packages/python/python_2.4.3.bb)2
9 files changed, 19 insertions, 19 deletions
diff --git a/contrib/python/generate-manifest.py b/contrib/python/generate-manifest.py
index 9810c7b1ae..ec65d221c3 100755
--- a/contrib/python/generate-manifest.py
+++ b/contrib/python/generate-manifest.py
@@ -8,12 +8,12 @@ import os
import sys
import time
-VERSION = "2.4.3"
+VERSION = "2.4.4"
# increase when touching python-core
BASEREV = 0
__author__ = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-__version__ = "$Revision: 1.20 $"
+__version__ = "$Revision: 1.21 $"
class MakefileMaker:
@@ -24,7 +24,7 @@ class MakefileMaker:
self.targetPrefix = "${libdir}/python%s" % VERSION[:3]
self.output = outfile
self.out( "#" * 120 )
- self.out( "### AUTO-GENERATED by '%s' [(C) 2002-2006 Michael 'Mickey' Lauer <mickey@Vanille.de>] on %s" % ( sys.argv[0], time.asctime() ) )
+ self.out( "### AUTO-GENERATED by '%s' [(C) 2002-2007 Michael 'Mickey' Lauer <mickey@Vanille.de>] on %s" % ( sys.argv[0], time.asctime() ) )
self.out( "###" )
self.out( "### Visit THE Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy" )
self.out( "###" )
@@ -158,7 +158,7 @@ if __name__ == "__main__":
m.setPrefix( "/", "/usr/" )
- m.addPackage( 1, "python-core", "Python Interpreter and core modules (needed!)", "",
+ m.addPackage( 0, "python-core", "Python Interpreter and core modules (needed!)", "",
"lib/python2.4/__future__.* lib/python2.4/copy.* lib/python2.4/copy_reg.* lib/python2.4/ConfigParser.py " +
"lib/python2.4/getopt.* lib/python2.4/linecache.* lib/python2.4/new.* " +
"lib/python2.4/os.* lib/python2.4/posixpath.* " +
@@ -202,7 +202,7 @@ if __name__ == "__main__":
m.addPackage( 0, "python-textutils", "Python Option Parsing, Text Wrapping and Comma-Separated-Value Support", "python-core, python-io, python-re, python-stringold",
"lib-dynload/_csv.so csv.* optparse.* textwrap.*" )
- m.addPackage( 1, "python-curses", "Python Curses Support", "python-core",
+ m.addPackage( 0, "python-curses", "Python Curses Support", "python-core",
"curses lib-dynload/_curses.so lib-dynload/_curses_panel.so" ) # package
m.addPackage( 0, "python-datetime", "Python Calendar and Time support", "python-core, python-codecs",
@@ -236,7 +236,7 @@ if __name__ == "__main__":
"lib-dynload/_socket.so lib-dynload/_ssl.so lib-dynload/select.so lib-dynload/termios.so lib-dynload/cStringIO.so "
"pipes.* socket.* tempfile.* StringIO.* " )
- m.addPackage( 1, "python-lang", "Python Low-Level Language Support", "python-core",
+ m.addPackage( 0, "python-lang", "Python Low-Level Language Support", "python-core",
"lib-dynload/array.so lib-dynload/parser.so lib-dynload/operator.so lib-dynload/_weakref.so " +
"lib-dynload/itertools.so lib-dynload/collections.so lib-dynload/_bisect.so lib-dynload/_heapq.so " +
"atexit.* bisect.* code.* codeop.* dis.* heapq.* inspect.* keyword.* opcode.* repr.* token.* tokenize.* " +
@@ -263,14 +263,14 @@ if __name__ == "__main__":
m.addPackage( 0, "python-unixadmin", "Python Unix Administration Support", "python-core",
"lib-dynload/nis.so lib-dynload/grp.so lib-dynload/pwd.so getpass.*" )
- m.addPackage( 1, "python-netclient", "Python Internet Protocol Clients", "python-core, python-datetime, python-io, python-lang, python-logging, python-mime",
+ m.addPackage( 0, "python-netclient", "Python Internet Protocol Clients", "python-core, python-datetime, python-io, python-lang, python-logging, python-mime",
"*Cookie*.* " +
"base64.* cookielib.* ftplib.* gopherlib.* hmac.* httplib.* mimetypes.* nntplib.* poplib.* smtplib.* telnetlib.* urllib.* urllib2.* urlparse.*" )
m.addPackage( 0, "python-netserver", "Python Internet Protocol Servers", "python-core, python-netclient",
"cgi.* BaseHTTPServer.* SimpleHTTPServer.* SocketServer.*" )
- m.addPackage( 1, "python-pickle", "Python Persistence Support", "python-core, python-codecs, python-io, python-re",
+ m.addPackage( 0, "python-pickle", "Python Persistence Support", "python-core, python-codecs, python-io, python-re",
"pickle.* shelve.* lib-dynload/cPickle.so" )
m.addPackage( 0, "python-pprint", "Python Pretty-Print Support", "python-core",
@@ -306,7 +306,7 @@ if __name__ == "__main__":
m.addPackage( 0, "python-tests", "Python Tests", "python-core",
"test" ) # package
- m.addPackage( 1, "python-threading", "Python Threading & Synchronization Support", "python-core, python-lang",
+ m.addPackage( 0, "python-threading", "Python Threading & Synchronization Support", "python-core, python-lang",
"_threading_local.* dummy_thread.* dummy_threading.* mutex.* threading.* Queue.*" )
m.addPackage( 0, "python-unittest", "Python Unit Testing Framework", "python-core, python-stringold, python-lang",
@@ -318,7 +318,7 @@ if __name__ == "__main__":
m.addPackage( 0, "python-xmlrpc", "Python XMLRPC Support", "python-core, python-xml, python-netserver, python-lang",
"xmlrpclib.* SimpleXMLRPCServer.*" )
- m.addPackage( 1, "python-zlib", "Python zlib Support.", "python-core",
+ m.addPackage( 0, "python-zlib", "Python zlib Support.", "python-core",
"lib-dynload/zlib.so" )
m.addPackage( 0, "python-mailbox", "Python Mailbox Format Support", "python-core, python-mime",
diff --git a/packages/python/python-2.4.3-manifest.inc b/packages/python/python-2.4.4-manifest.inc
index c116628678..35017aefe7 100644
--- a/packages/python/python-2.4.3-manifest.inc
+++ b/packages/python/python-2.4.4-manifest.inc
@@ -1,5 +1,5 @@
########################################################################################################################
-### AUTO-GENERATED by './generate-manifest.py' [(C) 2002-2006 Michael 'Mickey' Lauer <mickey@Vanille.de>] on Mon Nov 6 00:30:11 2006
+### AUTO-GENERATED by '/local/pkg/oe/org.openembedded.dev/contrib/python/generate-manifest.py' [(C) 2002-2007 Michael 'Mickey' Lauer <mickey@Vanille.de>] on Mon Dec 25 00:05:05 2006
###
### Visit THE Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
###
@@ -18,7 +18,7 @@ RDEPENDS_python-profile="python-core"
FILES_python-profile="${libdir}/python2.4/profile.* ${libdir}/python2.4/pstats.* "
DESCRIPTION_python-threading="Python Threading & Synchronization Support"
-PR_python-threading="ml1"
+PR_python-threading="ml0"
RDEPENDS_python-threading="python-core python-lang"
FILES_python-threading="${libdir}/python2.4/_threading_local.* ${libdir}/python2.4/dummy_thread.* ${libdir}/python2.4/dummy_threading.* ${libdir}/python2.4/mutex.* ${libdir}/python2.4/threading.* ${libdir}/python2.4/Queue.* "
@@ -38,7 +38,7 @@ RDEPENDS_python-codecs="python-core"
FILES_python-codecs="${libdir}/python2.4/codecs.* ${libdir}/python2.4/encodings ${libdir}/python2.4/gettext.* ${libdir}/python2.4/locale.* ${libdir}/python2.4/lib-dynload/_locale.so ${libdir}/python2.4/lib-dynload/unicodedata.so ${libdir}/python2.4/stringprep.* ${libdir}/python2.4/xdrlib.* "
DESCRIPTION_python-pickle="Python Persistence Support"
-PR_python-pickle="ml1"
+PR_python-pickle="ml0"
RDEPENDS_python-pickle="python-core python-codecs python-io python-re"
FILES_python-pickle="${libdir}/python2.4/pickle.* ${libdir}/python2.4/shelve.* ${libdir}/python2.4/lib-dynload/cPickle.so "
@@ -48,7 +48,7 @@ RDEPENDS_python-datetime="python-core python-codecs"
FILES_python-datetime="${libdir}/python2.4/_strptime.* ${libdir}/python2.4/calendar.* ${libdir}/python2.4/lib-dynload/datetime.so "
DESCRIPTION_python-core="Python Interpreter and core modules (needed!)"
-PR_python-core="ml1"
+PR_python-core="ml0"
RDEPENDS_python-core=""
FILES_python-core="/usr/lib/python2.4/__future__.* /usr/lib/python2.4/copy.* /usr/lib/python2.4/copy_reg.* /usr/lib/python2.4/ConfigParser.py /usr/lib/python2.4/getopt.* /usr/lib/python2.4/linecache.* /usr/lib/python2.4/new.* /usr/lib/python2.4/os.* /usr/lib/python2.4/posixpath.* /usr/lib/python2.4/warnings.* /usr/lib/python2.4/site.* /usr/lib/python2.4/stat.* /usr/lib/python2.4/UserDict.* /usr/lib/python2.4/UserList.* /usr/lib/python2.4/UserString.* /usr/lib/python2.4/lib-dynload/binascii.so /usr/lib/python2.4/lib-dynload/struct.so /usr/lib/python2.4/lib-dynload/time.so /usr/lib/python2.4/lib-dynload/xreadlines.so /usr/lib/python2.4/types.* /usr/bin/python "
@@ -133,7 +133,7 @@ RDEPENDS_python-fcntl="python-core"
FILES_python-fcntl="${libdir}/python2.4/lib-dynload/fcntl.so "
DESCRIPTION_python-netclient="Python Internet Protocol Clients"
-PR_python-netclient="ml1"
+PR_python-netclient="ml0"
RDEPENDS_python-netclient="python-core python-datetime python-io python-lang python-logging python-mime"
FILES_python-netclient="${libdir}/python2.4/*Cookie*.* ${libdir}/python2.4/base64.* ${libdir}/python2.4/cookielib.* ${libdir}/python2.4/ftplib.* ${libdir}/python2.4/gopherlib.* ${libdir}/python2.4/hmac.* ${libdir}/python2.4/httplib.* ${libdir}/python2.4/mimetypes.* ${libdir}/python2.4/nntplib.* ${libdir}/python2.4/poplib.* ${libdir}/python2.4/smtplib.* ${libdir}/python2.4/telnetlib.* ${libdir}/python2.4/urllib.* ${libdir}/python2.4/urllib2.* ${libdir}/python2.4/urlparse.* "
@@ -148,7 +148,7 @@ RDEPENDS_python-netserver="python-core python-netclient"
FILES_python-netserver="${libdir}/python2.4/cgi.* ${libdir}/python2.4/BaseHTTPServer.* ${libdir}/python2.4/SimpleHTTPServer.* ${libdir}/python2.4/SocketServer.* "
DESCRIPTION_python-curses="Python Curses Support"
-PR_python-curses="ml1"
+PR_python-curses="ml0"
RDEPENDS_python-curses="python-core"
FILES_python-curses="${libdir}/python2.4/curses ${libdir}/python2.4/lib-dynload/_curses.so ${libdir}/python2.4/lib-dynload/_curses_panel.so "
@@ -238,7 +238,7 @@ RDEPENDS_python-mmap="python-core python-io"
FILES_python-mmap="${libdir}/python2.4/lib-dynload/mmap.so "
DESCRIPTION_python-zlib="Python zlib Support."
-PR_python-zlib="ml1"
+PR_python-zlib="ml0"
RDEPENDS_python-zlib="python-core"
FILES_python-zlib="${libdir}/python2.4/lib-dynload/zlib.so "
@@ -258,7 +258,7 @@ RDEPENDS_python-idle="python-core python-tkinter"
FILES_python-idle="/usr/bin/idle /usr/lib/python2.4/idlelib "
DESCRIPTION_python-lang="Python Low-Level Language Support"
-PR_python-lang="ml1"
+PR_python-lang="ml0"
RDEPENDS_python-lang="python-core"
FILES_python-lang="${libdir}/python2.4/lib-dynload/array.so ${libdir}/python2.4/lib-dynload/parser.so ${libdir}/python2.4/lib-dynload/operator.so ${libdir}/python2.4/lib-dynload/_weakref.so ${libdir}/python2.4/lib-dynload/itertools.so ${libdir}/python2.4/lib-dynload/collections.so ${libdir}/python2.4/lib-dynload/_bisect.so ${libdir}/python2.4/lib-dynload/_heapq.so ${libdir}/python2.4/atexit.* ${libdir}/python2.4/bisect.* ${libdir}/python2.4/code.* ${libdir}/python2.4/codeop.* ${libdir}/python2.4/dis.* ${libdir}/python2.4/heapq.* ${libdir}/python2.4/inspect.* ${libdir}/python2.4/keyword.* ${libdir}/python2.4/opcode.* ${libdir}/python2.4/repr.* ${libdir}/python2.4/token.* ${libdir}/python2.4/tokenize.* ${libdir}/python2.4/traceback.* ${libdir}/python2.4/linecache.* ${libdir}/python2.4/weakref.* "
diff --git a/packages/python/python-2.4.3/.mtn2git_empty b/packages/python/python-2.4.4/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/python/python-2.4.3/.mtn2git_empty
+++ b/packages/python/python-2.4.4/.mtn2git_empty
diff --git a/packages/python/python-2.4.3/autohell.patch b/packages/python/python-2.4.4/autohell.patch
index b0eebb9ce8..b0eebb9ce8 100644
--- a/packages/python/python-2.4.3/autohell.patch
+++ b/packages/python/python-2.4.4/autohell.patch
diff --git a/packages/python/python-2.4.3/bindir-libdir.patch b/packages/python/python-2.4.4/bindir-libdir.patch
index 27ae5dce5b..27ae5dce5b 100644
--- a/packages/python/python-2.4.3/bindir-libdir.patch
+++ b/packages/python/python-2.4.4/bindir-libdir.patch
diff --git a/packages/python/python-2.4.3/crosscompile.patch b/packages/python/python-2.4.4/crosscompile.patch
index f917bb2567..f917bb2567 100644
--- a/packages/python/python-2.4.3/crosscompile.patch
+++ b/packages/python/python-2.4.4/crosscompile.patch
diff --git a/packages/python/python-2.4.3/fix-tkinter-detection.patch b/packages/python/python-2.4.4/fix-tkinter-detection.patch
index 602aa8e021..602aa8e021 100644
--- a/packages/python/python-2.4.3/fix-tkinter-detection.patch
+++ b/packages/python/python-2.4.4/fix-tkinter-detection.patch
diff --git a/packages/python/python-2.4.3/sitebranding.patch b/packages/python/python-2.4.4/sitebranding.patch
index 85bb83a506..85bb83a506 100644
--- a/packages/python/python-2.4.3/sitebranding.patch
+++ b/packages/python/python-2.4.4/sitebranding.patch
diff --git a/packages/python/python_2.4.3.bb b/packages/python/python_2.4.4.bb
index dfa828bcd9..1a565875c8 100644
--- a/packages/python/python_2.4.3.bb
+++ b/packages/python/python_2.4.4.bb
@@ -5,7 +5,7 @@ SECTION = "devel/python"
PRIORITY = "optional"
DEPENDS = "python-native readline zlib gdbm openssl tcl tk"
DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
-PR = "ml8"
+PR = "ml0"
PYTHON_MAJMIN = "2.4"