aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/kernel.bbclass4
-rw-r--r--conf/machine/h2200.conf2
-rw-r--r--packages/bluez/bluez-dtl1-workaround_1.0.bb17
-rw-r--r--packages/bluez/bluez-utils.inc2
-rw-r--r--packages/bluez/bluez-utils_3.11.bb6
-rw-r--r--packages/bluez/bluez-utils_3.12.bb6
-rw-r--r--packages/bluez/bluez-utils_3.4.bb2
-rw-r--r--packages/bluez/bluez-utils_3.7.bb2
-rw-r--r--packages/bluez/bluez-utils_3.8.bb4
-rw-r--r--packages/udev/udev-hostap-cs-vcc-workaround_1.0.bb12
-rw-r--r--packages/udev/udev_092.bb9
-rw-r--r--packages/udev/udev_097.bb5
-rw-r--r--packages/udev/udev_100.bb9
13 files changed, 40 insertions, 40 deletions
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index 4cc3784b6f..3a95fa787a 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -183,6 +183,10 @@ ALLOW_EMPTY_kernel = "1"
ALLOW_EMPTY_kernel-base = "1"
ALLOW_EMPTY_kernel-image = "1"
+# Userspace workarounds for kernel modules issues
+# This is shame, fix the kernel instead!
+RDEPENDS_kernel-module-dtl1-cs = "bluez-dtl1-workaround"
+
pkg_postinst_kernel-image () {
if [ ! -e "$D/lib/modules/${KERNEL_VERSION}" ]; then
mkdir -p $D/lib/modules/${KERNEL_VERSION}
diff --git a/conf/machine/h2200.conf b/conf/machine/h2200.conf
index 6c43e75625..56f1d17c04 100644
--- a/conf/machine/h2200.conf
+++ b/conf/machine/h2200.conf
@@ -26,7 +26,7 @@ PCMCIA_MANAGER = "pcmciautils"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel = "linux-handhelds-2.6"
-MACHINE_EXTRA_RDEPENDS = "h2200-bootloader"
+MACHINE_EXTRA_RDEPENDS = "h2200-bootloader udev-hostap-cs-vcc-workaround"
EXTRA_IMAGECMD_jffs2 = "--pad --eraseblock=0x4000"
#
diff --git a/packages/bluez/bluez-dtl1-workaround_1.0.bb b/packages/bluez/bluez-dtl1-workaround_1.0.bb
new file mode 100644
index 0000000000..413d220508
--- /dev/null
+++ b/packages/bluez/bluez-dtl1-workaround_1.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "A nasty hack for for dtl1-cs driver to workaround suspend/resume."
+SECTION = "console"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "file://02dtl1_cs.sh"
+
+do_install() {
+ install -d ${D}${sysconfdir}/apm/event.d/
+ install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
+}
+
+#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
+FILES_${PN} += "${sysconfdir}/apm/"
+
+PACKAGE_ARCH = "all"
diff --git a/packages/bluez/bluez-utils.inc b/packages/bluez/bluez-utils.inc
index b6f9660fa7..8eb4fbfbf0 100644
--- a/packages/bluez/bluez-utils.inc
+++ b/packages/bluez/bluez-utils.inc
@@ -10,7 +10,6 @@ LICENSE = "GPL"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1 \
file://handle-eintr.patch;patch=1;status=applied"
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
install -m 0755 ${S}/daemon/.libs/passkey-agent ${D}${base_bindir}/
}
diff --git a/packages/bluez/bluez-utils_3.11.bb b/packages/bluez/bluez-utils_3.11.bb
index 2419f431f6..6cadfc1a53 100644
--- a/packages/bluez/bluez-utils_3.11.bb
+++ b/packages/bluez/bluez-utils_3.11.bb
@@ -6,9 +6,8 @@ DEPENDS += "glib-2.0"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
"
-PR = "r0"
+PR = "r1"
EXTRA_OECONF = " \
--enable-bccmd \
@@ -84,9 +83,6 @@ FILES_${PN} = " \
${base_sbindir}/hciattach \
"
-#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
-FILES_${PN} += "${sysconfdir}/apm/"
-
FILES_${PN}-dbg += " \
${libdir}/bluetooth/.debug \
"
diff --git a/packages/bluez/bluez-utils_3.12.bb b/packages/bluez/bluez-utils_3.12.bb
index e543eed649..4710aa6779 100644
--- a/packages/bluez/bluez-utils_3.12.bb
+++ b/packages/bluez/bluez-utils_3.12.bb
@@ -4,9 +4,8 @@ DEPENDS += "glib-2.0"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
"
-PR = "r2"
+PR = "r3"
EXTRA_OECONF = " \
--enable-bccmd \
@@ -82,9 +81,6 @@ FILES_${PN} = " \
${base_sbindir}/hciattach \
"
-#Package 02dtl1_cs.sh, which is a nasty hack to get dtl1c_cs cards working with suspend/resume
-FILES_${PN} += "${sysconfdir}/apm/"
-
FILES_${PN}-dbg += " \
${libdir}/bluetooth/.debug \
"
diff --git a/packages/bluez/bluez-utils_3.4.bb b/packages/bluez/bluez-utils_3.4.bb
index 49e6ded250..f2bbd15507 100644
--- a/packages/bluez/bluez-utils_3.4.bb
+++ b/packages/bluez/bluez-utils_3.4.bb
@@ -11,7 +11,6 @@ PR = "r1"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1"
# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
}
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
diff --git a/packages/bluez/bluez-utils_3.7.bb b/packages/bluez/bluez-utils_3.7.bb
index 3dbaa030c1..7a76cb3200 100644
--- a/packages/bluez/bluez-utils_3.7.bb
+++ b/packages/bluez/bluez-utils_3.7.bb
@@ -11,7 +11,6 @@ PR = "r0"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1"
# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
}
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
diff --git a/packages/bluez/bluez-utils_3.8.bb b/packages/bluez/bluez-utils_3.8.bb
index d549d12d30..f2bbd15507 100644
--- a/packages/bluez/bluez-utils_3.8.bb
+++ b/packages/bluez/bluez-utils_3.8.bb
@@ -7,11 +7,10 @@ RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils-dbus"
RREPLACES = "bluez-utils-dbus"
RCONFLICTS_${PN} = "bluez-utils-nodbus"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
file://hcid.conf \
- file://02dtl1_cs.sh \
file://hciattach-ti-bts.patch;patch=1"
# Almost all serial CF cards w/ manfid 0x0000,0x0000 seem to use the bcs protocol
@@ -41,7 +40,6 @@ do_install_append() {
rmdir ${D}${bindir} ${D}${sbindir}
chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig
install -m 0644 ${WORKDIR}/hcid.conf ${D}${sysconfdir}/bluetooth/
- install -m 0755 ${WORKDIR}/02dtl1_cs.sh ${D}${sysconfdir}/apm/event.d/
}
CONFFILES_${PN} = "${sysconfdir}/bluetooth/hcid.conf ${sysconfdir}/bluetooth/rfcomm.conf \
diff --git a/packages/udev/udev-hostap-cs-vcc-workaround_1.0.bb b/packages/udev/udev-hostap-cs-vcc-workaround_1.0.bb
new file mode 100644
index 0000000000..4076cb2dd6
--- /dev/null
+++ b/packages/udev/udev-hostap-cs-vcc-workaround_1.0.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "A hack to force VCC to 5v for hostap_cs cards. This will fry your \
+card one sweet day."
+PR = "r1"
+
+SRC_URI = " file://50-hostap_cs.rules "
+
+do_install() {
+ install -d ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${WORKDIR}/50-hostap_cs.rules ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
+}
+
+PACKAGE_ARCH = "all"
diff --git a/packages/udev/udev_092.bb b/packages/udev/udev_092.bb
index 06b18d8baa..b946b98c56 100644
--- a/packages/udev/udev_092.bb
+++ b/packages/udev/udev_092.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
RPROVIDES_${PN} = "hotplug"
-PR = "r19"
+PR = "r20"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \
@@ -14,9 +14,6 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz
file://mount.blacklist \
"
-SRC_URI_append_h2200 = " file://50-hostap_cs.rules "
-PACKAGE_ARCH_h2200 = "h2200"
-
require udev.inc
INITSCRIPT_PARAMS = "start 03 S ."
@@ -55,10 +52,6 @@ do_install () {
install -m 0755 ${WORKDIR}/udevsynthesize.sh ${D}${sbindir}/udevsynthesize
}
-do_install_append_h2200() {
- install -m 0644 ${WORKDIR}/50-hostap_cs.rules ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
-}
-
pkg_postinst_append() {
# Add the root partition to mount.blacklist to avoid a bug in the auto-mounter,
diff --git a/packages/udev/udev_097.bb b/packages/udev/udev_097.bb
index c1eff0d083..360e6019d5 100644
--- a/packages/udev/udev_097.bb
+++ b/packages/udev/udev_097.bb
@@ -8,7 +8,7 @@ used to detect the type of a file system and read its metadata."
DESCRIPTION_libvolume-id-dev = "libvolume_id development headers, \
needed to link programs with libvolume_id."
-PR = "r9"
+PR = "r10"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \
@@ -18,9 +18,6 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz
require udev.inc
-SRC_URI_append_h2200 = " file://50-hostap_cs.rules "
-PACKAGE_ARCH_h2200 = "h2200"
-
INITSCRIPT_PARAMS = "start 03 S ."
FILES_${PN} += "${base_libdir}/udev/*"
diff --git a/packages/udev/udev_100.bb b/packages/udev/udev_100.bb
index f36a75ac29..e4ef8395a6 100644
--- a/packages/udev/udev_100.bb
+++ b/packages/udev/udev_100.bb
@@ -9,7 +9,7 @@ used to detect the type of a file system and read its metadata."
DESCRIPTION_libvolume-id-dev = "libvolume_id development headers, \
needed to link programs with libvolume_id."
-PR = "r8"
+PR = "r9"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \
@@ -19,9 +19,6 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz
require udev.inc
-SRC_URI_append_h2200 = " file://50-hostap_cs.rules "
-PACKAGE_ARCH_h2200 = "h2200"
-
INITSCRIPT_PARAMS = "start 03 S ."
FILES_${PN} += "${base_libdir}/udev/*"
@@ -56,10 +53,6 @@ do_install () {
install -d ${D}${base_libdir}/udev/
}
-do_install_append_h2200() {
- install -m 0644 ${WORKDIR}/50-hostap_cs.rules ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
-}
-
pkg_postinst_append() {
# Add the root partition to mount.blacklist to avoid a bug in the auto-mounter,