aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/tune-mips32.inc1
-rw-r--r--conf/machine/stb225.conf16
-rw-r--r--packages/linux/linux-2.6.28/stb225/uImage.patch23
-rw-r--r--packages/linux/linux_2.6.28.bb3
4 files changed, 37 insertions, 6 deletions
diff --git a/conf/machine/include/tune-mips32.inc b/conf/machine/include/tune-mips32.inc
new file mode 100644
index 0000000000..93da66b158
--- /dev/null
+++ b/conf/machine/include/tune-mips32.inc
@@ -0,0 +1 @@
+TARGET_CC_ARCH = "-march=mips32"
diff --git a/conf/machine/stb225.conf b/conf/machine/stb225.conf
index 97370e1fe8..c57adb09f8 100644
--- a/conf/machine/stb225.conf
+++ b/conf/machine/stb225.conf
@@ -1,8 +1,14 @@
# PNX8335 STB225 board
+
TARGET_ARCH = "mipsel"
-TARGET_CC_ARCH="-march=mips32"
+
MACHINE_FEATURES = "kernel26"
-IMAGE_FSTYPES="tar.gz"
-PREFERRED_PROVIDER_virtual/kernel="linux"
-KERNEL_IMAGETYPE="vmlinux"
-KERNEL_OUTPUT="${KERNEL_IMAGETYPE}"
+
+IMAGE_FSTYPES += "tar.gz"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux"
+KERNEL_IMAGETYPE = "uImage"
+
+SERIAL_CONSOLE ?= "115200 ttySA0"
+
+require conf/machine/include/tune-mips32.inc
diff --git a/packages/linux/linux-2.6.28/stb225/uImage.patch b/packages/linux/linux-2.6.28/stb225/uImage.patch
new file mode 100644
index 0000000000..f43a221e62
--- /dev/null
+++ b/packages/linux/linux-2.6.28/stb225/uImage.patch
@@ -0,0 +1,23 @@
+diff -urN linux-2.6.28.orig/arch/mips/Makefile linux-2.6.28/arch/mips/Makefile
+--- linux-2.6.28.orig/arch/mips/Makefile 2009-01-28 16:12:23.000000000 +0200
++++ linux-2.6.28/arch/mips/Makefile 2009-01-28 16:13:54.000000000 +0200
+@@ -682,6 +682,19 @@
+
+ all: $(all-y)
+
++# Support for U-Boot image creation (from U-Boot README)
++uImage: vmlinux
++ $(OBJCOPY) -O binary -R .note -R .comment -S vmlinux vmlinux.bin
++ rm -f vmlinux.bin.gz
++ gzip -9 vmlinux.bin
++ LA=`$(OBJDUMP) -p vmlinux | sed -n 's/LOAD.*vaddr \([^ ]*\).*/\1/p'`; \
++ EN=`$(OBJDUMP) -f vmlinux | sed -n 's/.*start address \([^ ]*\).*/\1/p'`; \
++ echo $$LA; \
++ echo $$EN; \
++ mkimage -A mips -O linux -T kernel -C gzip \
++ -a $$LA -e $$EN -n "Linux Kernel Image" \
++ -d vmlinux.bin.gz uImage
++
+ vmlinux.bin: $(vmlinux-32)
+ +@$(call makeboot,$@)
+
diff --git a/packages/linux/linux_2.6.28.bb b/packages/linux/linux_2.6.28.bb
index e37ab9d013..393209c3be 100644
--- a/packages/linux/linux_2.6.28.bb
+++ b/packages/linux/linux_2.6.28.bb
@@ -16,6 +16,7 @@ SRC_URI_append_at91sam9263ek = " \
file://linux-2.6.28-exp.patch.bz2;patch=1 "
SRC_URI_append_stb225 = " \
+ file://uImage.patch;patch=1 \
file://ebase-fix.patch;patch=1 \
file://enable-uart.patch;patch=1 \
- file://ip3902.patch;patch=1 "
+ file://ip3902.patch;patch=1"