aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/scons.bbclass13
-rw-r--r--packages/python/python-scons-native_0.96.90.bb12
2 files changed, 25 insertions, 0 deletions
diff --git a/classes/scons.bbclass b/classes/scons.bbclass
new file mode 100644
index 0000000000..3160eca69a
--- /dev/null
+++ b/classes/scons.bbclass
@@ -0,0 +1,13 @@
+DEPENDS += "python-scons-native"
+
+scons_do_compile() {
+ ${STAGING_BINDIR}/scons || \
+ oefatal "scons build execution failed."
+}
+
+scons_do_install() {
+ ${STAGING_BINDIR}/scons install || \
+ oefatal "scons install execution failed."
+}
+
+EXPORT_FUNCTIONS do_compile do_install
diff --git a/packages/python/python-scons-native_0.96.90.bb b/packages/python/python-scons-native_0.96.90.bb
new file mode 100644
index 0000000000..bc6fc7992d
--- /dev/null
+++ b/packages/python/python-scons-native_0.96.90.bb
@@ -0,0 +1,12 @@
+include python-scons_${PV}.bb
+inherit native
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_LIBDIR}/.. --install-data=${STAGING_DATADIR} || \
+ oefatal "python setup.py install execution failed."
+}
+
+do_install() {
+ :
+}