aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/ixp4xx/ixp4xx-npe_2.1.bb9
-rw-r--r--packages/ixp4xx/ixp4xx-npe_2.3.bb7
2 files changed, 9 insertions, 7 deletions
diff --git a/packages/ixp4xx/ixp4xx-npe_2.1.bb b/packages/ixp4xx/ixp4xx-npe_2.1.bb
index fc6576569d..ca89248fbb 100644
--- a/packages/ixp4xx/ixp4xx-npe_2.1.bb
+++ b/packages/ixp4xx/ixp4xx-npe_2.1.bb
@@ -1,20 +1,21 @@
DESCRIPTION = "NPE firmware for the IXP4xx line of devices"
MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
LICENSE = "Intel Public Licence"
-PR = "r3"
+PR = "r4"
DEPENDS = "ixp4xx-npe-native"
SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_1.zip"
S = ${WORKDIR}/ixp400_xscale_sw/src/npeDl
-FILES_${PN} = "${base_libdir}/firmware/NPE-B/NPE-B.010c0200"
+FILES_${PN} = "${base_libdir}/firmware/NPE-B"
do_compile() {
${STAGING_BINDIR}/IxNpeMicrocode
}
do_install() {
- install -d ${D}/${base_libdir}/firmware/NPE-B
- install ${S}/NPE-B.010c0200 ${D}/${base_libdir}/firmware/NPE-B/
+ install -d ${D}/${base_libdir}/firmware/
+ mv ${S}/NPE-B.010c0200 ${S}/NPE-B
+ install ${S}/NPE-B ${D}/${base_libdir}/firmware/
}
diff --git a/packages/ixp4xx/ixp4xx-npe_2.3.bb b/packages/ixp4xx/ixp4xx-npe_2.3.bb
index b0b27a6f99..5cc710ab69 100644
--- a/packages/ixp4xx/ixp4xx-npe_2.3.bb
+++ b/packages/ixp4xx/ixp4xx-npe_2.3.bb
@@ -1,13 +1,13 @@
DESCRIPTION = "NPE firmware for the IXP4xx line of devices"
MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
LICENSE = "Intel Public Licence"
-PR = "r2"
+PR = "r3"
DEPENDS = "ixp4xx-npe-native"
SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_3.zip"
S = ${WORKDIR}/ixp400_xscale_sw/src/npeDl
-FILES_${PN} = "${base_libdir}/firmware/NPE-B.010c0200"
+FILES_${PN} = "${base_libdir}/firmware/NPE-B"
do_compile() {
${STAGING_BINDIR}/IxNpeMicrocode
@@ -15,6 +15,7 @@ do_compile() {
do_install() {
install -d ${D}/${base_libdir}/firmware/
- install ${S}/NPE-B.010c0200 ${D}/${base_libdir}/firmware/
+ mv ${S}/NPE-B.010c0200 ${S}/NPE-B
+ install ${S}/NPE-B ${D}/${base_libdir}/firmware/
}