aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libxvmc/libxvmc_20040918.oe27
-rw-r--r--libxvmc/libxvmc_20040919.oe0
-rw-r--r--libxvmc/via.patch23
3 files changed, 23 insertions, 27 deletions
diff --git a/libxvmc/libxvmc_20040918.oe b/libxvmc/libxvmc_20040918.oe
deleted file mode 100644
index 0cfc2326d1..0000000000
--- a/libxvmc/libxvmc_20040918.oe
+++ /dev/null
@@ -1,27 +0,0 @@
-SECTION = "x11/libs"
-DEPENDS = "x11 xext libxv drm"
-DESCRIPTION = "X Video Motion Compensation extension library."
-
-SRC_URI = "cvs://anoncvs@cvs.freedesktop.org/cvs/xlibs;module=XvMC;date=20040918;method=pserver \
- cvs://anonymous@cvs.sourceforge.net/cvsroot/unichrome;module=libxvmc;date=20040918;method=pserver"
-S = "${WORKDIR}/XvMC"
-
-CFLAGS += "-I${STAGING_INCDIR}/X11/extensions -I${STAGING_INCDIR}/xserver-xorg"
-
-inherit autotools pkgconfig
-
-do_configure_prepend() {
- install -d ${S}/hw/via
- cp ${WORKDIR}/libxvmc/*.[ch] ${S}/hw/via/
-}
-
-do_stage() {
- oe_runmake install prefix=${STAGING_DIR} \
- bindir=${STAGING_BINDIR} \
- includedir=${STAGING_INCDIR} \
- libdir=${STAGING_LIBDIR} \
- datadir=${STAGING_DATADIR} \
- mandir=${STAGING_DATADIR}/man
- oe_libinstall -so -C hw/via libviaXvMC ${STAGING_LIBDIR}
- install hw/via/vldXvMC.h ${STAGING_INCDIR}
-}
diff --git a/libxvmc/libxvmc_20040919.oe b/libxvmc/libxvmc_20040919.oe
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/libxvmc/libxvmc_20040919.oe
diff --git a/libxvmc/via.patch b/libxvmc/via.patch
index e69de29bb2..1451bfded0 100644
--- a/libxvmc/via.patch
+++ b/libxvmc/via.patch
@@ -0,0 +1,23 @@
+--- XvMC/configure.ac.old 2004-09-18 13:16:31.000000000 +0100
++++ XvMC/configure.ac 2004-09-18 13:16:32.000000000 +0100
+@@ -14,4 +14,5 @@
+ AC_OUTPUT([Makefile
+ hw/Makefile
+ hw/i810/Makefile
++ hw/via/Makefile
+ xvmc.pc])
+--- /dev/null 2004-06-13 02:32:19.000000000 +0100
++++ XvMC/hw/via/Makefile.am 2004-09-18 13:16:01.000000000 +0100
+@@ -0,0 +1,7 @@
++AM_CFLAGS = $(XVMC_CFLAGS)
++libviaXvMC_la_LIBADD = $(XVMC_LIBS)
++
++lib_LTLIBRARIES = libviaXvMC.la
++
++libviaXvMC_la_SOURCES = viaXvMC.c viaXvMC.h viaLowLevel.c viaLowLevel.h \
++ viaXvMCPriv.h
+--- XvMC/hw/Makefile.am.old 2004-10-17 22:34:27.000000000 +0100
++++ XvMC/hw/Makefile.am 2004-10-17 22:34:31.000000000 +0100
+@@ -1 +1 @@
+-SUBDIRS = i810
++SUBDIRS = i810 via