aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/fuse/gmailfs_0.6.bb22
-rw-r--r--packages/python/python-libgmail_0.1.3.3.bb20
2 files changed, 42 insertions, 0 deletions
diff --git a/packages/fuse/gmailfs_0.6.bb b/packages/fuse/gmailfs_0.6.bb
new file mode 100644
index 0000000000..fbac857024
--- /dev/null
+++ b/packages/fuse/gmailfs_0.6.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GmailFS provides a mountable Linux filesystem which uses your Gmail account as its storage medium."
+HOMEPAGE = "http://richard.jones.name/google-hacks/gmail-filesystem/gmail-filesystem.html"
+MAINTAINER = "koen Kooi <koen@handhelds.org>"
+LICENSE = "GPL"
+
+DEPENDS = "fuse libgmail python-fuse"
+RDEPENDS = "fuse libgmail python-fuse python-unixadmin python-lang python-textutils python-core"
+
+SRC_URI = "http://richard.jones.name/google-hacks/gmail-filesystem/gmailfs-0.6.tar.gz"
+
+
+do_install() {
+install -d ${D}${datadir}/gmailfs
+install -d ${D}${bindir}
+install -d ${D}${sysconfdir}
+
+install -m 755 ${S}/gmailfs.py ${D}${datadir}/gmailfs/
+install -m 755 ${S}/mount.gmailfs ${D}${bindir}
+install -m 644 ${S}/*.conf ${D}${sysconfdir}
+
+}
+
diff --git a/packages/python/python-libgmail_0.1.3.3.bb b/packages/python/python-libgmail_0.1.3.3.bb
new file mode 100644
index 0000000000..f7d91f3748
--- /dev/null
+++ b/packages/python/python-libgmail_0.1.3.3.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Python Bindings for Google's Gmail Service"
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "python-core python-netclient python-email python-mime python-pprint python-re python-pickle"
+SRCNAME = "libgmail"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils-base
+
+do_install() {
+ install -d ${D}${libdir}/${PYTHON_DIR}
+ for file in *.py
+ do
+ install -m 0755 ${file} ${D}${libdir}/${PYTHON_DIR}
+ done
+}