aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xcontrib/angstrom/build-release.sh10
-rw-r--r--packages/gnome-mplayer/files/non-utf8-id3-fallback.patch22
-rw-r--r--packages/gnome-mplayer/files/uchar-for-utf8-check.patch22
-rw-r--r--packages/gnome-mplayer/gnome-mplayer_0.5.3.bb6
-rw-r--r--packages/gnome-mplayer/gnome-mplayer_cvs.bb6
-rw-r--r--packages/linux/linux-omap2-git/omap2430sdp/.mtn2git_empty (renamed from packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/.mtn2git_empty)0
-rw-r--r--packages/linux/linux-omap2-git/omap2430sdp/defconfig (renamed from packages/linux/linux-omap2-git/defconfig)0
-rw-r--r--packages/linux/linux-omap2-git/omap2430sdp/defconfig.eabi (renamed from packages/linux/linux-omap2-git/defconfig.eabi)0
-rw-r--r--packages/xcursor-transparent-theme/files/.mtn2git_empty0
-rw-r--r--packages/xcursor-transparent-theme/files/fix_watch_cursor.patch (renamed from packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/fix_watch_cursor.patch)0
-rw-r--r--packages/xcursor-transparent-theme/files/use-relative-symlinks.patch (renamed from packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch)0
-rw-r--r--packages/xcursor-transparent-theme/xcursor-watchonly-theme_0.1.1.bb15
12 files changed, 75 insertions, 6 deletions
diff --git a/contrib/angstrom/build-release.sh b/contrib/angstrom/build-release.sh
index 3c0bda25fe..2f882450c8 100755
--- a/contrib/angstrom/build-release.sh
+++ b/contrib/angstrom/build-release.sh
@@ -1,6 +1,6 @@
#!/bin/bash
-DO_UCLIBC=0
+DO_UCLIBC=1
do_build() {
echo "MACHINE = \"$BUILD_MACHINE\"" > conf/auto.conf
@@ -20,6 +20,12 @@ do_build() {
then
BUILD_MODE="uclibc"
echo 'ANGSTROM_MODE = "uclibc"' >> conf/auto.conf
+
+ if [ "$BUILD_CLEAN" != "" ]
+ then
+ bitbake -c clean $BUILD_CLEAN
+ fi
+
for target in $BUILD_TARGETS
do
bitbake $target && do_report_success
@@ -43,7 +49,7 @@ do_report_success() {
# No graphics
-for machine in ep93xx gumstix-connex gumstix-verdex efika omap5912osk
+for machine in ep93xx gumstix-connex gumstix-verdex efika dht-walnut omap5912osk
do
BUILD_MACHINE=$machine
BUILD_CLEAN="libtool-cross base-files"
diff --git a/packages/gnome-mplayer/files/non-utf8-id3-fallback.patch b/packages/gnome-mplayer/files/non-utf8-id3-fallback.patch
new file mode 100644
index 0000000000..3b13bf0015
--- /dev/null
+++ b/packages/gnome-mplayer/files/non-utf8-id3-fallback.patch
@@ -0,0 +1,22 @@
+I found that on ARM/glibc 2.5/glib 2.12.something test in strip_unicode() doesn't
+really catch invalid utf-8 chars. Also, let's tell user where problem lies straight.
+
+Paul Sokolovsky <pmiscml@gmail.com>
+--- a/src/thread.c.org 2007-12-24 00:10:15.000000000 +0200
++++ a/src/thread.c 2008-01-04 22:04:30.000000000 +0200
+@@ -349,13 +349,11 @@
+ //g_idle_add(set_media_info, idledata);
+ utf8name = g_locale_to_utf8(parse[name],-1, NULL, NULL,NULL);
+ if (utf8name == NULL) {
+- strip_unicode(parse[name],strlen(parse[name]));
+- utf8name = g_strdup(parse[name]);
++ utf8name = g_strdup("<cannot convert to utf-8>");
+ }
+ utf8artist = g_locale_to_utf8(parse[artist],-1, NULL, NULL,NULL);
+ if (utf8artist == NULL) {
+- strip_unicode(parse[artist],strlen(parse[artist]));
+- utf8artist = g_strdup(parse[artist]);
++ utf8artist = g_strdup("<cannot convert to utf-8>");
+ }
+
+ message = g_markup_printf_escaped(_("<small>\n<b>Title:</b>\t%s\n<b>Artist:</b>\t%s\n<b>File:</b>\t%s\n</small>"),utf8name,utf8artist,idledata->info);
diff --git a/packages/gnome-mplayer/files/uchar-for-utf8-check.patch b/packages/gnome-mplayer/files/uchar-for-utf8-check.patch
new file mode 100644
index 0000000000..f19d20716e
--- /dev/null
+++ b/packages/gnome-mplayer/files/uchar-for-utf8-check.patch
@@ -0,0 +1,22 @@
+--- a/src/support.c.org 2007-12-18 20:39:09.000000000 +0200
++++ a/src/support.c 2008-01-04 22:12:32.000000000 +0200
+@@ -24,7 +24,7 @@
+
+ #include "support.h"
+
+-void strip_unicode(gchar * data, gsize len)
++void strip_unicode(guchar * data, gsize len)
+ {
+ gsize i = 0;
+
+--- a/src/support.h.org 2007-12-17 18:21:46.000000000 +0200
++++ a/src/support.h 2008-01-04 22:24:15.000000000 +0200
+@@ -31,7 +31,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+
+-void strip_unicode(gchar * data, gsize len);
++void strip_unicode(guchar * data, gsize len);
+ gint play_file(gchar * filename, gint playlist);
+ gint detect_playlist(gchar * filename);
+ gint parse_playlist(gchar * filename);
diff --git a/packages/gnome-mplayer/gnome-mplayer_0.5.3.bb b/packages/gnome-mplayer/gnome-mplayer_0.5.3.bb
index 62533441c7..c01152cfb8 100644
--- a/packages/gnome-mplayer/gnome-mplayer_0.5.3.bb
+++ b/packages/gnome-mplayer/gnome-mplayer_0.5.3.bb
@@ -3,10 +3,12 @@ HOMEPAGE = "http://dekorte.homeip.net/download/gnome-mplayer/"
LICENSE = "GPL"
DEPENDS = "gtk+ gconf dbus-glib"
RDEPENDS = "mplayer"
-PR = "r2"
+PR = "r3"
inherit autotools pkgconfig gconf
SRC_URI = "http://dekorte.homeip.net/download/${PN}/${P}.tar.gz \
file://ac-gthread.patch;patch=1 \
- file://1.patch;patch=1"
+ file://1.patch;patch=1 \
+ file://uchar-for-utf8-check.patch;patch=1 \
+ file://non-utf8-id3-fallback.patch;patch=1"
diff --git a/packages/gnome-mplayer/gnome-mplayer_cvs.bb b/packages/gnome-mplayer/gnome-mplayer_cvs.bb
index ce0c445048..fe9daabfa0 100644
--- a/packages/gnome-mplayer/gnome-mplayer_cvs.bb
+++ b/packages/gnome-mplayer/gnome-mplayer_cvs.bb
@@ -5,7 +5,7 @@ DEPENDS = "gtk+ gconf dbus-glib"
RDEPENDS = "mplayer"
SRCDATE = "20080101"
PV = "0.5.3+cvs${SRCDATE}"
-PR = "r2"
+PR = "r3"
inherit autotools pkgconfig gconf
@@ -13,4 +13,6 @@ S = "${WORKDIR}/${PN}"
SRC_URI = "cvs://anonymous@dekorte.homeip.net/data/cvs;module=${PN} \
file://ac-gthread.patch;patch=1 \
- file://1.patch;patch=1"
+ file://1.patch;patch=1 \
+ file://uchar-for-utf8-check.patch;patch=1 \
+ file://non-utf8-id3-fallback.patch;patch=1"
diff --git a/packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/.mtn2git_empty b/packages/linux/linux-omap2-git/omap2430sdp/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/.mtn2git_empty
+++ b/packages/linux/linux-omap2-git/omap2430sdp/.mtn2git_empty
diff --git a/packages/linux/linux-omap2-git/defconfig b/packages/linux/linux-omap2-git/omap2430sdp/defconfig
index f3897e48a3..f3897e48a3 100644
--- a/packages/linux/linux-omap2-git/defconfig
+++ b/packages/linux/linux-omap2-git/omap2430sdp/defconfig
diff --git a/packages/linux/linux-omap2-git/defconfig.eabi b/packages/linux/linux-omap2-git/omap2430sdp/defconfig.eabi
index f3897e48a3..f3897e48a3 100644
--- a/packages/linux/linux-omap2-git/defconfig.eabi
+++ b/packages/linux/linux-omap2-git/omap2430sdp/defconfig.eabi
diff --git a/packages/xcursor-transparent-theme/files/.mtn2git_empty b/packages/xcursor-transparent-theme/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xcursor-transparent-theme/files/.mtn2git_empty
diff --git a/packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/fix_watch_cursor.patch b/packages/xcursor-transparent-theme/files/fix_watch_cursor.patch
index 73a5b2a87a..73a5b2a87a 100644
--- a/packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/fix_watch_cursor.patch
+++ b/packages/xcursor-transparent-theme/files/fix_watch_cursor.patch
diff --git a/packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch b/packages/xcursor-transparent-theme/files/use-relative-symlinks.patch
index df28dfbc88..df28dfbc88 100644
--- a/packages/xcursor-transparent-theme/xcursor-transparent-theme-0.1.1/use-relative-symlinks.patch
+++ b/packages/xcursor-transparent-theme/files/use-relative-symlinks.patch
diff --git a/packages/xcursor-transparent-theme/xcursor-watchonly-theme_0.1.1.bb b/packages/xcursor-transparent-theme/xcursor-watchonly-theme_0.1.1.bb
new file mode 100644
index 0000000000..e9e6479daf
--- /dev/null
+++ b/packages/xcursor-transparent-theme/xcursor-watchonly-theme_0.1.1.bb
@@ -0,0 +1,15 @@
+LICENSE = "GPL"
+DESCRIPTION = "Transparent xcursor theme for handheld systems with visible watch cursor"
+SECTION = "x11/base"
+RREPLACES = "xcursor-transparent-theme"
+RPROVIDES = "xcursor-transparent-theme"
+PR="r2"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/utils/xcursor-transparent-theme-${PV}.tar.gz \
+ file://use-relative-symlinks.patch;patch=1 \
+ file://skip_watch_cursor.patch;patch=1"
+S = "${WORKDIR}/xcursor-transparent-theme-${PV}"
+
+FILES_${PN} = "${datadir}/icons/xcursor-transparent/cursors/*"
+
+inherit autotools