aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch0
-rw-r--r--packages/gnutls/gnutls_1.0.23.bb26
-rw-r--r--packages/sylpheed/files/sylpheed-gnutls.patch0
-rw-r--r--packages/sylpheed/sylpheed_1.0.0-gtk2-20041224.bb28
4 files changed, 54 insertions, 0 deletions
diff --git a/packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch b/packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnutls/gnutls-1.0.23/gnutls-openssl.patch
diff --git a/packages/gnutls/gnutls_1.0.23.bb b/packages/gnutls/gnutls_1.0.23.bb
index e69de29bb2..d2453b5056 100644
--- a/packages/gnutls/gnutls_1.0.23.bb
+++ b/packages/gnutls/gnutls_1.0.23.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GNU Transport Layer Security Library"
+DEPENDS = "zlib libgcrypt"
+PR = "r2"
+
+LICENSE = "LGPL"
+
+SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.gz \
+ file://gnutls-openssl.patch;patch=1"
+
+inherit autotools
+
+PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
+FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
+FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
+FILES_${PN} = "${libdir}/libgnutls.so.*"
+FILES_${PN}-bin = "${bindir}/gnutls-serv ${bindir}/gnutls-cli \
+ ${bindir}/srptool ${bindir}/certtool ${bindir}/gnutls-srpcrypt"
+FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
+
+do_stage() {
+ oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
+
diff --git a/packages/sylpheed/files/sylpheed-gnutls.patch b/packages/sylpheed/files/sylpheed-gnutls.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/sylpheed/files/sylpheed-gnutls.patch
diff --git a/packages/sylpheed/sylpheed_1.0.0-gtk2-20041224.bb b/packages/sylpheed/sylpheed_1.0.0-gtk2-20041224.bb
index e69de29bb2..e3b44c09f3 100644
--- a/packages/sylpheed/sylpheed_1.0.0-gtk2-20041224.bb
+++ b/packages/sylpheed/sylpheed_1.0.0-gtk2-20041224.bb
@@ -0,0 +1,28 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme gnutls"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sylpheed-gtk2/sylpheed-${PV}.tar.gz \
+ file://sylpheed-gnutls.patch;patch=1"
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+FILES_${PN}-doc += "${datadir}"
+
+EXTRA_OECONF = "--with-gnutls"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed.png ${D}${datadir}/pixmaps/
+}
+