aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/bridge-utils/bridge-utils_1.0.4.bb19
-rw-r--r--packages/rxvt-unicode/rxvt-unicode_4.9.bb54
2 files changed, 73 insertions, 0 deletions
diff --git a/packages/bridge-utils/bridge-utils_1.0.4.bb b/packages/bridge-utils/bridge-utils_1.0.4.bb
index e69de29bb2..d4d26058c9 100644
--- a/packages/bridge-utils/bridge-utils_1.0.4.bb
+++ b/packages/bridge-utils/bridge-utils_1.0.4.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Tools for ethernet bridging."
+HOMEPAGE = "http://bridge.sourceforge.net/"
+SECTION = "console/network"
+LICENSE = "GPL"
+DEPENDS = "sysfsutils"
+RRECOMMENDS = "kernel-module-bridge"
+SRC_URI = "${SOURCEFORGE_MIRROR}/bridge/bridge-utils-${PV}.tar.gz"
+S = "${WORKDIR}/bridge-utils-${PV}"
+
+# The default sourceforge mirror does not yet have this package, and
+# sourceforge redirects on the file missing so wget doesn't realize it failed.
+# Force our own default here, since its known to have it.
+PREMIRRORS_prepend () {
+ ${SOURCEFORGE_MIRROR} http://unc.dl.sourceforge.net/sourceforge
+}
+
+inherit autotools
+
+EXTRA_OECONF = "--with-linux-headers=${STAGING_INCDIR}"
diff --git a/packages/rxvt-unicode/rxvt-unicode_4.9.bb b/packages/rxvt-unicode/rxvt-unicode_4.9.bb
index e69de29bb2..61582491d5 100644
--- a/packages/rxvt-unicode/rxvt-unicode_4.9.bb
+++ b/packages/rxvt-unicode/rxvt-unicode_4.9.bb
@@ -0,0 +1,54 @@
+SECTION = "x11/utils"
+DEPENDS = "x11 xt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}