summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/xorg-lib/libx11-1.1.5/configure.ac-nios2.patch33
-rw-r--r--recipes/xorg-lib/libx11-1.3.2/configure.ac-nios2.patch33
-rw-r--r--recipes/xorg-lib/libx11-1.3.6/configure.ac-nios2.patch33
-rw-r--r--recipes/xorg-lib/libx11-1.3.99.903/configure.ac-nios2.patch33
-rw-r--r--recipes/xorg-lib/libx11_1.1.5.bb3
-rw-r--r--recipes/xorg-lib/libx11_1.3.2.bb3
-rw-r--r--recipes/xorg-lib/libx11_1.3.6.bb3
-rw-r--r--recipes/xorg-lib/libx11_1.3.99.903.bb3
8 files changed, 140 insertions, 4 deletions
diff --git a/recipes/xorg-lib/libx11-1.1.5/configure.ac-nios2.patch b/recipes/xorg-lib/libx11-1.1.5/configure.ac-nios2.patch
new file mode 100644
index 0000000000..2e2d475acb
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.1.5/configure.ac-nios2.patch
@@ -0,0 +1,33 @@
+From affc2488a7f2660a74dc8354fc3e0bff2c4f879c Mon Sep 17 00:00:00 2001
+From: Dan Nicholson <dbn.lists@gmail.com>
+Date: Sat, 06 Nov 2010 21:58:09 +0000
+Subject: config: Fix architecture check for OS/2 to skip nios2 cpu
+
+The OS/2 platform requires some utility functions as well as having a
+non-32 bit wchar_t. Fix the configure check so that it doesn't also
+affect the nios2 cpu, which wouldn't influence these operating system
+issues.
+
+Signed-off-by: Dan Nicholson <dbn.lists@gmail.com>
+Tested-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
+Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+Reviewed-by: Julien Cristau <jcristau@debian.org>
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+diff --git a/configure.ac b/configure.ac
+index 1b4a8b7..01f43fb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -246,8 +246,8 @@ dnl AC_PATH_XTRA
+
+ # arch specific things
+ WCHAR32="1"
+-case $target_alias in
+- *os2*) os2="true" ; WCHAR32="0" ;;
++case $target_os in
++ os2*) os2="true" ; WCHAR32="0" ;;
+ *) ;;
+ esac
+ AC_SUBST(WCHAR32)
+--
+cgit v0.8.3-6-g21f6
diff --git a/recipes/xorg-lib/libx11-1.3.2/configure.ac-nios2.patch b/recipes/xorg-lib/libx11-1.3.2/configure.ac-nios2.patch
new file mode 100644
index 0000000000..2e2d475acb
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.3.2/configure.ac-nios2.patch
@@ -0,0 +1,33 @@
+From affc2488a7f2660a74dc8354fc3e0bff2c4f879c Mon Sep 17 00:00:00 2001
+From: Dan Nicholson <dbn.lists@gmail.com>
+Date: Sat, 06 Nov 2010 21:58:09 +0000
+Subject: config: Fix architecture check for OS/2 to skip nios2 cpu
+
+The OS/2 platform requires some utility functions as well as having a
+non-32 bit wchar_t. Fix the configure check so that it doesn't also
+affect the nios2 cpu, which wouldn't influence these operating system
+issues.
+
+Signed-off-by: Dan Nicholson <dbn.lists@gmail.com>
+Tested-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
+Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+Reviewed-by: Julien Cristau <jcristau@debian.org>
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+diff --git a/configure.ac b/configure.ac
+index 1b4a8b7..01f43fb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -246,8 +246,8 @@ dnl AC_PATH_XTRA
+
+ # arch specific things
+ WCHAR32="1"
+-case $target_alias in
+- *os2*) os2="true" ; WCHAR32="0" ;;
++case $target_os in
++ os2*) os2="true" ; WCHAR32="0" ;;
+ *) ;;
+ esac
+ AC_SUBST(WCHAR32)
+--
+cgit v0.8.3-6-g21f6
diff --git a/recipes/xorg-lib/libx11-1.3.6/configure.ac-nios2.patch b/recipes/xorg-lib/libx11-1.3.6/configure.ac-nios2.patch
new file mode 100644
index 0000000000..2e2d475acb
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.3.6/configure.ac-nios2.patch
@@ -0,0 +1,33 @@
+From affc2488a7f2660a74dc8354fc3e0bff2c4f879c Mon Sep 17 00:00:00 2001
+From: Dan Nicholson <dbn.lists@gmail.com>
+Date: Sat, 06 Nov 2010 21:58:09 +0000
+Subject: config: Fix architecture check for OS/2 to skip nios2 cpu
+
+The OS/2 platform requires some utility functions as well as having a
+non-32 bit wchar_t. Fix the configure check so that it doesn't also
+affect the nios2 cpu, which wouldn't influence these operating system
+issues.
+
+Signed-off-by: Dan Nicholson <dbn.lists@gmail.com>
+Tested-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
+Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+Reviewed-by: Julien Cristau <jcristau@debian.org>
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+diff --git a/configure.ac b/configure.ac
+index 1b4a8b7..01f43fb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -246,8 +246,8 @@ dnl AC_PATH_XTRA
+
+ # arch specific things
+ WCHAR32="1"
+-case $target_alias in
+- *os2*) os2="true" ; WCHAR32="0" ;;
++case $target_os in
++ os2*) os2="true" ; WCHAR32="0" ;;
+ *) ;;
+ esac
+ AC_SUBST(WCHAR32)
+--
+cgit v0.8.3-6-g21f6
diff --git a/recipes/xorg-lib/libx11-1.3.99.903/configure.ac-nios2.patch b/recipes/xorg-lib/libx11-1.3.99.903/configure.ac-nios2.patch
new file mode 100644
index 0000000000..2e2d475acb
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.3.99.903/configure.ac-nios2.patch
@@ -0,0 +1,33 @@
+From affc2488a7f2660a74dc8354fc3e0bff2c4f879c Mon Sep 17 00:00:00 2001
+From: Dan Nicholson <dbn.lists@gmail.com>
+Date: Sat, 06 Nov 2010 21:58:09 +0000
+Subject: config: Fix architecture check for OS/2 to skip nios2 cpu
+
+The OS/2 platform requires some utility functions as well as having a
+non-32 bit wchar_t. Fix the configure check so that it doesn't also
+affect the nios2 cpu, which wouldn't influence these operating system
+issues.
+
+Signed-off-by: Dan Nicholson <dbn.lists@gmail.com>
+Tested-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
+Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+Reviewed-by: Julien Cristau <jcristau@debian.org>
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+diff --git a/configure.ac b/configure.ac
+index 1b4a8b7..01f43fb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -246,8 +246,8 @@ dnl AC_PATH_XTRA
+
+ # arch specific things
+ WCHAR32="1"
+-case $target_alias in
+- *os2*) os2="true" ; WCHAR32="0" ;;
++case $target_os in
++ os2*) os2="true" ; WCHAR32="0" ;;
+ *) ;;
+ esac
+ AC_SUBST(WCHAR32)
+--
+cgit v0.8.3-6-g21f6
diff --git a/recipes/xorg-lib/libx11_1.1.5.bb b/recipes/xorg-lib/libx11_1.1.5.bb
index e7755854f0..b44dcc8265 100644
--- a/recipes/xorg-lib/libx11_1.1.5.bb
+++ b/recipes/xorg-lib/libx11_1.1.5.bb
@@ -1,7 +1,8 @@
require libx11.inc
DEPENDS = "${COMMON_DEPENDS}"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
+SRC_URI += " file://configure.ac-nios2.patch"
SRC_URI[archive.md5sum] = "d1512d65dadd4f48c779d4749e7753a8"
SRC_URI[archive.sha256sum] = "da9272900e41615e9c5dc25d84730b8966da6f5c8f4c40418dca2ad040fc8b82"
diff --git a/recipes/xorg-lib/libx11_1.3.2.bb b/recipes/xorg-lib/libx11_1.3.2.bb
index b3d48aba9f..189d1ffdfe 100644
--- a/recipes/xorg-lib/libx11_1.3.2.bb
+++ b/recipes/xorg-lib/libx11_1.3.2.bb
@@ -1,10 +1,11 @@
require libx11.inc
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
# gcc 4.5 ends up ICEing with thumb and -O1 with -fno-omit-framepointer
# therefore if we are in thumb mode then we use -Os instead of -O1 for
# DEBUG_OPTIMIZATION
DEBUG_OPTIMIZATION_thumb_append = " -Os"
SRC_URI += " file://dolt-fix.patch"
+SRC_URI += " file://configure.ac-nios2.patch"
SRC_URI[archive.md5sum] = "001d780829f936e34851ef7cd37b4dfd"
SRC_URI[archive.sha256sum] = "4def4d5c9fce85d690f1f29d675154594acdea3d3fe792d0cb513732c7b4bcb2"
diff --git a/recipes/xorg-lib/libx11_1.3.6.bb b/recipes/xorg-lib/libx11_1.3.6.bb
index 625f9065b2..8d9f343948 100644
--- a/recipes/xorg-lib/libx11_1.3.6.bb
+++ b/recipes/xorg-lib/libx11_1.3.6.bb
@@ -1,6 +1,7 @@
require libx11.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI += " file://dolt-fix.patch"
+SRC_URI += " file://configure.ac-nios2.patch"
SRC_URI[archive.md5sum] = "8e0a8a466aa78f66e09fe06cb395319f"
SRC_URI[archive.sha256sum] = "599826765c59a98b1e58b4f6c4ad50dca69eeb0e7bd78aea736ca815f45bea40"
diff --git a/recipes/xorg-lib/libx11_1.3.99.903.bb b/recipes/xorg-lib/libx11_1.3.99.903.bb
index 65ff63c9a2..5ea3291bdc 100644
--- a/recipes/xorg-lib/libx11_1.3.99.903.bb
+++ b/recipes/xorg-lib/libx11_1.3.99.903.bb
@@ -2,7 +2,8 @@ require libx11.inc
#--without-xcb is not an option anymore
#http://cgit.freedesktop.org/xorg/lib/libX11/commit/?id=15e5eaf62897b3179d1fbe457cb19f886f0449f8
DEPENDS_virtclass-native = "libxcb-native ${COMMON_DEPENDS}"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
+SRC_URI += " file://configure.ac-nios2.patch"
SRC_URI[archive.md5sum] = "3e8ed7a91f70bb819b5dab9c124a7062"
SRC_URI[archive.sha256sum] = "50205aad0646c0ab13aff8e8eaec7c5cddff416d3a012f83c5661ad98e49736f"